Re: PiDV, AMBEserver and Buster


 

You probably need to build AMBEserver it is not on the standard repositories. 



On Wed, Apr 22, 2020, 19:25 Mechanical_Mac <c.g.macarthur@...> wrote:
Thanks John, I really appreciate your assistance.

The PIDV is definitely installed correctly on the Raspberry Pi, starting at PIN 1.
I always start with a fresh install of the latest version of Raspbian, now Buster.
I didn't get very far. The following steps were done sequentially.

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install ambeserver
e:  unable to locate package ambeserver

I searched the raspbian package list for ambeserver without success. 

Any suggestions?
 
Colin
Colin G. MacArthur B.A., LL.B.


On Wed, Apr 22, 2020 at 1:01 AM John D Hays - K7VE <john@...> wrote:
You need to take a step wise approach to debug:

1. Make sure the HAT is properly seated.  

Orient it so that it is sitting on pins 1-26, here is an illustration on a 40 pin GPIO Raspberry Pi
image.png

Use a current version of Raspbian (Compass Linux is deprecated)
Build/Install ambeserver
Do Not Start amberserver until you confirm that the PiDV is communicating with the Raspberry Pi

Use the test program from 
sudo python AMBEtest3.py -i /dev/ttyS0

If this fails, then you may have a hardware problem.  On success, then test in foreground (not as daemon, don't use systemctl yet)

sudo AMBEserver -i /dev/ttyS0

Watch for errors, and then open a second terminal window and use:

python ambesocktest.py

If the ambesocktest works, then you can kill the AMBEserver and restart it with systemctl.
My lab is down at the moment so I am unable to do hands on build and document.  

--
John D. Hays
Kingston, WA
K7VE

 

Join ambe@nw-digital-radio.groups.io to automatically receive all group messages.