Re: ThumbDV on Ubuntu 20.04 Focal Fossa


 

Hi John,

This looks like a permissions problem.  Try running the python script to test the ThumbDV™ directly (no AMBEserver running).  If that works, then run AMBEserver in the foreground (no daemon) as that may give more clues.  Finally, make sure the created process user (probably root for daemon) is in the dialout group (based on the error).  Make sure chgrp is in /bin or if Ubuntu moved it.


On Fri, Apr 24, 2020 at 10:46 AM John Spoonhower <jpspoonhower@...> wrote:
I am working on installing  a thumbDV on a current release Ubuntu machine. I have followed the instructions John provided "Quick Build on Linux" but I have run into problem(s).
The download and compilation of the source file goes OK.
Likewise the installation of the executable and support files look like it went OK.
I have edited the file ambeserver-ttyUSB0.conf to look like:
#
# Configuration file for the AMBEserver program started by systemd.
# Adding flags to AMBESERVER_FLAGS will pass this to the daemon.
# For example, to change the speed to 460800, use the following line:
# AMBESERVER_FLAGS="-s 460800"
#

UDP_PORT=2460
# AMBESERVER_FLAGS=""
AMBESERVER_FLAGS="-s 460800"

When I start the service I get error messages:
sudo systemctl status ambeserver@...
● ambeserver@... - DV3000 Daemon
     Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Fri 2020-04-24 13:28:07 EDT; 33s ago
    Process: 111775 ExecStartPre=/bin/chgrp dialout /dev/ttyUSB0 (code=exited, status=217/USER)

Apr 24 13:28:07 ubuntu1 systemd[1]: Starting DV3000 Daemon...
Apr 24 13:28:07 ubuntu1 systemd[111775]: ambeserver@...: Failed to determine user credentials: N>
Apr 24 13:28:07 ubuntu1 systemd[111775]: ambeserver@...: Failed at step USER spawning /bin/chgrp>
Apr 24 13:28:07 ubuntu1 systemd[1]: ambeserver@...: Control process exited, code=exited, status=>
Apr 24 13:28:07 ubuntu1 systemd[1]: ambeserver@...: Failed with result 'exit-code'.
Apr 24 13:28:07 ubuntu1 systemd[1]: Failed to start DV3000 Daemon.
Apr 24 13:28:07 ubuntu1 systemd[1]: ambeserver@...: Triggering OnFailure= dependencies.

I am not sure what's going on. Looking foe some guidance!
73,
John, NX2I



--
John D. Hays
Kingston, WA
K7VE

 

Join ambe@nw-digital-radio.groups.io to automatically receive all group messages.