Re: Just received ThumbDV and need ThumbTest doesn't see it #thumbdv


Gwen Patton
 

Maybe the dock isn't properly powering the ThumbDV? I have my ThumbDV on a RasPi III with a powered hub attached. It absolutely will not work on an unpowered hub, or one that has too little power. The port on the RasPi has USB power, but it isn't ENOUGH power. So I have to use a powered hub with plenty of juice. I could run it on my Android phone directly with an OTG cable, but the battery drain was terrible, and I couldn't find a way to run it OTG *and* charge the phone at the same time. So I set it up on the powered hub on a RasPi, with a dynamic DNS connection to a subdomain I got from the dynamic DNS provider. I can access it from anywhere, including on my phone, when away from home, either 4G or WiFi or over the Ethernet LAN at home.

I suspect your dock isn't supplying enough amperage for it. I've seen docks and dongles that you'd think were powered, but really weren't -- all they did was just split the port you plugged them into, and didn't supply any additional power, basically an UNpowered hub. So that'd be my first test -- use a hub with an actual wall wart going to mains power and see if it works better. You could plug the powered hub into the dock and if it works, leave it there.

-=-=-=-=-=-=-=-=-
73,
Gwen, NG3P


On Wed, Apr 29, 2020 at 11:35 AM David Dennis <dave@...> wrote:

I assume the ThumbDV is using an FTDI device for the USB to Serial conversion. 

I’ve noticed similar issues when not plugged directly into the PC.   This is compared to a Powered Hub.   I’m starting to be suspect of the FTDI driver.    My guess is the driver may not be forgiving of some timing issue that is made worse when connected through a hub.   But that is just a wild guess.

 

Dave

 

 

From: ambe@nw-digital-radio.groups.io <ambe@nw-digital-radio.groups.io> On Behalf Of Dave Slotter, W3DJS
Sent: Tuesday, April 28, 2020 3:50 PM
To: ambe@nw-digital-radio.groups.io Notification <ambe@nw-digital-radio.groups.io>
Subject: Re: [ambe] Just received ThumbDV and need ThumbTest doesn't see it #thumbdv

 

HAH! That was it!

 

Connecting the ThumbDV directly to the laptop's embedded USB port works. Connecting it to a Dell laptop dock (powered) does not.

 

Of course, that's terribly frustrating. The point of the dock is to avoid plugging in / unplugging equipment.

 

Any idea how to solve this?

 

73,

 

On Tue, Apr 28, 2020 at 4:28 PM Bryan Hoyer <bhhoyer@...> wrote:

Dave,

I’m baffled. It looks fine. We only change a few values, as you can see in the script, and the manufacturing date is entered by hand and it is correct as well. Are you direct connected to the machine? We have seen some problems with unpowered hubs.

Bryan


--
- Dave
  W3DJS

Join ambe@nw-digital-radio.groups.io to automatically receive all group messages.