Re: PiDV, AMBEserver and Buster


 

OK, normally the PiDV™ would be on /dev/ttyAMA0 and not /dev/ttyS0 (Pi4 may re-map).

Give a try with:
sudo systemctl stop ambeserver@...  
sudo systemctl disable ambeserver@...  
sudo systemctl start ambeserver@...  
sudo systemctl status ambeserver@... 

If all is good, then

sudo systemctl enable ambeserver@...    

You can verify that opendv is in the dialout group with
 grep dialout /etc/group

Which should return something like:
dialout:x:20:opendv     


On Wed, Sep 30, 2020 at 6:58 AM KB5ZUR <kb5zur@...> wrote:
John,
Her you go.
-DS

pi@DV3000SVR:~/ambeserver-install $ ls -l /dev/tty*

crw-rw---- 1 root dialout 204, 64 Sep 29 15:13 /dev/ttyAMA0
crw--w---- 1 root tty       4, 64 Sep 29 17:56 /dev/ttyS0


Hi John,
I'm at exactly this same point with my PiDV on a new Raspberry pi 3B+ install.
PiDV works with ttl to usb adaptor in wibdows and passed AMBEtest3.py fine.

Tried the "sudo usermod -G dialout opendv with no success. I still get the following errors when trying to run ambeserver@ttyS0
pi@DV3000SVR:~/ambeserver-install $ sudo systemctl status ambeserver@...
● ambeserver@... - AMBEserver Daemon
   Loaded: loaded (/etc/systemd/system/ambeserver@.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2020-09-29 15:38:36 CDT; 34s ago
 Main PID: 1546 (code=exited, status=1/FAILURE)
 
Sep 29 15:38:36 DV3000SVR systemd[1]: Starting AMBEserver Daemon...
Sep 29 15:38:36 DV3000SVR systemd[1]: Started AMBEserver Daemon.
Sep 29 15:38:36 DV3000SVR AMBEserver[1546]: AMBEserver: Starting...
Sep 29 15:38:36 DV3000SVR AMBEserver[1546]: AMBEserver: Opened serial port /dev/ttyS0 at 230400 bps.
Sep 29 15:38:36 DV3000SVR AMBEserver[1546]: AMBEserver: Unable to open GPIO export interface: Permission denied
Sep 29 15:38:36 DV3000SVR AMBEserver[1546]: AMBEserver: Could not initialize the DV3K!
Sep 29 15:38:36 DV3000SVR systemd[1]: ambeserver@...: Main process exited, code=exited, status=1/FAIL
Sep 29 15:38:36 DV3000SVR systemd[1]: ambeserver@...: Failed with result 'exit-code'.
Sep 29 15:38:36 DV3000SVR systemd[1]: ambeserver@...: Triggering OnFailure= dependencies.
lines 1-14/14 (END)


seems to be some sort of GPIO Permission denied error.

Driving me a bit crazy trying to figure this out. Any help is appreciated.




--
John D. Hays
Kingston, WA
K7VE

 

Join ambe@nw-digital-radio.groups.io to automatically receive all group messages.