Re: ambeserver on Raspian Jessie with ThumbDV locks BlueDV on receive after having changed UDP Port


TG9AOR
 

I reinstalled everything, but I am at the same spot. I even reconnected the ThumbDV after stopping the ambeserver. Output of python ambesocketest.py below
pi@raspberrypi:~/Downloads/NWDigitalRadio $ python ambesocketest.py
^CTraceback (most recent call last):
  File "ambesocketest.py", line 23, in <module>
    d = s.recvfrom(1024)
KeyboardInterrupt
pi@raspberrypi:~/Downloads/NWDigitalRadio $ sudo systemctl status ambeserver@...
ambeserver@... - DV3000 Daemon
   Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled)
   Active: failed (Result: exit-code) since Fri 2017-09-29 22:54:45 UTC; 5min ago
  Process: 2891 ExecStart=/usr/sbin/AMBEserver -p ${UDP_PORT} -i /dev/%i $AMBESERVER_FLAGS (code=exited, status=1/FAILURE)
  Process: 2888 ExecStartPre=/bin/chmod 0660 /dev/%i (code=exited, status=0/SUCCESS)
  Process: 2885 ExecStartPre=/bin/chgrp dialout /dev/%i (code=exited, status=0/SUCCESS)
 Main PID: 2891 (code=exited, status=1/FAILURE)
Sep 29 22:54:08 raspberrypi systemd[1]: Starting DV3000 Daemon...
Sep 29 22:54:08 raspberrypi systemd[1]: Started DV3000 Daemon.
Sep 29 22:54:08 raspberrypi AMBEserver[2891]: AMBEserver: Starting...
Sep 29 22:54:08 raspberrypi AMBEserver[2891]: AMBEserver: Opened serial port /dev/ttyUSB1 at 460800 bps.
Sep 29 22:54:45 raspberrypi AMBEserver[2891]: AMBEserver: Couldn't find start byte in serial data
Sep 29 22:54:45 raspberrypi AMBEserver[2891]: AMBEserver: error receiving response to reset
Sep 29 22:54:45 raspberrypi AMBEserver[2891]: AMBEserver: Could not initialize the DV3K!
Sep 29 22:54:45 raspberrypi systemd[1]: ambeserver@...: main process exited, code=exited, status=1/FAILURE
Sep 29 22:54:45 raspberrypi systemd[1]: Unit ambeserver@... entered failed state.
Sep 29 22:54:45 raspberrypi systemd[1]: Triggering OnFailure= dependencies of ambeserver@....
pi@raspberrypi:~/Downloads/NWDigitalRadio $ sudo systemctl restart ambeserver@...
pi@raspberrypi:~/Downloads/NWDigitalRadio $ sudo systemctl status ambeserver@...
ambeserver@... - DV3000 Daemon
   Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled)
   Active: active (running) since Fri 2017-09-29 23:00:47 UTC; 1s ago
  Process: 2972 ExecStartPre=/bin/chmod 0660 /dev/%i (code=exited, status=0/SUCCESS)
  Process: 2969 ExecStartPre=/bin/chgrp dialout /dev/%i (code=exited, status=0/SUCCESS)
 Main PID: 2975 (AMBEserver)
   CGroup: /system.slice/system-ambeserver.slice/ambeserver@...
           └─2975 /usr/sbin/AMBEserver -p 18317 -i /dev/ttyUSB1 -s 460800
Sep 29 23:00:47 raspberrypi systemd[1]: Started DV3000 Daemon.
Sep 29 23:00:47 raspberrypi AMBEserver[2975]: AMBEserver: Starting...
Sep 29 23:00:47 raspberrypi AMBEserver[2975]: AMBEserver: Opened serial port /dev/ttyUSB1 at 460800 bps.
pi@raspberrypi:~/Downloads/NWDigitalRadio $ sudo systemctl stop ambeserver@...<---------Here I unplugged and reinserted ThumDV
pi@raspberrypi:~/Downloads/NWDigitalRadio $ sudo systemctl restart ambeserver@...
pi@raspberrypi:~/Downloads/NWDigitalRadio $ sudo systemctl status ambeserver@...
● ambeserver@... - DV3000 Daemon
   Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled)
   Active: active (running) since Fri 2017-09-29 23:03:56 UTC; 5min ago
  Process: 3048 ExecStartPre=/bin/chmod 0660 /dev/%i (code=exited, status=0/SUCCESS)
  Process: 3045 ExecStartPre=/bin/chgrp dialout /dev/%i (code=exited, status=0/SUCCESS)
 Main PID: 3051 (AMBEserver)
   CGroup: /system.slice/system-ambeserver.slice/ambeserver@...
           └─3051 /usr/sbin/AMBEserver -p 18317 -i /dev/ttyUSB1 -s 460800
Sep 29 23:03:56 raspberrypi systemd[1]: Started DV3000 Daemon.
Sep 29 23:03:56 raspberrypi AMBEserver[3051]: AMBEserver: Starting...
Sep 29 23:03:56 raspberrypi AMBEserver[3051]: AMBEserver: Opened serial port /dev/ttyUSB1 at 460800 bps.
Sep 29 23:03:56 raspberrypi AMBEserver[3051]: AMBEserver: Initialized AMBE3000R version V120.E100.XXXX.C106.G514.R009.B0010411.C0020208.
Sep 29 23:03:56 raspberrypi AMBEserver[3051]: AMBEserver: Listening for connections on UDP port 18317.


However, the BlueDV says reconnecting once I transmit an echo transmission, I guess when he tries to start decoding.


TG9AOR

Join ambe@nw-digital-radio.groups.io to automatically receive all group messages.