Re: Ambe server on raspberry pi 3 B+


node750tt@...
 

John,
When I boot the Pi without USB Dongle Ambeserver will not run. I must boot the Pi with the Dongle in one of the USB ports. So I cannot test the Dongle in the Window 
PC using the Pi ip address in BlueDV as the ambeserver will not be running on the Pi.

Another thing in BlueDV setup under Ambe, when I uncheck ThumbDV / DV3000 box and tick use ambeserver box,  entered the ip address saved, open back up BlueDV setup page the tick in that box is not there. Do you think is is because BlueDV is realizing that the abmeserver is not running?

The server test fine on the Pi with the .py script. I also checked in ../log/opendv nothing in the logs show errors all shows fine. 

pi@DStar:/ $ sudo systemctl status ambeserver@...
 ambeserver@... - DV3000 Daemon
   Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled; vendor pres
   Active: active (running) since Wed 2018-08-01 07:11:08 UTC; 4min 18s ago
  Process: 442 ExecStartPre=/bin/chmod 0660 /dev/ttyUSB0 (code=exited, status=0/
  Process: 437 ExecStartPre=/bin/chgrp dialout /dev/ttyUSB0 (code=exited, status
 Main PID: 451 (AMBEserver)
   CGroup: /system.slice/system-ambeserver.slice/ambeserver@...
           ??451 /usr/sbin/AMBEserver -p 2460 -i /dev/ttyUSB0 -s 460800
 
Aug 01 07:11:08 DStar systemd[1]: Starting DV3000 Daemon...
Aug 01 07:11:08 DStar systemd[1]: Started DV3000 Daemon.
Aug 01 07:11:08 DStar AMBEserver[451]: AMBEserver: Starting...
Aug 01 07:11:08 DStar AMBEserver[451]: AMBEserver: Opened serial port /dev/ttyUS
Aug 01 07:11:08 DStar AMBEserver[451]: AMBEserver: Initialized AMBE3000R version
Aug 01 07:11:08 DStar AMBEserver[451]: AMBEserver: Listening for connections on 
 
Server reply : a
                0AMBE3000R
I am able to drop or connect to any reflector, I double check my USB soundcard settings double check the alsamixer still no TX. only RX. Not sure what else to check.






Join ambe@nw-digital-radio.groups.io to automatically receive all group messages.