Date   

Re: AMBEServer Install for PiDV

 

Mike,

Set up the opendv user:

sudo useradd -s /bin/false opendv

then 

sudo usermod -G dialout
sudo usermod -G gpio
sudo usermod -G audio

In /etc/opendv create 3 files:  ambeserver-ttyAMA0.conf  ambeserver-ttyS0.conf  ambeserver-ttyUSB0.conf

Each will contain:
#
# Configuration file for the AMBEserver program started by systemd.
# Adding flags to AMBESERVER_FLAGS will pass this to the daemon.
# For example, to change the speed to 460800, use the following line:
# AMBESERVER_FLAGS="-s 460800"
#

UDP_PORT=2460
AMBESERVER_FLAGS="-r"

create a file in /etc/systemd/system named ambeserver@.service

Containing:
[Unit]
Description=DV3000 Daemon
After=network.target serial-getty@%i.service dev-%i.device
Conflicts=serial-getty@%i.service
OnFailure=serial-getty@%i.service

[Service]
User=opendv
EnvironmentFile=/etc/opendv/%p-%i.conf
PermissionsStartOnly=true
ExecStartPre=/bin/chgrp dialout /dev/%i
ExecStartPre=/bin/chmod 0660 /dev/%i
ExecStart=/usr/sbin/AMBEserver -p ${UDP_PORT} -i /dev/%i $AMBESERVER_FLAGS
Restart=on-abort

[Install]
WantedBy=multi-user.target

 
Startup and enable  ambeserver

sudo systemctl enable  ambeserver@ttyAMA0
sudo systemctl start  ambeserver@ttyAMA0
sudo systemctl status  ambeserver@ttyAMA0

If you are not familiar with systemd  check out manual pages:

man systemctl
man systemd



John D. Hays
Edmonds, WA
K7VE

   


Re: AMBEServer Install for PiDV

Mike Besemer - WM4B
 

When you get it figured out, I hope you can document it; I'm heading in the same direction if I can get AMBEServer loaded and running.

Mike
WM4B


On Tue, Mar 12, 2019 at 12:25 PM, John Anderson via Groups.Io wrote:

 Hi John.

I dont have a static ip from my internet provider but i plan to use my home noip.com account which is running in my fibre router and have a static ip assigned to the Pi on my home network, so i think all i need is instructions and ports number to link the VM via the internet to the Pi, any help would be very much appreciated.


Re: AMBEServer Install for PiDV

John Anderson
 

Hi John.

I dont have a static ip from my internet provider but i plan to use my home noip.com account which is running in my fibre router and have a static ip assigned to the Pi on my home network, so i think all i need is instructions and ports number to link the VM via the internet to the Pi, any help would be very much appreciated.

73.


Re: AMBEServer Install for PiDV

 

AMBEserver can run over networking, either LAN or Internet.  If you want to access it from a VM at a remote location, you will need to know the public IP address at home and forward the UDP port to the Pi (for added security, you may want to only forward from/to your VMs public IP address).  I will leave it to others to discuss the configuration for your specific combination.

On Tue, Mar 12, 2019 at 9:10 AM John Anderson via Groups.Io <mi0aaz=yahoo.co.uk@groups.io> wrote:
While this thread is running i might as well ask, how easy or hard is it to have the Pi with PiDV board here at home running AMBEServer which in turn is linked to my Debian server VM connected to an XLX reflector of my choice ? So far i have a DVSwitch based bridge running from AllStar to DMR on my VM, is it possible to have this configured as an AllStar to D-Star (XLX) bridge instead ?

73 John Mi0AAZ
_._,_._,_




John D. Hays
Edmonds, WA
K7VE

   


Re: AMBEServer Install for PiDV

John Anderson
 

While this thread is running i might as well ask, how easy or hard is it to have the Pi with PiDV board here at home running AMBEServer which in turn is linked to my Debian server VM connected to an XLX reflector of my choice ? So far i have a DVSwitch based bridge running from AllStar to DMR on my VM, is it possible to have this configured as an AllStar to D-Star (XLX) bridge instead ?

73 John Mi0AAZ


Re: AMBEServer Install for PiDV

 

Almost there 


On Tue, Mar 12, 2019, 05:13 Mike Besemer <mwbesemer@...> wrote:
John,

You seriously underestimate my ability to confuse myself!

I did:

gcc -o AMBEserver AMBEserver.c

sudo cp AMBEserver /usr/sbin

So I now have AMBEServer in /usr/sbin. 

Looking over the rest of the page: 

I did not have the directory "/etc/opendv", so I created it.  At that point, the XYL revoked my kitchen pass.

Looks like tonight I need to create ambeserver-ttyAMA0.conf as follows:

#
# Configuration file for the AMBEserver program started by systemd.
# Adding flags to AMBESERVER_FLAGS will pass this to the daemon.
# For example, to change the speed to 460800, use the following line:
# AMBESERVER_FLAGS="-s 460800"
#

UDP_PORT=2460
AMBESERVER_FLAGS=""

Am I getting warm?

73,

Mike
WM4B



On Mon, Mar 11, 2019 at 8:10 PM, John D Hays - K7VE wrote:

 Mike,


It appears the makefile is now missing, but no worries -- try this approach



(Read the whole page.





On Mon, Mar 11, 2019 at 4:51 PM Mike Besemer < mwbesemer@...> wrote:
John,
 
Typing ‘make’ yields the following:
 
pi@raspberrypi:~/DV3000 $ make
make: *** No targets specified and no makefile found.  Stop.
pi@raspberrypi:~/DV3000 $
 
Mike
WM4B
 
 
 
From: ambe@nw-digital-radio.groups.io[mailto: ambe@nw-digital-radio.groups.io] On Behalf Of John D Hays - K7VE
Sent: Monday, March 11, 2019 7:41 PM
To: ambe@nw-digital-radio.groups.io
Subject: Re: [ambe] AMBEServer Install for PiDV
 
Hi Mike
 
On Mon, Mar 11, 2019 at 4:38 PM Mike Besemer < mwbesemer@...> wrote:
 
I get as far as the ls command (below) before things go wrong.  When I run ls, the Makefile is not there.
 
ls
AMBEserver.c  AMBEtest2.py  AMBEtest3.py  dv3000d-AMBEserver.pdf  dv3000d.c  init.d   Makefile  README-dv3000d.txt  README.txt
 
Now type --
make
 
--
 
___________________________________

John D. Hays
Edmonds, WA
K7VE
 
     
 


--

___________________________________

John D. Hays
Edmonds, WA
K7VE



     


Re: AMBEServer Install for PiDV

Mike Besemer - WM4B
 

John,

You seriously underestimate my ability to confuse myself!

I did:

wget https://raw.githubusercontent.com/dl5di/OpenDV/master/DummyRepeater/DV3000/AMBEserver.c
gcc -o AMBEserver AMBEserver.c

sudo cp AMBEserver /usr/sbin

So I now have AMBEServer in /usr/sbin. 

Looking over the rest of the page: 

I did not have the directory "/etc/opendv", so I created it.  At that point, the XYL revoked my kitchen pass.

Looks like tonight I need to create ambeserver-ttyAMA0.conf as follows:

#
# Configuration file for the AMBEserver program started by systemd.
# Adding flags to AMBESERVER_FLAGS will pass this to the daemon.
# For example, to change the speed to 460800, use the following line:
# AMBESERVER_FLAGS="-s 460800"
#

UDP_PORT=2460
AMBESERVER_FLAGS=""

Am I getting warm?

73,

Mike
WM4B



On Mon, Mar 11, 2019 at 8:10 PM, John D Hays - K7VE wrote:

 Mike,


It appears the makefile is now missing, but no worries -- try this approach



(Read the whole page.





On Mon, Mar 11, 2019 at 4:51 PM Mike Besemer < mwbesemer@...> wrote:
John,
 
Typing ‘make’ yields the following:
 
pi@raspberrypi:~/DV3000 $ make
make: *** No targets specified and no makefile found.  Stop.
pi@raspberrypi:~/DV3000 $
 
Mike
WM4B
 
 
 
From: ambe@nw-digital-radio.groups.io[mailto: ambe@nw-digital-radio.groups.io] On Behalf Of John D Hays - K7VE
Sent: Monday, March 11, 2019 7:41 PM
Subject: Re: [ambe] AMBEServer Install for PiDV
 
Hi Mike
 
On Mon, Mar 11, 2019 at 4:38 PM Mike Besemer < mwbesemer@...> wrote:
 
I get as far as the ls command (below) before things go wrong.  When I run ls, the Makefile is not there.
 
ls
AMBEserver.c  AMBEtest2.py  AMBEtest3.py  dv3000d-AMBEserver.pdf  dv3000d.c  init.d   Makefile  README-dv3000d.txt  README.txt
 
Now type --
make
 
--
 
___________________________________

John D. Hays
Edmonds, WA
K7VE
 
     
 


--

___________________________________

John D. Hays
Edmonds, WA
K7VE



     


Re: AMBEServer Install for PiDV

Mike Besemer - WM4B
 

Simple - except when it's not.

It appears that those directions are for the DVThumb, not my PiDV (DV3000).  I guess this will work if I do the following:

$ sudo nano /boot/config.txt
   init_uart_clock=3686400

$ sudo nano /etc/inittab
  Replace: T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100
  With: #T0:23:respawn:/sbin/getty -L ttyAMA0 115200 vt100

$ sudo nano /boot/cmdline.txtd
   Replace: wc_otg.lpm_enable=0 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
   With: dwc_otg.lpm_enable=0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait

If I can get it to work, perhaps I'll write it up.

Unfortunatly, time to work on this is limited; I'll see what happens.

Thanks and 73,

Mike
WM4B


On Mon, Mar 11, 2019 at 7:45 PM, Clint Heffner wrote:

 This is the only one I have gotten to work recently...




Its so simple.

Clint -- KF8MZ


Re: AMBEServer Install for PiDV

Mike Besemer - WM4B
 

I'll give it a try, but I'm NOT running a DVThumb. I have the DV3000 (PiDV) attached to the GPIO headers.

I appreciate the help. It's frustrating for a newbie to have to chase problems with out-of-date documentation. I just suffered through all that getting AllStar up and running.

73,

Mike
WM4B

On Mon, Mar 11, 2019 at 8:22 PM, (null) (null) via Groups.Io wrote:

Mike 
Try this document it worked well for me, Under step 1. use this link instead of whats in the document. 

Index of /images/


| | | | Index of /images/


|

|

|



On Monday, March 11, 2019, 5:12:24 PM PDT, Clint Heffner <clintheffner@gmail.com> wrote:
This is the only one I have gotten to work recently...
https://nw-digital-radio.groups.io/g/ambe/message/703
Its so simple.
Clint -- KF8MZ



Re: AMBEServer Install for PiDV

(null) (null)
 

Mike 

Try this document it worked well for me, Under step 1. use this link instead of whats in the document. 





On Monday, March 11, 2019, 5:12:24 PM PDT, Clint Heffner <clintheffner@...> wrote:


This is the only one I have gotten to work recently...


Its so simple.

Clint -- KF8MZ


Re: AMBEServer Install for PiDV

Clint Heffner
 

This is the only one I have gotten to work recently...


Its so simple.

Clint -- KF8MZ


Re: AMBEServer Install for PiDV

 

Mike,

It appears the makefile is now missing, but no worries -- try this approach




On Mon, Mar 11, 2019 at 4:51 PM Mike Besemer <mwbesemer@...> wrote:

John,

 

Typing ‘make’ yields the following:

 

pi@raspberrypi:~/DV3000 $ make

make: *** No targets specified and no makefile found.  Stop.

pi@raspberrypi:~/DV3000 $

 

Mike

WM4B

 

 

 

From: ambe@nw-digital-radio.groups.io [mailto:ambe@nw-digital-radio.groups.io] On Behalf Of John D Hays - K7VE
Sent: Monday, March 11, 2019 7:41 PM
To: ambe@nw-digital-radio.groups.io
Subject: Re: [ambe] AMBEServer Install for PiDV

 

Hi Mike

 

On Mon, Mar 11, 2019 at 4:38 PM Mike Besemer <mwbesemer@...> wrote:

 

I get as far as the ls command (below) before things go wrong.  When I run ls, the Makefile is not there.

 

ls

AMBEserver.c  AMBEtest2.py  AMBEtest3.py  dv3000d-AMBEserver.pdf  dv3000d.c  init.d  Makefile  README-dv3000d.txt  README.txt

 

Now type --

make

 

--

 


John D. Hays
Edmonds, WA

K7VE

 

   

 



--


John D. Hays
Edmonds, WA
K7VE

   


Re: AMBEServer Install for PiDV

Mike Besemer - WM4B
 

John,

 

Typing ‘make’ yields the following:

 

pi@raspberrypi:~/DV3000 $ make

make: *** No targets specified and no makefile found.  Stop.

pi@raspberrypi:~/DV3000 $

 

Mike

WM4B

 

 

 

From: ambe@nw-digital-radio.groups.io [mailto:ambe@nw-digital-radio.groups.io] On Behalf Of John D Hays - K7VE
Sent: Monday, March 11, 2019 7:41 PM
To: ambe@nw-digital-radio.groups.io
Subject: Re: [ambe] AMBEServer Install for PiDV

 

Hi Mike

 

On Mon, Mar 11, 2019 at 4:38 PM Mike Besemer <mwbesemer@...> wrote:

 

I get as far as the ls command (below) before things go wrong.  When I run ls, the Makefile is not there.

 

ls

AMBEserver.c  AMBEtest2.py  AMBEtest3.py  dv3000d-AMBEserver.pdf  dv3000d.c  init.d  Makefile  README-dv3000d.txt  README.txt

 

Now type --

make

 

--

 


John D. Hays
Edmonds, WA

K7VE

 

   

 


Re: AMBEServer Install for PiDV

 

Hi Mike

On Mon, Mar 11, 2019 at 4:38 PM Mike Besemer <mwbesemer@...> wrote:


I get as far as the ls command (below) before things go wrong.  When I run ls, the Makefile is not there.


ls

AMBEserver.c  AMBEtest2.py  AMBEtest3.py  dv3000d-AMBEserver.pdf  dv3000d.c  init.d  Makefile  README-dv3000d.txt  README.txt


Now type --
make

--


John D. Hays
Edmonds, WA
K7VE

   


AMBEServer Install for PiDV

Mike Besemer - WM4B
 

Greetings,

New guy here.

Trying to get AMBEServer installed on my Pi using Method 2 here: http://nwdigitalradio.com/dv3000-ambeserver/

I get as far as the ls command (below) before things go wrong.  When I run ls, the Makefile is not there.

I am not a Linux geek, but can generally follow directions.  What am I doing wrong?

73,

Mike

WM4B

apt-get install git

 

cd

git clone https://github.com/dl5di/OpenDV.git

Cloning into ‘OpenDV’…

remote: Counting objects: 2196, done.

remote: Total 2196 (delta 0), reused 0 (delta 0)

Receiving objects: 100% (2196/2196), 29.65 MiB | 2.05 MiB/s, done.

Resolving deltas: 100% (1444/1444), done.

Checking connectivity… done.

mv OpenDV/DummyRepeater/DV3000 DV3000

rm -rf OpenDV

cd DV3000

ls

AMBEserver.c  AMBEtest2.py  AMBEtest3.py  dv3000d-AMBEserver.pdf  dv3000d.c  init.d  Makefile  README-dv3000d.txt  README.txt


Re: No light. Dongle fails test

va7vw@...
 

I am referring to a ThumbDV from NW Digital Radio.

It is showing as a USB com port on my PC.


Re: No light. Dongle fails test

va7vw@...
 

Thanks for the link. I have confirmed that it is on the correct com port.


Re: Can 6 Digit DMR IDs work with BlueDV & AMBE Servers?? #dmrid, #ambe, # amberserver

Dev 9Y4DG
 

Hi Jason,
Unfortunately..that did not work.

Thanks again for your help....73 Dev


On Fri, 22 Feb 2019 at 11:18, Jason Kingsbury <jkingsbury13@...> wrote:
Not sure if this will work, but have you tried to put a 0 (zero) in front of the six digit ID when configuring it on BlueDV? 


On Feb 8, 2019, at 1:56 PM, Dev Gosine <dgosine@...> wrote:

Good day,
                  Thank you for taking the time to read this message and also for your kind contribution to the thread.

Here are the facts.

1. I have 5 AMBE Servers.
2. I have 2 DMR IDs
3. BlueDV (Android) does not support adding an additional 2 digits to the end of the DMR ID as the DMR ID input field allows only 7 digits.
4. I have applied for additional DMR IDs, but was given five 6 digit repeater IDs.
5. This initially sounded like the perfect solution since I have 5 AMBE Servers and got 5 DMR IDs.
6. The problem is that the 6 digit DMR ID is not seen on Brandmeister's Hoseline when I transmit. This means I have absolutely no transmission being monitored on hoseline if I were to transmit.

Can anyone tell me what I'm doing wrong and possibly lead me in the correct direction.

I thank you again for all your contributions.....73 Dev, 9Y4DG
 

 



--


“Your chances of success in any undertaking can
always be measured by your belief in yourself"
       ~Robert Collier~.

The pessimist complains about the wind.
The optimist expects it to change.
The leader adjusts the sails.

                 ~John Maxwell~

Teamwork is the ability to work together toward a common vision.
The ability to direct individual accomplishment toward organizational objectives.
It is the fuel that allows common people to attain uncommon results.
      ~ Anonymous~

We believe that:

"We make a living by what we get,
We make a life by what we give!"
          ~Winston Churchill~


Re: Can 6 Digit DMR IDs work with BlueDV & AMBE Servers?? #dmrid, #ambe, # amberserver

Dev 9Y4DG
 

Thanks Jason... certainly worth a try
73 Dev

On Fri, Feb 22, 2019, 11:18 AM Jason Kingsbury <jkingsbury13@...> wrote:
Not sure if this will work, but have you tried to put a 0 (zero) in front of the six digit ID when configuring it on BlueDV? 


On Feb 8, 2019, at 1:56 PM, Dev Gosine <dgosine@...> wrote:

Good day,
                  Thank you for taking the time to read this message and also for your kind contribution to the thread.

Here are the facts.

1. I have 5 AMBE Servers.
2. I have 2 DMR IDs
3. BlueDV (Android) does not support adding an additional 2 digits to the end of the DMR ID as the DMR ID input field allows only 7 digits.
4. I have applied for additional DMR IDs, but was given five 6 digit repeater IDs.
5. This initially sounded like the perfect solution since I have 5 AMBE Servers and got 5 DMR IDs.
6. The problem is that the 6 digit DMR ID is not seen on Brandmeister's Hoseline when I transmit. This means I have absolutely no transmission being monitored on hoseline if I were to transmit.

Can anyone tell me what I'm doing wrong and possibly lead me in the correct direction.

I thank you again for all your contributions.....73 Dev, 9Y4DG
 

 


Re: No light. Dongle fails test

 

Are you referring to a ThumbDV from NW Digital Radio?

Is it showing as a com port on your computer?


On Fri, Mar 1, 2019 at 10:34 PM <va7vw@...> wrote:
If there is no light and it fails the test, is it finished or can it be repaired?



--


John D. Hays
Edmonds, WA
K7VE

   

761 - 780 of 1592