Change port on Ambe Server


Kenny Richards
 

Marco,

The file is owned by the system, so you'll need to use an account with root privileges. Then any text editor should be able to open and edit the file, just remember that you can do a lot of damage when editing system files as root.  I'd recommend using the nano editor if your not familiar with linux, here is the command to edit the file as root.

$ sudo /usr/bin/nano /etc/init.d/AMBEserver

73,
Kenny


Marco Della Cagna
 

Tahnk you for answeare Kenny, i have found the file /etc/init.d/AMBEserver but i cannot open it for change the port.
What software should I use to open an executable file?
73
Marco - IK6IOQ


Kenny Richards
 

Marco,

I don't run the version of AMBEserver installed via the Compass install, but I know you change the port used by AMBEserver with the -p option when starting it. I'd take a look in the startup script in /etc/init.d which launches it at boot time. You can probably add the -p PORT# there and take care of moving it from 2460 to what you want.

For reference, there is a section in my start up script (/etc/init.d/AMBEserver) which looks like this:

 case "$1" in
  start)
        /usr/bin/AMBEserver -i /dev/ttyUSB0
        echo "Starting AMBEserver" >&2
        exit 0
        ;;

Change it to this for Port 9999

 case "$1" in
  start)
        /usr/bin/AMBEserver -i /dev/ttyUSB0 -p 9999
        echo "Starting AMBEserver" >&2
        exit 0
        ;;

73,
Kenny, KU7M


Marco Della Cagna
 

Hallo,
i try to change port on my AMBEServer running on Compass Linux under Rasp PI, so in the directory /etc/opendv i change the file ambeserver-ttyUSB0.conf 
The problem is that every time i reboot the server the port is again 2460 and not the number i edit.
Obviously I'm editing as root and with nano editor and before changing the port, i stop the server.
What i wrong ? How can i fix the problem ?
Thank you and 73
Marco - IK6IOQ