Topics

How to Change AMBEServer UDP Port Number?? #udpport #ambe #port


Dev 9Y4DG
 

Good day,
                   The AMBEServer defaults to port 2460. I would like to run multiple servers simultaneously. Of course, they can't all use port 2460 concurrently.

So the question is how does one change the UDP port either in the initialisation process of the Raspberry Pi and/or in the AMBE Server??

I suspect a file of two needs to be edited..... any ideas or suggestions??

I thank you for your contributions...73 Dev, 9Y4DG


(null) (null)
 

Dev

I’m running multiple servers also and I did the following on the PI server:

pico /etc/opendv/ambeserver-ttyUSB0.conf
Changed the UDP port to 18307

Did UDP port forwarding on the router for 18307.

Frank k6fed 

On Jan 29, 2019, at 8:53 PM, Dev Gosine <dgosine@...> wrote:

Good day,
                   The AMBEServer defaults to port 2460. I would like to run multiple servers simultaneously. Of course, they can't all use port 2460 concurrently.

So the question is how does one change the UDP port either in the initialisation process of the Raspberry Pi and/or in the AMBE Server??

I suspect a file of two needs to be edited..... any ideas or suggestions??

I thank you for your contributions...73 Dev, 9Y4DG


Dev 9Y4DG
 

Thank you Frank for your very prompt response..

It seems as though you might be using Compass Linux. Unfortunately, I'm using Raspian Stretch., so there is no opendv folder and neither am I seeing any ambeserver-ttyUSB0.conf file to edit.

Thanks again buddy...73 Dev, 9Y4DG


On Wed, 30 Jan 2019 at 01:25, (null) (null) via Groups.Io <fdecuire=yahoo.com@groups.io> wrote:
Dev

I’m running multiple servers also and I did the following on the PI server:

pico /etc/opendv/ambeserver-ttyUSB0.conf
Changed the UDP port to 18307

Did UDP port forwarding on the router for 18307.

Frank k6fed 

On Jan 29, 2019, at 8:53 PM, Dev Gosine <dgosine@...> wrote:

Good day,
                   The AMBEServer defaults to port 2460. I would like to run multiple servers simultaneously. Of course, they can't all use port 2460 concurrently.

So the question is how does one change the UDP port either in the initialisation process of the Raspberry Pi and/or in the AMBE Server??

I suspect a file of two needs to be edited..... any ideas or suggestions??

I thank you for your contributions...73 Dev, 9Y4DG



--


“Your chances of success in any undertaking can
always be measured by your belief in yourself"
       ~Robert Collier~.

The pessimist complains about the wind.
The optimist expects it to change.
The leader adjusts the sails.

                 ~John Maxwell~

Teamwork is the ability to work together toward a common vision.
The ability to direct individual accomplishment toward organizational objectives.
It is the fuel that allows common people to attain uncommon results.
      ~ Anonymous~

We believe that:

"We make a living by what we get,
We make a life by what we give!"
          ~Winston Churchill~


 

There are command line switches to set the port and device. 


On Wed, Jan 30, 2019, 05:05 Dev Gosine <dgosine@... wrote:
Thank you Frank for your very prompt response..

It seems as though you might be using Compass Linux. Unfortunately, I'm using Raspian Stretch., so there is no opendv folder and neither am I seeing any ambeserver-ttyUSB0.conf file to edit.

Thanks again buddy...73 Dev, 9Y4DG


On Wed, 30 Jan 2019 at 01:25, (null) (null) via Groups.Io <fdecuire=yahoo.com@groups.io> wrote:
Dev

I’m running multiple servers also and I did the following on the PI server:

pico /etc/opendv/ambeserver-ttyUSB0.conf
Changed the UDP port to 18307

Did UDP port forwarding on the router for 18307.

Frank k6fed 

On Jan 29, 2019, at 8:53 PM, Dev Gosine <dgosine@...> wrote:

Good day,
                   The AMBEServer defaults to port 2460. I would like to run multiple servers simultaneously. Of course, they can't all use port 2460 concurrently.

So the question is how does one change the UDP port either in the initialisation process of the Raspberry Pi and/or in the AMBE Server??

I suspect a file of two needs to be edited..... any ideas or suggestions??

I thank you for your contributions...73 Dev, 9Y4DG



--


“Your chances of success in any undertaking can
always be measured by your belief in yourself"
       ~Robert Collier~.

The pessimist complains about the wind.
The optimist expects it to change.
The leader adjusts the sails.

                 ~John Maxwell~

Teamwork is the ability to work together toward a common vision.
The ability to direct individual accomplishment toward organizational objectives.
It is the fuel that allows common people to attain uncommon results.
      ~ Anonymous~

We believe that:

"We make a living by what we get,
We make a life by what we give!"
          ~Winston Churchill~


Stefsan
 

Hi Dev,

as you remember before you compile (with make and make install) you had edit the ambeserver.c file with a editor (as root) to change in it the baudrate ( maybe you have), on one of the following line you can also change the port. Change them also and the baudrate and compile again ( with make and make install)

B.r.

Stefan DL1ESZ

Am 30.01.19 um 14:05 schrieb Dev Gosine:

Thank you Frank for your very prompt response..

It seems as though you might be using Compass Linux. Unfortunately, I'm using Raspian Stretch., so there is no opendv folder and neither am I seeing any ambeserver-ttyUSB0.conf file to edit.

Thanks again buddy...73 Dev, 9Y4DG


On Wed, 30 Jan 2019 at 01:25, (null) (null) via Groups.Io <fdecuire=yahoo.com@groups.io> wrote:
Dev

I’m running multiple servers also and I did the following on the PI server:

pico /etc/opendv/ambeserver-ttyUSB0.conf
Changed the UDP port to 18307

Did UDP port forwarding on the router for 18307.

Frank k6fed 

On Jan 29, 2019, at 8:53 PM, Dev Gosine <dgosine@...> wrote:

Good day,
                   The AMBEServer defaults to port 2460. I would like to run multiple servers simultaneously. Of course, they can't all use port 2460 concurrently.

So the question is how does one change the UDP port either in the initialisation process of the Raspberry Pi and/or in the AMBE Server??

I suspect a file of two needs to be edited..... any ideas or suggestions??

I thank you for your contributions...73 Dev, 9Y4DG



--


“Your chances of success in any undertaking can
always be measured by your belief in yourself"
       ~Robert Collier~.

The pessimist complains about the wind.
The optimist expects it to change.
The leader adjusts the sails.

                 ~John Maxwell~

Teamwork is the ability to work together toward a common vision.
The ability to direct individual accomplishment toward organizational objectives.
It is the fuel that allows common people to attain uncommon results.
      ~ Anonymous~

We believe that:

"We make a living by what we get,
We make a life by what we give!"
          ~Winston Churchill~


Jorge
 

Hi all,

You can use switch "p" to change port number, exemp: usr/local/sbin/ambeserver -d -i -p 24999 /dev/ttyUSB0 -s 460800

Hope this help

On Wed, 30 Jan 2019 at 15:36, John D Hays - K7VE <john@...> wrote:
There are command line switches to set the port and device. 

On Wed, Jan 30, 2019, 05:05 Dev Gosine <dgosine@... wrote:
Thank you Frank for your very prompt response..

It seems as though you might be using Compass Linux. Unfortunately, I'm using Raspian Stretch., so there is no opendv folder and neither am I seeing any ambeserver-ttyUSB0.conf file to edit.

Thanks again buddy...73 Dev, 9Y4DG


On Wed, 30 Jan 2019 at 01:25, (null) (null) via Groups.Io <fdecuire=yahoo.com@groups.io> wrote:
Dev

I’m running multiple servers also and I did the following on the PI server:

pico /etc/opendv/ambeserver-ttyUSB0.conf
Changed the UDP port to 18307

Did UDP port forwarding on the router for 18307.

Frank k6fed 

On Jan 29, 2019, at 8:53 PM, Dev Gosine <dgosine@...> wrote:

Good day,
                   The AMBEServer defaults to port 2460. I would like to run multiple servers simultaneously. Of course, they can't all use port 2460 concurrently.

So the question is how does one change the UDP port either in the initialisation process of the Raspberry Pi and/or in the AMBE Server??

I suspect a file of two needs to be edited..... any ideas or suggestions??

I thank you for your contributions...73 Dev, 9Y4DG



--


“Your chances of success in any undertaking can
always be measured by your belief in yourself"
       ~Robert Collier~.

The pessimist complains about the wind.
The optimist expects it to change.
The leader adjusts the sails.

                 ~John Maxwell~

Teamwork is the ability to work together toward a common vision.
The ability to direct individual accomplishment toward organizational objectives.
It is the fuel that allows common people to attain uncommon results.
      ~ Anonymous~

We believe that:

"We make a living by what we get,
We make a life by what we give!"
          ~Winston Churchill~



--

73's

***********************************
CT1JIB / Jorge Santos
***********************************


Jorge
 

Sorry a typo

/usr/local/sbin/ambeserver -d -p 24999 -i /dev/ttyUSB0 -s 460800


On Wed, 30 Jan 2019 at 15:44, Jorge via Groups.Io <ct1jib=gmail.com@groups.io> wrote:
Hi all,

You can use switch "p" to change port number, exemp: usr/local/sbin/ambeserver -d -i -p 24999 /dev/ttyUSB0 -s 460800

Hope this help

On Wed, 30 Jan 2019 at 15:36, John D Hays - K7VE <john@...> wrote:
There are command line switches to set the port and device. 

On Wed, Jan 30, 2019, 05:05 Dev Gosine <dgosine@... wrote:
Thank you Frank for your very prompt response..

It seems as though you might be using Compass Linux. Unfortunately, I'm using Raspian Stretch., so there is no opendv folder and neither am I seeing any ambeserver-ttyUSB0.conf file to edit.

Thanks again buddy...73 Dev, 9Y4DG


On Wed, 30 Jan 2019 at 01:25, (null) (null) via Groups.Io <fdecuire=yahoo.com@groups.io> wrote:
Dev

I’m running multiple servers also and I did the following on the PI server:

pico /etc/opendv/ambeserver-ttyUSB0.conf
Changed the UDP port to 18307

Did UDP port forwarding on the router for 18307.

Frank k6fed 

On Jan 29, 2019, at 8:53 PM, Dev Gosine <dgosine@...> wrote:

Good day,
                   The AMBEServer defaults to port 2460. I would like to run multiple servers simultaneously. Of course, they can't all use port 2460 concurrently.

So the question is how does one change the UDP port either in the initialisation process of the Raspberry Pi and/or in the AMBE Server??

I suspect a file of two needs to be edited..... any ideas or suggestions??

I thank you for your contributions...73 Dev, 9Y4DG



--


“Your chances of success in any undertaking can
always be measured by your belief in yourself"
       ~Robert Collier~.

The pessimist complains about the wind.
The optimist expects it to change.
The leader adjusts the sails.

                 ~John Maxwell~

Teamwork is the ability to work together toward a common vision.
The ability to direct individual accomplishment toward organizational objectives.
It is the fuel that allows common people to attain uncommon results.
      ~ Anonymous~

We believe that:

"We make a living by what we get,
We make a life by what we give!"
          ~Winston Churchill~



--

73's

***********************************
CT1JIB / Jorge Santos
***********************************



--

73's

***********************************
CT1JIB / Jorge Santos
***********************************


 

A standard convention in Unix/Linux is to provide a simple usage message, by using an -h or --help flag to a command.

e.g.

ambeserver -h

will show you:
Usage: AMBEserver [-d] [-r] [-s speed] [-p port] [-i tty] [-v] [-x]\n

This shows you command line options to set the speed, port, and tty that ambeserver should use.


Dev 9Y4DG
 

Thanks guys.....Your feedback and responses were awesome!!

Mission accomplished!!!....73 Dev, 9Y4DG


On Wed, 30 Jan 2019 at 15:48, John D Hays - K7VE <john@...> wrote:

A standard convention in Unix/Linux is to provide a simple usage message, by using an -h or --help flag to a command.

e.g.

ambeserver -h

will show you:
Usage: AMBEserver [-d] [-r] [-s speed] [-p port] [-i tty] [-v] [-x]\n

This shows you command line options to set the speed, port, and tty that ambeserver should use.



--


“Your chances of success in any undertaking can
always be measured by your belief in yourself"
       ~Robert Collier~.

The pessimist complains about the wind.
The optimist expects it to change.
The leader adjusts the sails.

                 ~John Maxwell~

Teamwork is the ability to work together toward a common vision.
The ability to direct individual accomplishment toward organizational objectives.
It is the fuel that allows common people to attain uncommon results.
      ~ Anonymous~

We believe that:

"We make a living by what we get,
We make a life by what we give!"
          ~Winston Churchill~