Topics

AMBEServer DVStick 30 Compass Raspberry Pi #ambeserver


Al Mesa <hkradiogadget@...>
 

Hello,
I am having the following issue:
CONDITIONS: Raspberry Pi 3B+ Compass Linux, DVStick 30.
ISSUE After install without problems the AMBEserver per instructions and after start the AMBEServer service, a few seconds after the AMBEServer services stop and failed.
Please see the terminal detail:
 

^Xroot@compass:~# systemctl start ambeserver@...

root@compass:~# systemctl status ambeserver@...

● ambeserver@... - DV3000 Daemon

   Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled; vendor pres

   Active: active (running) since Thu 2019-02-28 11:14:00 EST; 31s ago

  Process: 20143 ExecStartPre=/bin/chmod 0660 /dev/ttyUSB0 (code=exited, status=

  Process: 20142 ExecStartPre=/bin/chgrp dialout /dev/ttyUSB0 (code=exited, stat

 Main PID: 20148 (AMBEserver)

   CGroup: /system.slice/system-ambeserver.slice/ambeserver@...

           └─20148 /usr/sbin/AMBEserver -p 2460 -i /dev/ttyUSB0

 

Feb 28 11:14:00 compass systemd[1]: Starting DV3000 Daemon...

Feb 28 11:14:00 compass systemd[1]: Started DV3000 Daemon.

Feb 28 11:14:00 compass AMBEserver[20148]: AMBEserver: Starting...

Feb 28 11:14:00 compass AMBEserver[20148]: AMBEserver: Opened serial port /dev/t

 

/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

 

pi@compass:~ $ sudo systemctl status ambeserver@...

● ambeserver@... - DV3000 Daemon

   Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled; vendor pres

   Active: failed (Result: exit-code) since Thu 2019-02-28 11:14:36 EST; 1min 27

  Process: 20148 ExecStart=/usr/sbin/AMBEserver -p ${UDP_PORT} -i /dev/ttyUSB0 $

  Process: 20143 ExecStartPre=/bin/chmod 0660 /dev/ttyUSB0 (code=exited, status=

  Process: 20142 ExecStartPre=/bin/chgrp dialout /dev/ttyUSB0 (code=exited, stat

 Main PID: 20148 (code=exited, status=1/FAILURE)

 

Feb 28 11:14:00 compass systemd[1]: Starting DV3000 Daemon...

Feb 28 11:14:00 compass systemd[1]: Started DV3000 Daemon.

Feb 28 11:14:00 compass AMBEserver[20148]: AMBEserver: Starting...

Feb 28 11:14:00 compass AMBEserver[20148]: AMBEserver: Opened serial port /dev/t

Feb 28 11:14:36 compass systemd[1]: ambeserver@...: Main process exi

Feb 28 11:14:36 compass systemd[1]: ambeserver@...: Unit entered fai

Feb 28 11:14:36 compass systemd[1]: ambeserver@...: Triggering OnFai

Feb 28 11:14:36 compass systemd[1]: ambeserver@...: Failed with resu


I am looking for any advice or information about what I need to do to fix this problem.
 
Thank you.
 
Al
W4RAM
 
[Note: DVStick 30 is not a product of NW Digital Radio - Moderator]


Stefsan
 

Hi Mesa,

at first ive running AMBEServer also with DV30 Stick in perfect value. I am using a normal actual raspian image on a raspi zero W and a 2b+ also.

Normally its to know that the physical port ist /dev/ttyUSB0 ( its the first USB device) and second the portspeed its 460800 Baud somewhere in the AMBEserver start script the information must transfered by starting trhe AMBEServer.

The needed Port for Application communication is 2460 UDP.


What to do: check in terminal on pi or via ssh if you can attach following folder when DV30 is connected to usb port of raspberry with command   ls /dev/ttyUSB*      it must come back with /dev/ttyUSB0 if that is right usb connection is ok

Other Problem could be that your user ( most its pi) is not in the group dailout) check with   sudo nano /etc/group   and find the line with  it must look like this ( pi is important, if not add it) dailout:x:20:pi

best is use a actual raspian and compile ( make , make install) the "github resource AMBE Server Marrold" in only 2 steps and crate a desktop start script in .config/autostart .

If you need assistance contact me its very easy.

BR Stefan DL1ESZ



Am 28.02.19 um 18:04 schrieb Al Mesa:

Hello,
I am having the following issue:
CONDITIONS: Raspberry Pi 3B+ Compass Linux, DVStick 30.
ISSUE After install without problems the AMBEserver per instructions and after start the AMBEServer service, a few seconds after the AMBEServer services stop and failed.
Please see the terminal detail:
 

^Xroot@compass:~# systemctl start ambeserver@...

root@compass:~# systemctl status ambeserver@...

ambeserver@... - DV3000 Daemon

   Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled; vendor pres

   Active: active (running) since Thu 2019-02-28 11:14:00 EST; 31s ago

  Process: 20143 ExecStartPre=/bin/chmod 0660 /dev/ttyUSB0 (code=exited, status=

  Process: 20142 ExecStartPre=/bin/chgrp dialout /dev/ttyUSB0 (code=exited, stat

 Main PID: 20148 (AMBEserver)

   CGroup: /system.slice/system-ambeserver.slice/ambeserver@...

           └─20148 /usr/sbin/AMBEserver -p 2460 -i /dev/ttyUSB0

 

Feb 28 11:14:00 compass systemd[1]: Starting DV3000 Daemon...

Feb 28 11:14:00 compass systemd[1]: Started DV3000 Daemon.

Feb 28 11:14:00 compass AMBEserver[20148]: AMBEserver: Starting...

Feb 28 11:14:00 compass AMBEserver[20148]: AMBEserver: Opened serial port /dev/t

 

/////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

 

pi@compass:~ $ sudo systemctl status ambeserver@...

ambeserver@... - DV3000 Daemon

   Loaded: loaded (/lib/systemd/system/ambeserver@.service; enabled; vendor pres

   Active: failed (Result: exit-code) since Thu 2019-02-28 11:14:36 EST; 1min 27

  Process: 20148 ExecStart=/usr/sbin/AMBEserver -p ${UDP_PORT} -i /dev/ttyUSB0 $

  Process: 20143 ExecStartPre=/bin/chmod 0660 /dev/ttyUSB0 (code=exited, status=

  Process: 20142 ExecStartPre=/bin/chgrp dialout /dev/ttyUSB0 (code=exited, stat

 Main PID: 20148 (code=exited, status=1/FAILURE)

 

Feb 28 11:14:00 compass systemd[1]: Starting DV3000 Daemon...

Feb 28 11:14:00 compass systemd[1]: Started DV3000 Daemon.

Feb 28 11:14:00 compass AMBEserver[20148]: AMBEserver: Starting...

Feb 28 11:14:00 compass AMBEserver[20148]: AMBEserver: Opened serial port /dev/t

Feb 28 11:14:36 compass systemd[1]: ambeserver@...: Main process exi

Feb 28 11:14:36 compass systemd[1]: ambeserver@...: Unit entered fai

Feb 28 11:14:36 compass systemd[1]: ambeserver@...: Triggering OnFai

Feb 28 11:14:36 compass systemd[1]: ambeserver@...: Failed with resu


I am looking for any advice or information about what I need to do to fix this problem.
 
Thank you.
 
Al
W4RAM
 
[Note: DVStick 30 is not a product of NW Digital Radio - Moderator]