Re: ThumbDV and AMBEserver : Couldn't find start byte in serial data


Ian
 

Santu,

I too had a similar problem with my ThumbDV until I changed over to compasslinux; I found it easier to use Compass as it is Raspbian Jessie with the UDRC driver and a few other minor updates and is available as lite or with GUI.

My version is:-
Linux compass03 4.4.22-v7+ #1 SMP Thu Sep 29 05:45:46 EDT 2016 armv7l GNU/Linux

and is running on a PI2 and PI3.

Just my thoughts.

Regards,
Ian..



Linux compass03 4.4.22-v7+ #1 SMP Thu Sep 29 05:45:46 EDT 2016 armv7l GNU/Linux

On 27-12-2016 20:14, Santu OTTAVI wrote:
Hi,
I'm trying to run AMBEserver with a ThumbDV on a Raspberry Pi 2
running Raspbian (with kernel 4.4.38).
I compiled AMBEserver from DL5DI OpenDV GitHub.
I try to run it with the following command :
/usr/bin/AMBEserver -d -i /dev/ttyUSB0 -s 460800
It seems to start :
AMBEserver: Opened serial port /dev/ttyUSB0 at 460800 bps.
Then, after a few seconds, I get the following errors :
AMBEserver: Couldn't find start byte in serial data
AMBEserver: error receiving response to reset
AMBEserver: Could not initialize the DV3K!
ThumbDV is brand new, out-of-the-box. I tried both speeds of 230400
and 460800, with same results.
Please note I didn't follow the installation procedure described here :
https://nw-digital-radio.groups.io/g/ambe/wiki/Installing-AMBEserver-on-a-Raspberry-Pi-and-ThumbDV%E2%84%A2
(I do not want to use an 'exotic' Linux distribution, I'd like to run
it on standard Raspbian).
Thank you in advance. 73 de TK1BI

Join main@nw-digital-radio.groups.io to automatically receive all group messages.