Re: ThumbDV and Mac OS


Dick Herrick
 

Anna

Sorry i’m still fumbling a bit.

Working now.
Listening fine on REF001 C.
I’ve set the space bar as the transmit button.
I would expect my calling to show up in the list of the Buster window, but it does not.
I do hear the chirp indicating that I’ve “done something”
The Yellow LED in the ThumbDV does light when I press that space bar.
Still I am apparently not transmitting.
Audio settings appear OK


Dick Herrick, BEE, PE
rjherrickpe@...

(Office) 704-509-2882
(Cell)    704-995-1522

On Aug 9, 2018, at 12:43 PM, Annaliese McDermond <nh6z@...> wrote:


On Aug 9, 2018, at 9:36 AM, Dick Herrick via Groups.Io <rjherrickpe@...> wrote:

Ha!  Of course you would have the answer as the author of the software.

It did indeed recognize the ThumbDV and the vocoder.  Is this something I would need to do every time or just an initial situation?

Just the first time.  What happens is that Buster initially defaults to the 230400 baud rate.  On first launch, it tries to talk to the ThumbDV at the wrong baud rate, and you get the “cannot talk to vocoder” dialog box.  The issue is that the wrong baud rate confuses the AMBE chip on the ThumbDV, so it essentially locks up.  Even if you now set the correct baud rate, it won’t work.  So, you have to get the baud rate set, and then reset the ThumbDV by reinserting it.  This makes it talk and everything’s good.  Buster will now remember this good configuration until you change it to something else.

On some reflection, what I probably should do is default the baud rate to 0, which guarantees things will fail without talking to the ThumbDV.  Then when people reset it, things are all good.

Anyhow, I’m glad you could get it to work.  Have fun with it!


Blessings, and thanks for your creativity …



Dick Herrick, BEE, PE
rjherrickpe@...

(Office) 704-509-2882
(Cell)    704-995-1522

— Anna, NH6Z,_._,_


Join main@nw-digital-radio.groups.io to automatically receive all group messages.