Date   

Re: ThumbDV and AMBEserver : Couldn't find start byte in serial data

 

Are you sure the ThumbDV is at /dev/ttyUSB0 ? (ls /dev/ttyUSB?)

Have you tried the python test scripts?

If you have a Windows box handy, you can also test using ThumbTest.exe from https://nw-digital-radio.groups.io/g/ambe/files

If it is a newly purchased ThumbDV the baud rate is 460800

On Tue, Dec 27, 2016 at 12:14 PM, Santu OTTAVI <t.ottavi@...> wrote:
Hi,

I'm trying to run AMBEserver with a ThumbDV on a Raspberry Pi 2 running Raspbian (with kernel 4.4.38).

I compiled AMBEserver from DL5DI OpenDV GitHub.

I try to run it with the following command :
  /usr/bin/AMBEserver -d -i /dev/ttyUSB0 -s 460800

It seems to start :
  AMBEserver: Opened serial port /dev/ttyUSB0 at 460800 bps.

Then, after a few seconds, I get the following errors :
  AMBEserver: Couldn't find start byte in serial data
  AMBEserver: error receiving response to reset
  AMBEserver: Could not initialize the DV3K!

ThumbDV is brand new, out-of-the-box. I tried both speeds of 230400 and 460800, with same results.

Please note I didn't follow the installation procedure described here :
https://nw-digital-radio.groups.io/g/ambe/wiki/Installing-AMBEserver-on-a-Raspberry-Pi-and-ThumbDV%E2%84%A2
(I do not want to use an 'exotic' Linux distribution, I'd like to run it on standard Raspbian).

Thank you in advance. 73 de TK1BI










--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   


Re: ThumbDV and AMBEserver : Couldn't find start byte in serial data

Ian
 

Santu,

I too had a similar problem with my ThumbDV until I changed over to compasslinux; I found it easier to use Compass as it is Raspbian Jessie with the UDRC driver and a few other minor updates and is available as lite or with GUI.

My version is:-
Linux compass03 4.4.22-v7+ #1 SMP Thu Sep 29 05:45:46 EDT 2016 armv7l GNU/Linux

and is running on a PI2 and PI3.

Just my thoughts.

Regards,
Ian..



Linux compass03 4.4.22-v7+ #1 SMP Thu Sep 29 05:45:46 EDT 2016 armv7l GNU/Linux

On 27-12-2016 20:14, Santu OTTAVI wrote:
Hi,
I'm trying to run AMBEserver with a ThumbDV on a Raspberry Pi 2
running Raspbian (with kernel 4.4.38).
I compiled AMBEserver from DL5DI OpenDV GitHub.
I try to run it with the following command :
/usr/bin/AMBEserver -d -i /dev/ttyUSB0 -s 460800
It seems to start :
AMBEserver: Opened serial port /dev/ttyUSB0 at 460800 bps.
Then, after a few seconds, I get the following errors :
AMBEserver: Couldn't find start byte in serial data
AMBEserver: error receiving response to reset
AMBEserver: Could not initialize the DV3K!
ThumbDV is brand new, out-of-the-box. I tried both speeds of 230400
and 460800, with same results.
Please note I didn't follow the installation procedure described here :
https://nw-digital-radio.groups.io/g/ambe/wiki/Installing-AMBEserver-on-a-Raspberry-Pi-and-ThumbDV%E2%84%A2
(I do not want to use an 'exotic' Linux distribution, I'd like to run
it on standard Raspbian).
Thank you in advance. 73 de TK1BI


ThumbDV and AMBEserver : Couldn't find start byte in serial data

Santu OTTAVI (TK1BI)
 

Hi,

I'm trying to run AMBEserver with a ThumbDV on a Raspberry Pi 2 running Raspbian (with kernel 4.4.38).

I compiled AMBEserver from DL5DI OpenDV GitHub.

I try to run it with the following command :
/usr/bin/AMBEserver -d -i /dev/ttyUSB0 -s 460800

It seems to start :
AMBEserver: Opened serial port /dev/ttyUSB0 at 460800 bps.

Then, after a few seconds, I get the following errors :
AMBEserver: Couldn't find start byte in serial data
AMBEserver: error receiving response to reset
AMBEserver: Could not initialize the DV3K!

ThumbDV is brand new, out-of-the-box. I tried both speeds of 230400 and 460800, with same results.

Please note I didn't follow the installation procedure described here :
https://nw-digital-radio.groups.io/g/ambe/wiki/Installing-AMBEserver-on-a-Raspberry-Pi-and-ThumbDV%E2%84%A2
(I do not want to use an 'exotic' Linux distribution, I'd like to run it on standard Raspbian).

Thank you in advance. 73 de TK1BI


Re: error: unable to retrieve device version

j.lineback
 

Follow your instincts  and browse for DStar.  The first hit you should see is dstarinfo.  Front page says "Am I registered?"

Sent from my iPhone

On Dec 23, 2016, at 10:03 PM, Jp Colville <colville500@...> wrote:



On Fri, Dec 23, 2016 at 3:52 PM John D Hays - K7VE <john@...> wrote:
REF030 C  and REF001 C  are two of the busiest - connect to them and listen for awhile.  Try putting out a call.

I don't use WinDV on a day to day basis (I tend to use RF or Buster with AMBEserver), so perhaps someone who does can provide additional input.


On Mon, Dec 19, 2016 at 9:47 PM, Jp Colville <colville500@...> wrote:
ok John....getting close....I can connect now, was messing with the gateway settings. I don't hear anyone...but  I am connected now. What should my gateway settings be?











-- aparently no one tells a guy he needs to register with the dstar network. Even the you tube vid i saw doesnt tell you that. Whynare they so secrative about getting this going, no directions from mw digital. i dont get it



John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   












Re: error: unable to retrieve device version

Jp Colville <colville500@...>
 



On Fri, Dec 23, 2016 at 3:52 PM John D Hays - K7VE <john@...> wrote:
REF030 C  and REF001 C  are two of the busiest - connect to them and listen for awhile.  Try putting out a call.

I don't use WinDV on a day to day basis (I tend to use RF or Buster with AMBEserver), so perhaps someone who does can provide additional input.


On Mon, Dec 19, 2016 at 9:47 PM, Jp Colville <colville500@...> wrote:
ok John....getting close....I can connect now, was messing with the gateway settings. I don't hear anyone...but  I am connected now. What should my gateway settings be?











-- aparently no one tells a guy he needs to register with the dstar network. Even the you tube vid i saw doesnt tell you that. Whynare they so secrative about getting this going, no directions from mw digital. i dont get it



John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   












Re: error: unable to retrieve device version

 

REF030 C  and REF001 C  are two of the busiest - connect to them and listen for awhile.  Try putting out a call.

I don't use WinDV on a day to day basis (I tend to use RF or Buster with AMBEserver), so perhaps someone who does can provide additional input.


On Mon, Dec 19, 2016 at 9:47 PM, Jp Colville <colville500@...> wrote:
ok John....getting close....I can connect now, was messing with the gateway settings. I don't hear anyone...but  I am connected now. What should my gateway settings be?




--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   


Re: error: unable to retrieve device version

Jp Colville <colville500@...>
 

ok John....getting close....I can connect now, was messing with the gateway settings. I don't hear anyone...but  I am connected now. What should my gateway settings be?


Re: error: unable to retrieve device version

 

On Mon, Dec 19, 2016 at 9:24 PM, Jp Colville <colville500@...> wrote:
It was the baud rate setting.just figured that part out...but....  i am using the 1.5.8 software version. Now it seems that I am not connected, and the connect button is grayed out. i am making a little headway, that baud issue really had me going there. Thanks for your help John.




--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   


Re: error: unable to retrieve device version

Jp Colville <colville500@...>
 

It was the baud rate setting.just figured that part out...but....  i am using the 1.5.8 software version. Now it seems that I am not connected, and the connect button is grayed out. i am making a little headway, that baud issue really had me going there. Thanks for your help John.


Re: error: unable to retrieve device version

 

What program? Do you have the correct com port and baud rate?

On Dec 19, 2016 21:03, "Jp Colville" <colville500@...> wrote:

got this error on both a pc and a tablet. windows 10. any ideas?


error: unable to retrieve device version

Jp Colville <colville500@...>
 

got this error on both a pc and a tablet. windows 10. any ideas?


Re: Holiday Sale on the ThumbDV for $99.95

Jose Manuel Martinez Barbera
 

What program can I use the dv3000u Thumbdv in dmr?

El El mar, 29 nov 2016 a las 22:10, Barry Bettman <k6st@...> escribió:
Is there any software to access DMR with the NW Thumbdv ?



On Tue, Nov 29, 2016 at 2:04 PM, John D Hays - K7VE <john@...> wrote:

Visit: http://nwdigitalradio.com/product/thumbdv/


















--
Enviado desde EA8EE red movil


Re: WinDV

Brendan O'Neill
 

I understand the support situation, thank you for your reply. I have attempted to get this going ion a Win 7 Enterprise laptop and I am having the exact same issues with being troubled with display issues. I have sent 5 communications to DutchStar and have zero replies, so now I have 2 different Windows versions experiencing the exact same issue with display issues keeping me from using the WinDV software.


I will look into the AmbeServer that someone else was suggesting but Buster is working and I do believe in the Keep it Simple S_____ method, so if it works why break it, right ?


73,

Brendan

KM4HRR


Re: WinDV

Scott Currie
 

I suspect an incompatibility between WinDV and Win10 and/or your computer. I have run WinDV on a Win7 system with a ThumbDV for weeks on end without any problems. WinDV is still considered beta, and has not seen any updates from Dutch*Star in some time (nearly 2 years ago). I'm not sure it was even tested on Win10.

-Scott, NS7C

On Thu, Dec 8, 2016 at 10:33 PM, Brendan O'Neill <brendan.oneill@...> wrote:

I've gone roughly 1hour w/o the app crashing or having display issues but the "stop" button to end a transmission is failing to engage once a transmission has begun. Thet's just bad amateur radio practice and if it's the app failing then that's no good. It's a pretty app but I'm not sure it's a very reliable app at this time. Well, I hope it's been noticed and addressed. I have no idea if they are reading my submissions, I get no replies.


I do not want just complain or point out faults. I do appreciate the application and the effort that's been put into it. So, thank you for the app and I hope my donation goes toward making it a better app.


73,

Brendan

KM4HRR




--
-Scott


Re: WinDV

 

Brendan,

Since you have a Mac and Windows, you might want to consider setting up an AMBE server on your LAN, see: https://nw-digital-radio.groups.io/g/ambe/wiki/Installing-AMBEserver-on-a-Raspberry-Pi-and-ThumbDV%E2%84%A2

Buster can address it, and DummyRepeater (+ ircDDBGateway) can address it on Windows.

I am sorry you are having difficulty with WinDV, but NW Digital Radio is only able to provide support for the ThumbDV and PiDV in the AMBE area.  Software support must come from the software authors.

By the way, there is a group specific for these devices at https://nw-digital-radio.groups.io/g/ambe

On Thu, Dec 8, 2016 at 10:33 PM, Brendan O'Neill <brendan.oneill@...> wrote:

I've gone roughly 1hour w/o the app crashing or having display issues but the "stop" button to end a transmission is failing to engage once a transmission has begun. Thet's just bad amateur radio practice and if it's the app failing then that's no good. It's a pretty app but I'm not sure it's a very reliable app at this time. Well, I hope it's been noticed and addressed. I have no idea if they are reading my submissions, I get no replies.


I do not want just complain or point out faults. I do appreciate the application and the effort that's been put into it. So, thank you for the app and I hope my donation goes toward making it a better app.


73,

Brendan

KM4HRR




--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   


Re: WinDV

Brendan O'Neill
 

I've gone roughly 1hour w/o the app crashing or having display issues but the "stop" button to end a transmission is failing to engage once a transmission has begun. Thet's just bad amateur radio practice and if it's the app failing then that's no good. It's a pretty app but I'm not sure it's a very reliable app at this time. Well, I hope it's been noticed and addressed. I have no idea if they are reading my submissions, I get no replies.


I do not want just complain or point out faults. I do appreciate the application and the effort that's been put into it. So, thank you for the app and I hope my donation goes toward making it a better app.


73,

Brendan

KM4HRR


Re: WinDV

Brendan O'Neill
 

Well, that was short lived. It's back to it's old ways again. Unacceptable That I'd have to do a regedit and reconfigure software each time I want to use the software. WinDV needs work! To bad DutchStar does not reply to emails. I've sent 3 all with no reply.


73,

Brendan

KM4HRR


Re: WinDV

Brendan O'Neill
 

Well, looks like I'm back up and running. I had to do the Regedit and remove the entire folder under Software and rerun the installer, I did I have do this two times for it to work but I now have WinDV running and working on my Win10 Surf e Pro2.


here is what I did:


Windows Key + r

type regedit 

click ok

click yes 

scroll to HKEY_CURRENT_USER

expand with arrow 

scroll to SOFTWARE

expand with arrow

scroll to MicroWalt Corporation

highlight, right click delete

rerun WinDV installer

once installed run WinDV in Win7 Compatability Mode



this was a frustrating battle but it's fixed and I'm happy.


73,

Brendan

KM4HRR


Re: UDRC Demo by NH6Z at MicroHAMS 2016

Julie McGrew
 

Bryan,

Thank you very much for the information and the informative link.

73,

julie


Re: UDRC Demo by NH6Z at MicroHAMS 2016

 

Hi Julie,

It was just a stock case hand modified as a proof of concept. The display is connected but doesn’t do anything.

Check out this case by Budd Churchward:


On Dec 8, 2016, at 11:48 AM, Julie McGrew <juliemcgrew@...> wrote:

During the video UDRC demo done by NH6Z at MicroHAMS 2016, the setup for the UDRC is shown in a great rack mount case with a touch screen in the face plate.  Would someone be so kind as to point me in the direction I may purchase both the rack mount case and the touch screen for our own installation with a DR-1X?

Many thanks & 73,
julie mcgrew
AC0WN