Topics

2m rig Update

Steve McGrane <temporarilyoffline@...>
 

IT WORKS!  (so far)
Untitled.png
With my makeshift TM-281 cable I was able to receive an APRS message sent from my potatofeng using the APRS-K2 cable plugged into my android.

Next I have to send a message from my 281 and receive it on my droid.

Then I'll be able to start working on Xastir.  Anybody got any docs for getting Xastir to work with DRAWS?

Basil Gunn
 

Steve McGrane <temporarilyoffline@...> writes:

IT WORKS! (so far)
Nice work Steve.

[image: Untitled.png]
With my makeshift TM-281 cable I was able to receive an APRS message sent
from my potatofeng using the APRS-K2 cable plugged into my android.

Next I have to send a message from my 281 and receive it on my droid.

Then I'll be able to start working on Xastir. Anybody got any docs for
getting Xastir to work with DRAWS?
The lastest version is installed on the DRAWS Beta image
Xastir V2.1.1

This points to some notes I made to get Xastir working.

https://github.com/nwdigitalradio/n7nix/tree/master/xastir

/Basil

 

Start XASTIR  and go into interfaces, then configure an AGW or KISS over TCP connection. You can also configure a GPSD interface to localhost for position reports from the integrated GPS.


On Fri, May 24, 2019, 14:34 Steve McGrane <temporarilyoffline@...> wrote:
IT WORKS!  (so far)
Untitled.png
With my makeshift TM-281 cable I was able to receive an APRS message sent from my potatofeng using the APRS-K2 cable plugged into my android.

Next I have to send a message from my 281 and receive it on my droid.

Then I'll be able to start working on Xastir.  Anybody got any docs for getting Xastir to work with DRAWS?

Steve McGrane <temporarilyoffline@...>
 

image.png


I guessed at those two and they are both "UP" and I even got a CLI output on the direwolf console... now to get them to do anything...  (my map is blank, even after my self-beaconing)

Still running through Basil's directions.


On Fri, May 24, 2019 at 5:14 PM John D Hays - K7VE <john@...> wrote:
Start XASTIR  and go into interfaces, then configure an AGW or KISS over TCP connection. You can also configure a GPSD interface to localhost for position reports from the integrated GPS.

On Fri, May 24, 2019, 14:34 Steve McGrane <temporarilyoffline@...> wrote:
IT WORKS!  (so far)
Untitled.png
With my makeshift TM-281 cable I was able to receive an APRS message sent from my potatofeng using the APRS-K2 cable plugged into my android.

Next I have to send a message from my 281 and receive it on my droid.

Then I'll be able to start working on Xastir.  Anybody got any docs for getting Xastir to work with DRAWS?

 

Your device 0 looks incorrect. Core servers would be something like noam.aprs2.net 

The direwolf would be localhost:8000 or 8001 depending on protocol. 

On Fri, May 24, 2019, 15:49 Steve McGrane <temporarilyoffline@...> wrote:
image.png


I guessed at those two and they are both "UP" and I even got a CLI output on the direwolf console... now to get them to do anything...  (my map is blank, even after my self-beaconing)

Still running through Basil's directions.

On Fri, May 24, 2019 at 5:14 PM John D Hays - K7VE <john@...> wrote:
Start XASTIR  and go into interfaces, then configure an AGW or KISS over TCP connection. You can also configure a GPSD interface to localhost for position reports from the integrated GPS.

On Fri, May 24, 2019, 14:34 Steve McGrane <temporarilyoffline@...> wrote:
IT WORKS!  (so far)
Untitled.png
With my makeshift TM-281 cable I was able to receive an APRS message sent from my potatofeng using the APRS-K2 cable plugged into my android.

Next I have to send a message from my 281 and receive it on my droid.

Then I'll be able to start working on Xastir.  Anybody got any docs for getting Xastir to work with DRAWS?

Steve McGrane <temporarilyoffline@...>
 

Core INET is just a comment, I can make it say anything (DRAWS)?



On Fri, May 24, 2019 at 5:53 PM John D Hays - K7VE <john@...> wrote:
Your device 0 looks incorrect. Core servers would be something like noam.aprs2.net 

The direwolf would be localhost:8000 or 8001 depending on protocol. 

On Fri, May 24, 2019, 15:49 Steve McGrane <temporarilyoffline@...> wrote:
image.png


I guessed at those two and they are both "UP" and I even got a CLI output on the direwolf console... now to get them to do anything...  (my map is blank, even after my self-beaconing)

Still running through Basil's directions.

On Fri, May 24, 2019 at 5:14 PM John D Hays - K7VE <john@...> wrote:
Start XASTIR  and go into interfaces, then configure an AGW or KISS over TCP connection. You can also configure a GPSD interface to localhost for position reports from the integrated GPS.

On Fri, May 24, 2019, 14:34 Steve McGrane <temporarilyoffline@...> wrote:
IT WORKS!  (so far)
Untitled.png
With my makeshift TM-281 cable I was able to receive an APRS message sent from my potatofeng using the APRS-K2 cable plugged into my android.

Next I have to send a message from my 281 and receive it on my droid.

Then I'll be able to start working on Xastir.  Anybody got any docs for getting Xastir to work with DRAWS?

Basil Gunn
 

From my Xastir install doc device 0 should be:
Networked AGWPE (localhost:8000)
/Basil

Steve McGrane <temporarilyoffline@...> writes:

[image: image.png]


I guessed at those two and they are both "UP" and I even got a CLI output
on the direwolf console... now to get them to do anything... (my map is
blank, even after my self-beaconing)

Still running through Basil's directions.

On Fri, May 24, 2019 at 5:14 PM John D Hays - K7VE <@john_hays> wrote:

Start XASTIR and go into interfaces, then configure an AGW or KISS over
TCP connection. You can also configure a GPSD interface to localhost for
position reports from the integrated GPS.

On Fri, May 24, 2019, 14:34 Steve McGrane <temporarilyoffline@...>
wrote:

IT WORKS! (so far)
[image: Untitled.png]
With my makeshift TM-281 cable I was able to receive an APRS message sent
from my potatofeng using the APRS-K2 cable plugged into my android.

Next I have to send a message from my 281 and receive it on my droid.

Then I'll be able to start working on Xastir. Anybody got any docs for
getting Xastir to work with DRAWS?

David Lowry
 

https://imgur.com/iMaXWRR

Not sure if it is correct but is sure fills up my map.

Steve McGrane <temporarilyoffline@...>
 

So far I can receive only.

I'm getting a little screwed up in the pin labeling and what side of the cable I'm on.

What I have so far:

Cable from DRAWS w/end cut reveals

Pin 6 Green
Pin 5 Black
Pin 4 Orange
Pin 3 Yellow
Pin 2 Brown
Pin 1 Red

Radio uses an RJ-45 MIC cable and a speaker audio

Pin 1 N/C
Pin 2 DC 8V
Pin 3 GND
Pin 4 PTT
Pin 5 GND (MIC)
Pin 6 MIC
Pin 7 N/C
Pin 8 DTMF Data

Plus TRS on rear audio 1/8th jack

I have
DRAWS = Radio
1 = 6
2 = 5
3 = 4
4 = N/C
5 = Rear Speaker TIP
6 = N/C
GND = N/C

Any thoughts?


On Fri, May 24, 2019 at 6:47 PM David Lowry <huskyrunnr@...> wrote:
https://imgur.com/iMaXWRR

Not sure if it is correct but is sure fills up my map.

Steve McGrane <temporarilyoffline@...>
 

Follow-up to the cable issue.

I've double checked the setup.  If I put the hand mic back in line and Press PTT, my receiving radio breaks squelch, so it would seem that the PTT circuit is not activating from DRAWS.

I checked with Basil's notes and I've got PTT setup for 12 & 23.  For grins, I've reversed the GPIO numbers and cables such that I've hit all combos of l/r ports and 12/13 GPIOs. still no joy.

Any thoughts?


On Fri, May 24, 2019 at 7:25 PM Temporarily Offline <temporarilyoffline@...> wrote:
So far I can receive only.

I'm getting a little screwed up in the pin labeling and what side of the cable I'm on.

What I have so far:

Cable from DRAWS w/end cut reveals

Pin 6 Green
Pin 5 Black
Pin 4 Orange
Pin 3 Yellow
Pin 2 Brown
Pin 1 Red

Radio uses an RJ-45 MIC cable and a speaker audio

Pin 1 N/C
Pin 2 DC 8V
Pin 3 GND
Pin 4 PTT
Pin 5 GND (MIC)
Pin 6 MIC
Pin 7 N/C
Pin 8 DTMF Data

Plus TRS on rear audio 1/8th jack

I have
DRAWS = Radio
1 = 6
2 = 5
3 = 4
4 = N/C
5 = Rear Speaker TIP
6 = N/C
GND = N/C

Any thoughts?

On Fri, May 24, 2019 at 6:47 PM David Lowry <huskyrunnr@...> wrote:
https://imgur.com/iMaXWRR

Not sure if it is correct but is sure fills up my map.

Basil Gunn
 

To debug PTT issues:
Use the 'How to use measure_deviate.sh' notes here:
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

Use left & right connector locations and either tune a second radio to
the same frequency as your test radio so you can hear the tone or watch
your radio to see if it transmits. If that doesn't work you have a cable
problem.

/Basil


Steve McGrane <temporarilyoffline@...> writes:

Follow-up to the cable issue.

I've double checked the setup. If I put the hand mic back in line and
Press PTT, my receiving radio breaks squelch, so it would seem that the PTT
circuit is not activating from DRAWS.

I checked with Basil's notes and I've got PTT setup for 12 & 23. For
grins, I've reversed the GPIO numbers and cables such that I've hit all
combos of l/r ports and 12/13 GPIOs. still no joy.

Any thoughts?

On Fri, May 24, 2019 at 7:25 PM Temporarily Offline <
temporarilyoffline@...> wrote:

So far I can receive only.

I'm getting a little screwed up in the pin labeling and what side of the
cable I'm on.

What I have so far:

Cable from DRAWS w/end cut reveals

Pin 6 Green
Pin 5 Black
Pin 4 Orange
Pin 3 Yellow
Pin 2 Brown
Pin 1 Red

Radio uses an RJ-45 MIC cable and a speaker audio

Pin 1 N/C
Pin 2 DC 8V
Pin 3 GND
Pin 4 PTT
Pin 5 GND (MIC)
Pin 6 MIC
Pin 7 N/C
Pin 8 DTMF Data

Plus TRS on rear audio 1/8th jack

I have
DRAWS = Radio
1 = 6
2 = 5
3 = 4
4 = N/C
5 = Rear Speaker TIP
6 = N/C
GND = N/C

Any thoughts?

On Fri, May 24, 2019 at 6:47 PM David Lowry <huskyrunnr@...> wrote:

https://imgur.com/iMaXWRR

Not sure if it is correct but is sure fills up my map.


Steve McGrane <temporarilyoffline@...>
 

I got some time today (its raining!) to play with this.

Initially the measure_deviation.sh script would run and not trip the PTT circuit.  So I re-wired the cable and after looking more closely, I don't even understand why it worked in the first place.  I think originally I had the speaker from the radio connected to the ground pin on the draws din6 connector???  maybe the ground is "noisy enough" that it got picked up elsewhere???

Here is my rewire:

Radio MIC   to DRAWS AFOUT
Radio PTT   to DRAWS PTT
Radio GND   to DRAWS GND
Radio AFOUT to DRAWS AFIN

(I'm guessing that a common ground would help out.  The DRAWS and the radio are plugged into the same power supply, so this could also be creating a loop)

And the results are that measure_deviate.sh will trip the PTT, but will not stop PTTing.

The DRAWS will both send and receive APRS messages using XASTIR.  XASTIR repeats the "text message" several times and has the same "won't stop PTTing" problem.

So its progress... but it comes at a price.

1. Any ideas on the won't stop PTTing issue?
2. If you think I'm making a ground loop and shouldn't let me know.

Thanks,
- Steve


On Sat, May 25, 2019 at 8:19 PM Basil Gunn <basil@...> wrote:

To debug PTT issues:
Use the 'How to use measure_deviate.sh' notes here:
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

Use left & right connector locations and either tune a second radio to
the same frequency as your test radio so you can hear the tone or watch
your radio to see if it transmits. If that doesn't work you have a cable
problem.

/Basil


Steve McGrane <temporarilyoffline@...> writes:

> Follow-up to the cable issue.
>
> I've double checked the setup.  If I put the hand mic back in line and
> Press PTT, my receiving radio breaks squelch, so it would seem that the PTT
> circuit is not activating from DRAWS.
>
> I checked with Basil's notes and I've got PTT setup for 12 & 23.  For
> grins, I've reversed the GPIO numbers and cables such that I've hit all
> combos of l/r ports and 12/13 GPIOs. still no joy.
>
> Any thoughts?
>
> On Fri, May 24, 2019 at 7:25 PM Temporarily Offline <
> temporarilyoffline@...> wrote:
>
>> So far I can receive only.
>>
>> I'm getting a little screwed up in the pin labeling and what side of the
>> cable I'm on.
>>
>> What I have so far:
>>
>> Cable from DRAWS w/end cut reveals
>>
>> Pin 6 Green
>> Pin 5 Black
>> Pin 4 Orange
>> Pin 3 Yellow
>> Pin 2 Brown
>> Pin 1 Red
>>
>> Radio uses an RJ-45 MIC cable and a speaker audio
>>
>> Pin 1 N/C
>> Pin 2 DC 8V
>> Pin 3 GND
>> Pin 4 PTT
>> Pin 5 GND (MIC)
>> Pin 6 MIC
>> Pin 7 N/C
>> Pin 8 DTMF Data
>>
>> Plus TRS on rear audio 1/8th jack
>>
>> I have
>> DRAWS = Radio
>> 1 = 6
>> 2 = 5
>> 3 = 4
>> 4 = N/C
>> 5 = Rear Speaker TIP
>> 6 = N/C
>> GND = N/C
>>
>> Any thoughts?
>>
>> On Fri, May 24, 2019 at 6:47 PM David Lowry <huskyrunnr@...> wrote:
>>
>>> https://imgur.com/iMaXWRR
>>>
>>> Not sure if it is correct but is sure fills up my map.
>>>
>>>
>>>
>
>



Basil Gunn
 

Verify the DRAWS hat
--------------------
Disconnect the cable from your radio but plug into DRAWS hat
on the open connector put your volt meter on what you think is the PTT pin

Manually turn the gpio for PTT on & off

Left connector:
PTT On:
gpio -g write 12 1
PTT Off:
gpio -g write 12 0
PTT Check:
gio -g read 12

Right connector:
PTT On:
gpio -g write 23 1
PTT Off:
gpio -g write 23 0
PTT Check:
gio -g read 23

Verify your radio
-----------------

Disconnect the cable from DRAWS hat & connect to radio.
Ground the pin you think is the PTT pin ... did your radio transmit?
Un-ground the PTT pin ... did the radio stop transmitting?

/Basil



Steve McGrane <temporarilyoffline@...> writes:

I got some time today (its raining!) to play with this.

Initially the measure_deviation.sh script would run and not trip the PTT
circuit. So I re-wired the cable and after looking more closely, I don't
even understand why it worked in the first place. I think originally I had
the speaker from the radio connected to the ground pin on the draws din6
connector??? maybe the ground is "noisy enough" that it got picked up
elsewhere???

Here is my rewire:

Radio MIC to DRAWS AFOUT
Radio PTT to DRAWS PTT
Radio GND to DRAWS GND
Radio AFOUT to DRAWS AFIN

(I'm guessing that a common ground would help out. The DRAWS and the radio
are plugged into the same power supply, so this could also be creating a
loop)

And the results are that measure_deviate.sh will trip the PTT, but will not
stop PTTing.

The DRAWS will both send and receive APRS messages using XASTIR. XASTIR
repeats the "text message" several times and has the same "won't stop
PTTing" problem.

So its progress... but it comes at a price.

1. Any ideas on the won't stop PTTing issue?
2. If you think I'm making a ground loop and shouldn't let me know.

Thanks,
- Steve

On Sat, May 25, 2019 at 8:19 PM Basil Gunn <@basil860> wrote:


To debug PTT issues:
Use the 'How to use measure_deviate.sh' notes here:
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

Use left & right connector locations and either tune a second radio to
the same frequency as your test radio so you can hear the tone or watch
your radio to see if it transmits. If that doesn't work you have a cable
problem.

/Basil


Steve McGrane <temporarilyoffline@...> writes:

Follow-up to the cable issue.

I've double checked the setup. If I put the hand mic back in line and
Press PTT, my receiving radio breaks squelch, so it would seem that the
PTT
circuit is not activating from DRAWS.

I checked with Basil's notes and I've got PTT setup for 12 & 23. For
grins, I've reversed the GPIO numbers and cables such that I've hit all
combos of l/r ports and 12/13 GPIOs. still no joy.

Any thoughts?

On Fri, May 24, 2019 at 7:25 PM Temporarily Offline <
temporarilyoffline@...> wrote:

So far I can receive only.

I'm getting a little screwed up in the pin labeling and what side of the
cable I'm on.

What I have so far:

Cable from DRAWS w/end cut reveals

Pin 6 Green
Pin 5 Black
Pin 4 Orange
Pin 3 Yellow
Pin 2 Brown
Pin 1 Red

Radio uses an RJ-45 MIC cable and a speaker audio

Pin 1 N/C
Pin 2 DC 8V
Pin 3 GND
Pin 4 PTT
Pin 5 GND (MIC)
Pin 6 MIC
Pin 7 N/C
Pin 8 DTMF Data

Plus TRS on rear audio 1/8th jack

I have
DRAWS = Radio
1 = 6
2 = 5
3 = 4
4 = N/C
5 = Rear Speaker TIP
6 = N/C
GND = N/C

Any thoughts?

On Fri, May 24, 2019 at 6:47 PM David Lowry <huskyrunnr@...> wrote:

https://imgur.com/iMaXWRR

Not sure if it is correct but is sure fills up my map.




Steve McGrane <temporarilyoffline@...>
 

Thanks for getting back to me.

DRAWS Side:

Pin 3/Orange writing 1 to pin 12 will raise voltage to 4.22v
PTT light goes on

Pin 3/Orange writing 0 to pin 12 will lower voltage to 3.6mv
PTT light goes off

Removing the cable I think is PTT on the radio side and touching the ground on the DRAWS side (Pin 5) results in open transmit until removed.

New Development:  If I have radio and DRAWS connected properly I can turn on PTT with CLI.  When I turn off PTT at CLI, DRAWS PTT light goes out, THEN if I touch something to the PTT it adds enough resistance to pull the circuit down and turn off the radio.

So I tried some resistors in-line:

1.0k = Too Much PTT wouldn't open
____?
820 = Close, works, but  not very reliably
570 = Too Little PTT wouldn't close

outside of that, I'm either out of ideas or parts.

`gpio -g write 12 1 && sleep 1 && gpio -g write 12 0`

Any thoughts are welcome?


On Mon, May 27, 2019 at 2:17 PM Basil Gunn <basil@...> wrote:

Verify the DRAWS hat
--------------------
Disconnect the cable from your radio but plug into DRAWS hat
on the open connector put your volt meter on what you think is the PTT pin

Manually turn the gpio for PTT on & off

Left connector:
PTT On:
gpio -g write 12 1
PTT Off:
gpio -g write 12 0
PTT Check:
gio -g read 12

Right connector:
PTT On:
gpio -g write 23 1
PTT Off:
gpio -g write 23 0
PTT Check:
gio -g read 23

Verify your radio
-----------------

Disconnect the cable from DRAWS hat & connect to radio.
Ground the pin you think is the PTT pin ... did your radio transmit?
Un-ground the PTT pin ... did the radio stop transmitting?

/Basil



Steve McGrane <temporarilyoffline@...> writes:

> I got some time today (its raining!) to play with this.
>
> Initially the measure_deviation.sh script would run and not trip the PTT
> circuit.  So I re-wired the cable and after looking more closely, I don't
> even understand why it worked in the first place.  I think originally I had
> the speaker from the radio connected to the ground pin on the draws din6
> connector???  maybe the ground is "noisy enough" that it got picked up
> elsewhere???
>
> Here is my rewire:
>
> Radio MIC   to DRAWS AFOUT
> Radio PTT   to DRAWS PTT
> Radio GND   to DRAWS GND
> Radio AFOUT to DRAWS AFIN
>
> (I'm guessing that a common ground would help out.  The DRAWS and the radio
> are plugged into the same power supply, so this could also be creating a
> loop)
>
> And the results are that measure_deviate.sh will trip the PTT, but will not
> stop PTTing.
>
> The DRAWS will both send and receive APRS messages using XASTIR.  XASTIR
> repeats the "text message" several times and has the same "won't stop
> PTTing" problem.
>
> So its progress... but it comes at a price.
>
> 1. Any ideas on the won't stop PTTing issue?
> 2. If you think I'm making a ground loop and shouldn't let me know.
>
> Thanks,
> - Steve
>
> On Sat, May 25, 2019 at 8:19 PM Basil Gunn <basil@...> wrote:
>
>>
>> To debug PTT issues:
>> Use the 'How to use measure_deviate.sh' notes here:
>> https://github.com/nwdigitalradio/n7nix/tree/master/deviation
>>
>> Use left & right connector locations and either tune a second radio to
>> the same frequency as your test radio so you can hear the tone or watch
>> your radio to see if it transmits. If that doesn't work you have a cable
>> problem.
>>
>> /Basil
>>
>>
>> Steve McGrane <temporarilyoffline@...> writes:
>>
>> > Follow-up to the cable issue.
>> >
>> > I've double checked the setup.  If I put the hand mic back in line and
>> > Press PTT, my receiving radio breaks squelch, so it would seem that the
>> PTT
>> > circuit is not activating from DRAWS.
>> >
>> > I checked with Basil's notes and I've got PTT setup for 12 & 23.  For
>> > grins, I've reversed the GPIO numbers and cables such that I've hit all
>> > combos of l/r ports and 12/13 GPIOs. still no joy.
>> >
>> > Any thoughts?
>> >
>> > On Fri, May 24, 2019 at 7:25 PM Temporarily Offline <
>> > temporarilyoffline@...> wrote:
>> >
>> >> So far I can receive only.
>> >>
>> >> I'm getting a little screwed up in the pin labeling and what side of the
>> >> cable I'm on.
>> >>
>> >> What I have so far:
>> >>
>> >> Cable from DRAWS w/end cut reveals
>> >>
>> >> Pin 6 Green
>> >> Pin 5 Black
>> >> Pin 4 Orange
>> >> Pin 3 Yellow
>> >> Pin 2 Brown
>> >> Pin 1 Red
>> >>
>> >> Radio uses an RJ-45 MIC cable and a speaker audio
>> >>
>> >> Pin 1 N/C
>> >> Pin 2 DC 8V
>> >> Pin 3 GND
>> >> Pin 4 PTT
>> >> Pin 5 GND (MIC)
>> >> Pin 6 MIC
>> >> Pin 7 N/C
>> >> Pin 8 DTMF Data
>> >>
>> >> Plus TRS on rear audio 1/8th jack
>> >>
>> >> I have
>> >> DRAWS = Radio
>> >> 1 = 6
>> >> 2 = 5
>> >> 3 = 4
>> >> 4 = N/C
>> >> 5 = Rear Speaker TIP
>> >> 6 = N/C
>> >> GND = N/C
>> >>
>> >> Any thoughts?
>> >>
>> >> On Fri, May 24, 2019 at 6:47 PM David Lowry <huskyrunnr@...> wrote:
>> >>
>> >>> https://imgur.com/iMaXWRR
>> >>>
>> >>> Not sure if it is correct but is sure fills up my map.
>> >>>
>> >>>
>> >>>
>> >
>> >
>>
>>
>>
>>
>
>