Topics

#draws #draws

okiejim
 

My Draws hat with Xastir is sending packets out over my wifi when I have it on. When I turn off my wifi it sends the packets out via a normal digipeater on the rf side. I found this out when a coordinator in the area said I was doing this and I was wondering what I have set up wrong to have it doing this. I do not have any digi setup on Xastir that I am aware off. Can anyone help direct me to what I did wrong. I want to wifi on so I can remote desktop to the Pi. Thank you.

Basil Gunn
 

There are a couple of possibilities.

It is possible to configure Direwolf to gate traffic to the Internet. If
you did NOT touch the direwolf.conf file then you are most likely OK
since my scripts do not configure Direwolf to do this.

It is possible that you have configured Xastir to gate packets to the
Internet. In Xastir check Interface -> Interface control, select Device
0 Networked AGWPE, click on properties. Verify under 'IGate Options'
that 'Disable all IGate traffic' is selected.

You might have an application loaded on your RPi that broadcasts on all
network interfaces. Verify that iptables has the policy the install
scripts should have setup. Run script iptable-check.sh, you should see
these addresses are dropped 224.0.0.22, 224.0.0.251, 239.255.255.250

To understand your problem I would need to look at the offending packets
that your coordinator is referring to. For instance is he referring to
broadcast/multicast packets from some application or is he referring to
APRS packets gated to the Internet by you. You could ask your
coordinator to send you a copy of the packets they saw or you could
capture them yourself.

# From a console window
# Install tcpdump
apt-get update
apt-get install tcpdump

# Run tcpdump
sudo tcpdump -e -vvv -i wlan0

Hope this is helpful.

/Basil n7nix

okiejim <kd6vpe@...> writes:

My Draws hat with Xastir is sending packets out over my wifi when I
have it on. When I turn off my wifi it sends the packets out via a
normal digipeater on the rf side. I found this out when a coordinator
in the area said I was doing this and I was wondering what I have set
up wrong to have it doing this. I do not have any digi setup on Xastir
that I am aware off. Can anyone help direct me to what I did wrong. I
want to wifi on so I can remote desktop to the Pi. Thank you *.*

Steve, N9VW
 

A suggestion if I may. The tcpdump command will generate a lot of data and it becomes problematic to capture it from the screen and/or the buffer will overrun and you will miss packets. I have found it much easier to capture into a file. From there you can easily move the file of the output where you need it.

sudo tcpdump -e -vvv -i wlan0 -w filename.txt

The program will provide a count of the number of packets captured, press CTRL-C to stop the capture and close the file.

73 de Steve, N9VW

On 4/13/2019 8:24 AM, Basil Gunn wrote:
There are a couple of possibilities.

It is possible to configure Direwolf to gate traffic to the Internet. If
you did NOT touch the direwolf.conf file then you are most likely OK
since my scripts do not configure Direwolf to do this.

It is possible that you have configured Xastir to gate packets to the
Internet. In Xastir check Interface -> Interface control, select Device
0 Networked AGWPE, click on properties. Verify under 'IGate Options'
that 'Disable all IGate traffic' is selected.

You might have an application loaded on your RPi that broadcasts on all
network interfaces. Verify that iptables has the policy the install
scripts should have setup. Run script iptable-check.sh, you should see
these addresses are dropped 224.0.0.22, 224.0.0.251, 239.255.255.250

To understand your problem I would need to look at the offending packets
that your coordinator is referring to. For instance is he referring to
broadcast/multicast packets from some application or is he referring to
APRS packets gated to the Internet by you.  You could ask your
coordinator to send you a copy of the packets they saw or you could
capture them yourself.

# From a console window
# Install tcpdump
apt-get update
apt-get install tcpdump

# Run tcpdump
sudo tcpdump -e -vvv -i wlan0

Hope this is helpful.

/Basil n7nix

okiejim <kd6vpe@...> writes:

My Draws hat with Xastir is sending packets out over my wifi when I
have it on. When I turn off my wifi it sends the packets out via a
normal digipeater on the rf side. I found this out when a coordinator
in the area said I was doing this and I was wondering what I have set
up wrong to have it doing this. I do not have any digi setup on Xastir
that I am aware off. Can anyone help direct me to what I did wrong. I
want to wifi on so I can remote desktop to the Pi. Thank you *.*



Steve, N9VW
 

I messed up the file name. The extension should be .pcap   (tcpdump formats the file appropriately for Wireshark to digest)

Steve, N9VW

On 4/13/2019 9:15 AM, Steve, N9VW wrote:
A suggestion if I may. The tcpdump command will generate a lot of data and it becomes problematic to capture it from the screen and/or the buffer will overrun and you will miss packets. I have found it much easier to capture into a file. From there you can easily move the file of the output where you need it.

sudo tcpdump -e -vvv -i wlan0 -w filename.txt

The program will provide a count of the number of packets captured, press CTRL-C to stop the capture and close the file.

73 de Steve, N9VW

On 4/13/2019 8:24 AM, Basil Gunn wrote:
There are a couple of possibilities.

It is possible to configure Direwolf to gate traffic to the Internet. If
you did NOT touch the direwolf.conf file then you are most likely OK
since my scripts do not configure Direwolf to do this.

It is possible that you have configured Xastir to gate packets to the
Internet. In Xastir check Interface -> Interface control, select Device
0 Networked AGWPE, click on properties. Verify under 'IGate Options'
that 'Disable all IGate traffic' is selected.

You might have an application loaded on your RPi that broadcasts on all
network interfaces. Verify that iptables has the policy the install
scripts should have setup. Run script iptable-check.sh, you should see
these addresses are dropped 224.0.0.22, 224.0.0.251, 239.255.255.250

To understand your problem I would need to look at the offending packets
that your coordinator is referring to. For instance is he referring to
broadcast/multicast packets from some application or is he referring to
APRS packets gated to the Internet by you.  You could ask your
coordinator to send you a copy of the packets they saw or you could
capture them yourself.

# From a console window
# Install tcpdump
apt-get update
apt-get install tcpdump

# Run tcpdump
sudo tcpdump -e -vvv -i wlan0

Hope this is helpful.

/Basil n7nix

okiejim <kd6vpe@...> writes:

My Draws hat with Xastir is sending packets out over my wifi when I
have it on. When I turn off my wifi it sends the packets out via a
normal digipeater on the rf side. I found this out when a coordinator
in the area said I was doing this and I was wondering what I have set
up wrong to have it doing this. I do not have any digi setup on Xastir
that I am aware off. Can anyone help direct me to what I did wrong. I
want to wifi on so I can remote desktop to the Pi. Thank you *.*

      


okiejim
 

Here is an update. The coordinator has not gotten back to me on email after several attempts by me to help resolve his email to me. I went into direwolf and commented out the following lines.
IGLOGIN my call here with pass code
IGTXLIMIT  10
 
As far as I can tell this has stopped the situation but not sure. I have my wifi up along with xastir and since I see no response from the coordinator I assume I have meet his request. I hope so.
If anyone sees this as a wrong setup please let me know. I am still learning this card, but I do have a project planed in the near future. It will use the direwolf,sound card and radio remote control.
I am a happy user. This is exactly why I wanted to buy this hat. I love to experiment and learn.