Topics

VNC on Compass

John B Brown
 

I cannot get realvnc to run on Compass.  I've tried manually installing it but without success.  Any suggestions?  I'm running Compass on a RPI3 with full updates and upgrades

John B

AD7QQ

John B Brown
 

Well, shortly after posting this I was able to get realvnc to work.

If anyone is interested I'll pass on the details

W2TLJ
 

Try using TightVNC. Works well on the configuration you have.

On Feb 15, 2017 2:04 AM, "John B Brown" <drbrown@...> wrote:

I cannot get realvnc to run on Compass.  I've tried manually installing it but without success.  Any suggestions?  I'm running Compass on a RPI3 with full updates and upgrades

John B

AD7QQ

Robert Sears
 

I followed these instructions https://www.realvnc.com/docs/raspberry-pi.html 

And it works fine on two UDRC-2's

Robert/KF7VOP

On 2/14/2017 10:42 PM, John B Brown wrote:

I cannot get realvnc to run on Compass.  I've tried manually installing it but without success.  Any suggestions?  I'm running Compass on a RPI3 with full updates and upgrades

John B

AD7QQ


Ian
 

On 15-02-2017 06:42, John B Brown wrote:
I cannot get realvnc to run on Compass. I've tried manually
installing it but without success. Any suggestions? I'm running
Compass on a RPI3 with full updates and upgrades
John B
AD7QQ
_._,_._,_

John,

I couldn't get VNC to work for me either, even after setting it using raspi-config; I'm using RemoteDesktopViewer. I have ircddbgateway and dummyrepeater running on the PI and found I can edit remotely using:-

ian@debian8:~$ ssh -X pi@....13
pi@....13's password:

then

pi@compasslite01:~ $ sudo -E ircddbgatewayconfig
Gtk-Message: Failed to load module "canberra-gtk-module"

and the ircddbgatewayconfig window appears on my desktop regardless of the error message and I can make " adjustments ".

Not the most elegant solution although it works for me..

Regards,

Ian..

Ian
 

I should have said it's possible to use your Browser with VNC.

Regards,
Ian..

Jeff - K2AK <k2ak@...>
 

I use putty and it works perfectly for SSH and built some macros to do
ordinary tasks like that. I think I might have had to turn on SSH in
raspi-config and then all was fine.

Jeff
K2AK

-----Original Message-----
From: main@nw-digital-radio.groups.io
[mailto:main@nw-digital-radio.groups.io] On Behalf Of Ian
Sent: Wednesday, February 15, 2017 9:13 AM
To: main@nw-digital-radio.groups.io
Subject: Re: [nw-digital-radio] VNC on Compass



On 15-02-2017 06:42, John B Brown wrote:
I cannot get realvnc to run on Compass. I've tried manually
installing it but without success. Any suggestions? I'm running
Compass on a RPI3 with full updates and upgrades

John B

AD7QQ
_._,_._,_

John,

I couldn't get VNC to work for me either, even after setting it using
raspi-config; I'm using RemoteDesktopViewer. I have ircddbgateway and
dummyrepeater running on the PI and found I can edit remotely using:-

ian@debian8:~$ ssh -X pi@....13
pi@....13's password:

then

pi@compasslite01:~ $ sudo -E ircddbgatewayconfig
Gtk-Message: Failed to load module "canberra-gtk-module"

and the ircddbgatewayconfig window appears on my desktop regardless of the
error message and I can make " adjustments ".

Not the most elegant solution although it works for me..

Regards,

Ian..

 

A few observations:

  1. The latest Raspbian/Jesse/Debian 8 releases, upon which Compass is based do not turn on SSH by default, you have to enable it:  sudo systemctl enable ssh ; sudo systemctl start ssh
  2. Since Compass is based on Raspbian-Jesse, you can use Raspbian resources for documentation and help.
  3. I usually use tightvnc or xrdp vs realvnc - be aware that hacker robots probe the well known ports for these applications 
    • Be sure you change/update all system and user passwords 
    • xrdp is accessible from Windows Remote Desktop clients (which are available for Windows, Android, MacOS, ...)

On Wed, Feb 15, 2017 at 12:35 PM, Jeff - K2AK <k2ak@...> wrote:
I use putty and it works perfectly for SSH and built some macros to do
ordinary tasks like that. I think I might have had to turn on SSH in
raspi-config and then all was fine.

Jeff
K2AK

-----Original Message-----
From: main@....io
[mailto:main@nw-digital-radio.groups.io] On Behalf Of Ian
Sent: Wednesday, February 15, 2017 9:13 AM
To: main@....io
Subject: Re: [nw-digital-radio] VNC on Compass



On 15-02-2017 06:42, John B Brown wrote:
> I cannot get realvnc to run on Compass.  I've tried manually
> installing it but without success.  Any suggestions?  I'm running
> Compass on a RPI3 with full updates and upgrades
>
> John B
>
> AD7QQ
> _._,_._,_


John,

I couldn't get VNC to work for me either, even after setting it using
raspi-config; I'm using RemoteDesktopViewer.  I have ircddbgateway and
dummyrepeater running on the PI and found I can edit remotely using:-

ian@debian8:~$ ssh -X pi@....13
pi@....13's password:

then

pi@compasslite01:~ $ sudo -E ircddbgatewayconfig
Gtk-Message: Failed to load module "canberra-gtk-module"

and the ircddbgatewayconfig window appears on my desktop regardless of the
error message and I can make " adjustments ".

Not the most elegant solution although it works for me..

Regards,

Ian..











--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

 

Also visit your router firewall rules.

I use MikroTik routers, and deploy this strategy which seems to work well


You can also just block external attempts if you just access your Pi from your LAN.

On Wed, Feb 15, 2017 at 12:58 PM, John D Hays - K7VE <john@...> wrote:
A few observations:

  1. The latest Raspbian/Jesse/Debian 8 releases, upon which Compass is based do not turn on SSH by default, you have to enable it:  sudo systemctl enable ssh ; sudo systemctl start ssh
  2. Since Compass is based on Raspbian-Jesse, you can use Raspbian resources for documentation and help.
  3. I usually use tightvnc or xrdp vs realvnc - be aware that hacker robots probe the well known ports for these applications 
    • Be sure you change/update all system and user passwords 
    • xrdp is accessible from Windows Remote Desktop clients (which are available for Windows, Android, MacOS, ...)

On Wed, Feb 15, 2017 at 12:35 PM, Jeff - K2AK <k2ak@...> wrote:
I use putty and it works perfectly for SSH and built some macros to do
ordinary tasks like that. I think I might have had to turn on SSH in
raspi-config and then all was fine.

Jeff
K2AK

-----Original Message-----
From: main@...o
[mailto:main@nw-digital-radio.groups.io] On Behalf Of Ian
Sent: Wednesday, February 15, 2017 9:13 AM
To: main@...o
Subject: Re: [nw-digital-radio] VNC on Compass



On 15-02-2017 06:42, John B Brown wrote:
> I cannot get realvnc to run on Compass.  I've tried manually
> installing it but without success.  Any suggestions?  I'm running
> Compass on a RPI3 with full updates and upgrades
>
> John B
>
> AD7QQ




--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

Ian
 

I had REALVNC working with my Browser before updating to the latest version; now I cannot use my Browser and I got the " sign in " prompt for REALVNC, so rather than set up an account I installed tightvncserver on the RPi3 as I can use xtightvncviewer from my main PC. THe update went from version 5 something to version 6 something on REALVNC.

Regards,
Ian..

On 15-02-2017 20:58, John D Hays - K7VE wrote:
A few observations:
* The latest Raspbian/Jesse/Debian 8 releases, upon which Compass is
based do not turn on SSH by default, you have to enable it: SUDO
SYSTEMCTL ENABLE SSH ; SUDO SYSTEMCTL START SSH
* Since Compass is based on Raspbian-Jesse, you can use Raspbian
resources for documentation and help.
* I usually use tightvnc or xrdp vs realvnc - be aware that hacker
robots probe the well known ports for these applications
* Be sure you change/update all system and user passwords
* xrdp is accessible from Windows Remote Desktop clients (which are
available for Windows, Android, MacOS, ...)
On Wed, Feb 15, 2017 at 12:35 PM, Jeff - K2AK <@k2ak> wrote:

I use putty and it works perfectly for SSH and built some macros to
do
ordinary tasks like that. I think I might have had to turn on SSH in
raspi-config and then all was fine.
Jeff
K2AK
-----Original Message-----
From: main@nw-digital-radio.groups.io
[mailto:main@nw-digital-radio.groups.io] On Behalf Of Ian
Sent: Wednesday, February 15, 2017 9:13 AM
To: main@nw-digital-radio.groups.io
Subject: Re: [nw-digital-radio] VNC on Compass
On 15-02-2017 06:42, John B Brown wrote:
I cannot get realvnc to run on Compass. I've tried manually
installing it but without success. Any suggestions? I'm running
Compass on a RPI3 with full updates and upgrades
John B
AD7QQ
Links:
------
[1] http://k7ve.org/blog
[2] http://twitter.com/#!/john_hays
[3] https://nw-digital-radio.groups.io/g/main/message/1483
[4] https://groups.io/mt/4368002?uid=162806
[5] https://nw-digital-radio.groups.io/g/main/post
[6] https://nw-digital-radio.groups.io/g/main/editsub?uid=162806
[7] https://nw-digital-radio.groups.io/g/main
[8] https://groups.io/static/tos
[9] https://nw-digital-radio.groups.io/g/main/leave/defanged

Ken Koster
 

On Wednesday, February 15, 2017 12:58:17 PM PST John D Hays - K7VE wrote:
A few observations:


1. The latest Raspbian/Jesse/Debian 8 releases, upon which Compass is
based do not turn on SSH by default, you have to enable it: *sudo
Another way is to copy the image to your SD card, then mount it and add a
blank file called 'ssh' to the boot partition. Then ssh is automatically
started without the need to run raspi-config first.

systemctl enable ssh ; sudo systemctl start ssh*
2. Since Compass is based on Raspbian-Jesse, you can use Raspbian
resources for documentation and help.
3. I usually use tightvnc or xrdp vs realvnc - be aware that hacker
robots probe the well known ports for these applications
- Be sure you change/update all system and user passwords
- xrdp is accessible from Windows Remote Desktop clients (which are
available for Windows, Android, MacOS, ...)
I use x11vnc on all mine and start it with a systemd service file. It starts
up after everything is running and announces itself with avahi (Apples
zeroconf). If anyone is interested I'll be happy to publish the service file.

Ken, N7IPB


On Wed, Feb 15, 2017 at 12:35 PM, Jeff - K2AK <@k2ak> wrote:
I use putty and it works perfectly for SSH and built some macros to do
ordinary tasks like that. I think I might have had to turn on SSH in
raspi-config and then all was fine.

Jeff
K2AK

-----Original Message-----
From: main@nw-digital-radio.groups.io
[mailto:main@nw-digital-radio.groups.io] On Behalf Of Ian
Sent: Wednesday, February 15, 2017 9:13 AM
To: main@nw-digital-radio.groups.io
Subject: Re: [nw-digital-radio] VNC on Compass

On 15-02-2017 06:42, John B Brown wrote:
I cannot get realvnc to run on Compass. I've tried manually
installing it but without success. Any suggestions? I'm running
Compass on a RPI3 with full updates and upgrades

John B

AD7QQ
_._,_._,_
John,

I couldn't get VNC to work for me either, even after setting it using
raspi-config; I'm using RemoteDesktopViewer. I have ircddbgateway and
dummyrepeater running on the PI and found I can edit remotely using:-

ian@debian8:~$ ssh -X pi@....13
pi@....13's password:

then

pi@compasslite01:~ $ sudo -E ircddbgatewayconfig
Gtk-Message: Failed to load module "canberra-gtk-module"

and the ircddbgatewayconfig window appears on my desktop regardless of the
error message and I can make " adjustments ".

Not the most elegant solution although it works for me..

Regards,

Ian..

Basil Gunn
 

On Wed, 15 Feb 2017 13:20:58 -0800
"Ken Koster" <n7ipb@...> wrote:

I use x11vnc on all mine and start it with a systemd service file.
It starts up after everything is running and announces itself with
avahi (Apples zeroconf). If anyone is interested I'll be happy to
publish the service file.
Ken's notes & systemd service file are published here:

https://github.com/nwdigitalradio/n7nix/tree/master/vnc

Thanks Ken!

/Basil n7nix

Woodrick, Ed
 

An announcement from RealVNC yesterday

 

https://www.raspberrypi.org/blog/get-back-to-my-pi-from-anywhere-with-vnc-connect/

 

In today’s guest blog, Andy Clark, Engineering Manager at RealVNC, introduces VNC Connect: a brand-new, and free, version of VNC that makes it simple to connect securely to your Raspberry Pi from anywhere in the world.

 

Ed WA4YIH

 

From: main@nw-digital-radio.groups.io [mailto:main@nw-digital-radio.groups.io] On Behalf Of John D Hays - K7VE
Sent: Wednesday, February 15, 2017 4:04 PM
To: main@nw-digital-radio.groups.io
Subject: Re: [nw-digital-radio] VNC on Compass

 

Also visit your router firewall rules.

 

I use MikroTik routers, and deploy this strategy which seems to work well

 

 

You can also just block external attempts if you just access your Pi from your LAN.

 

On Wed, Feb 15, 2017 at 12:58 PM, John D Hays - K7VE <john@...> wrote:

A few observations:

 

  1. The latest Raspbian/Jesse/Debian 8 releases, upon which Compass is based do not turn on SSH by default, you have to enable it:  sudo systemctl enable ssh ; sudo systemctl start ssh
  2. Since Compass is based on Raspbian-Jesse, you can use Raspbian resources for documentation and help.
  3. I usually use tightvnc or xrdp vs realvnc - be aware that hacker robots probe the well known ports for these applications 
    • Be sure you change/update all system and user passwords 
    • xrdp is accessible from Windows Remote Desktop clients (which are available for Windows, Android, MacOS, ...)

 

On Wed, Feb 15, 2017 at 12:35 PM, Jeff - K2AK <k2ak@...> wrote:

I use putty and it works perfectly for SSH and built some macros to do
ordinary tasks like that. I think I might have had to turn on SSH in
raspi-config and then all was fine.

Jeff
K2AK


-----Original Message-----
From: main@nw-digital-radio.groups.io
[mailto:main@nw-digital-radio.groups.io] On Behalf Of Ian
Sent: Wednesday, February 15, 2017 9:13 AM
To: main@nw-digital-radio.groups.io
Subject: Re: [nw-digital-radio] VNC on Compass



On 15-02-2017 06:42, John B Brown wrote:
> I cannot get realvnc to run on Compass.  I've tried manually
> installing it but without success.  Any suggestions?  I'm running
> Compass on a RPI3 with full updates and upgrades
>
> John B
>
> AD7QQ



 

--

 


John D. Hays

K7VE

 

PO Box 1223, Edmonds, WA 98020-1223

Image removed by sender. Image removed by sender. Image removed by sender. Image removed by sender.