Topics

IRCddB Help

Duff <wa7bfn@...>
 

Hello Gents;

I recently installed a UDRCII on a DRX1 Repeater... and it works GREAT... as advertised very nice...

I'm now trying to configure the IRCddB gateway ... I've follwed the configuration verbatim both in command line and GUI... to NO joy. 

I'm not a network guru...know just enough to get me in trouble..Just wondering if anyboy has a list of 

If it does this....do that... if it doesn'tdo  this don't do that... :) I think you can see where i'm headed :)


I see a lot of activity on the log...(Glogg program) however can't get the unit to connect or setup the remote for same...

can somebody point me int he right direction before I lose what hair I have left:) 

Smiles..,

Thanks

duff in Spokane 

 

Hi Duff,


Are you running the ircddbgateway on the same Raspberry Pi as dstarrepeater?  If so, then you use the local address 127.0.0.1 to connect the dstarrepeater and ircddbgateway.


I assume you are following -- https://nw-digital-radio.groups.io/g/udrc/wiki/Configuring-ircDDBgateway ?  (BTW, the UDRC community provides help in https://nw-digital-radio.groups.io/g/udrc/messages


John

(BTW, I was over to CDA a couple of weeks back for my Father-In-Law's 90th birthday)

Duff <wa7bfn@...>
 

Hi John and others....

worked on the IRCddB Gateway config this afternoon...  Unable to connect via the usual methods...

WE looked at the Log Sheet. it says...RPT2 has the same Call as RPT so shutting down or something..

I see activity on the logs..so it seems the pi is seeing the gateway..just not the other way...being able to communicate... Ideas?

Thanks

WA7BFN

Duff Spokane 


 

This is often a user radio issue.

Make sure the radio is in DR mode with RPT1 as the module number and RPT2 as the 'G' module, and UR set to "Use Repeater" (On older radios you can set these individually and put CQCQCQ in the UR field).

The other thing to check is the /etc/opendv/dstargateway_1 configuration file and make sure you set

callsign=WW7DRX  B
gateway=WW7DRX  G

Using your repeater/gateway callsigns with the module letters in the 8th position.

Peruse both logs,  /var/log/opendv/dstarrepeaterd_1.log and /var/log/opendv/ircddbgatewayd.log

On Sat, Dec 3, 2016 at 6:41 PM, Duff <wa7bfn@...> wrote:

Hi John and others....

worked on the IRCddB Gateway config this afternoon...  Unable to connect via the usual methods...

WE looked at the Log Sheet. it says...RPT2 has the same Call as RPT so shutting down or something..

I see activity on the logs..so it seems the pi is seeing the gateway..just not the other way...being able to communicate... Ideas?

Thanks

WA7BFN

Duff Spokane 





--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

Duff <wa7bfn@...>
 

Hi John 
Thanks again for all the help. got the DV memory right but am unable to connect to refs 
Haven't tried the Android app yet  
If you have an idea of where to look let me know  
Thanks again have a nice evening
Duff




Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: John D Hays - K7VE <john@...>
Date: 12/3/16 6:54 PM (GMT-08:00)
To: main@nw-digital-radio.groups.io
Subject: Re: [nw-digital-radio] IRCddB Help

This is often a user radio issue.

Make sure the radio is in DR mode with RPT1 as the module number and RPT2 as the 'G' module, and UR set to "Use Repeater" (On older radios you can set these individually and put CQCQCQ in the UR field).

The other thing to check is the /etc/opendv/dstargateway_1 configuration file and make sure you set

callsign=WW7DRX  B
gateway=WW7DRX  G

Using your repeater/gateway callsigns with the module letters in the 8th position.

Peruse both logs,  /var/log/opendv/dstarrepeaterd_1.log and /var/log/opendv/ircddbgatewayd.log

On Sat, Dec 3, 2016 at 6:41 PM, Duff <wa7bfn@...> wrote:

Hi John and others....

worked on the IRCddB Gateway config this afternoon...  Unable to connect via the usual methods...

WE looked at the Log Sheet. it says...RPT2 has the same Call as RPT so shutting down or something..

I see activity on the logs..so it seems the pi is seeing the gateway..just not the other way...being able to communicate... Ideas?

Thanks

WA7BFN

Duff Spokane 





--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

 

The main thing is to open two terminal windows and tail the log files

tail -f /var/log/opendv/dstarrepeaterd_1.log
tail -f /var/log/opendv/ircddbgatewayd.log

Key up and see what they show -- dstarrepeater will show your headers, make sure they look right.  ircddbgateway will show the linking attempt.

Also go back through the dstarrepeater_1 configuration and make sure dplus is enabled and that you have a US Trust registered user callsign in the dplus login.  If those two are not in place you will be unable to link into dplus -- also realize the hosts files get out of date, so try different reflectors and I recommend, this step.  https://nw-digital-radio.groups.io/g/udrc/wiki/Configuring-ircDDBgateway#Reflector-Host-Files



On Sat, Dec 3, 2016 at 8:58 PM, Duff <wa7bfn@...> wrote:
Hi John 
Thanks again for all the help. got the DV memory right but am unable to connect to refs 
Haven't tried the Android app yet  
If you have an idea of where to look let me know  
Thanks again have a nice evening
Duff




Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: John D Hays - K7VE <john@...>
Date: 12/3/16 6:54 PM (GMT-08:00)
Subject: Re: [nw-digital-radio] IRCddB Help

This is often a user radio issue.

Make sure the radio is in DR mode with RPT1 as the module number and RPT2 as the 'G' module, and UR set to "Use Repeater" (On older radios you can set these individually and put CQCQCQ in the UR field).

The other thing to check is the /etc/opendv/dstargateway_1 configuration file and make sure you set

callsign=WW7DRX  B
gateway=WW7DRX  G

Using your repeater/gateway callsigns with the module letters in the 8th position.

Peruse both logs,  /var/log/opendv/dstarrepeaterd_1.log and /var/log/opendv/ircddbgatewayd.log

On Sat, Dec 3, 2016 at 6:41 PM, Duff <wa7bfn@...> wrote:

Hi John and others....

worked on the IRCddB Gateway config this afternoon...  Unable to connect via the usual methods...

WE looked at the Log Sheet. it says...RPT2 has the same Call as RPT so shutting down or something..

I see activity on the logs..so it seems the pi is seeing the gateway..just not the other way...being able to communicate... Ideas?

Thanks

WA7BFN

Duff Spokane 





--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   




--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223