Last edited · 3 revisions  

 


Installing GQRX

Basic Install Instructions from a terminal

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libqt5gui5 libqt5core5a libqt5network5
sudo apt-get install libqt5widgets5 libqt5svg5 libportaudio2
cd
wget https://github.com/csete/gqrx/releases/download/v2.6/gqrx-2.6-rpi3-2.tar.xz
tar xvf gqrx-2.6-rpi3-2.tar.xz
cd gqrx-2.6-rpi3-2/
./setup_gqrx.sh

Support for GQRX

NW Digital Radio is not the author of this software and does not provide technical support for GQRX.  The instructions provided herein are informational, all support for gqrx should be directed to GQRX Support 

Main resource page


Run GQRX

Install a supported SDR device, see the GQRX Hardware page.

cd
./run_gqrx.sh

Special Note for newer RTL-SDR Devices


If you get errors trying to use a newer RTL SDR device. You may need to disable the generic driver module.
cd /etc/modprobe.d
# Use your favorite editor such as nano, vi, or emacs to edit and save blacklist.conf
sudo nano blacklist.conf
Insert the following into the file
# blacklist due to gqrx
blacklist dvb_usb_rtl28xxu

You will need to reboot and then run gqrx again.

sudo reboot

After reboot, at the terminal.

cd
./run_gqrx.sh
Note: this method  has been successfully tried with this popular RTL-SDR