Re: UDRC-II squelch on the Yaesu FT-897D

 

Stuart, have you made any progress on this problem?

I’d like to understand what’s going on and help get this resolved.

Thanks,
Bryan K7UDR

On Nov 12, 2016, at 1:14 AM, Stuart Longland VK4MSL <stuartl@...> wrote:

Hi all,

I've just recently got the UDRC-II board up and running on a Raspberry
Pi 3 single board computer, and this evening started experimenting with
it. I'm hoping to get the unit going for 1200-baud packet radio as a
starting point, as my local emergency comms group¹ use this extensively
in a couple of their events.

One thing I noticed when I went into the mixer… yep, the TLV320AIC3204
is a complex beast. I remember this from when I last had a skirmish
with this chip back around 2010 for Jacques Electronics, these things
have more knobs and dials than the cockpit of a fighter jet!

Thankfully, the "Simplified Block Diagram" in the data sheet provides
the road map to understanding that mixer. Judging from the schematics,
it appears the key channels are the Line Output and Line 1 inputs. The
headphone amplifier and Line 2 and 3 can all be disregarded.

I tried firing up the FT-897D I have here and first connected the Pi up
via the supplied Mini-DIN6 cable. I noticed the moment I did this, the
audio on the FT-897D shuts off.

This happens even if the Pi is turned off.

With the Pi running, I tried getting arecord/aplay to pipe audio from
the UDRC to a USB headset.

arecord -f dat -D hw:udrc - | aplay -D pulse -f dat -

I got no audio out.

I've observed this phenomenon before: on that occasion I was trying to
get the squelch output pin on that data jack to drive the base of a
transistor.

It seems *any* significant load on this pin causes the output of the
radio to mute.

The schematic shows the signal from this pin goes into a base resistor,
a second bias resistor to ground, into the base of a NPN transistor. I
haven't spotted where on the PCB it is, and no designation is given in
the schematic.

As a test, I tried rigging up a quick and dirty adapter to go via the
DB15-HD connector into a Mini-DIN6 I had laying around: I deliberately
skipped the squelch pin.

With that, I was able to get a somewhat noisy audio signal on the left
channel from the data port on the radio. (I had the set on a local
3m-band WFM radio station.)

Conceivably, I can make my own data cables hooking to the DB15-HD
connector. This is messy however, and I'd like to identify and fix the
underlying problem if possible.

I'm wondering if anyone else had similar experiences and knows which
resistor I can try replacing on the UDRC-II board to tweak the load seen
by the radio.
--
Stuart Longland (aka Redhatter, VK4MSL)

I haven't lost my mind...
...it's backed up on a tape somewhere.

1. https://www.brisbanewicen.org.au/


Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.