Re: direwolf configuration file


Basil Gunn
 

Hey John,

Which UDRC do you have, original or II?
- look at the silk screen on the board or
- run udrcver.sh from here:
https://github.com/nwdigitalradio/n7nix/blob/master/systemd/bin/udrcver.sh

Which UDRC port are you using mDin6 or HD15?

Assuming you have a UDRC II
If you are using mDin6 then you will need to set up Direwolf channel 1
(Direwolf uses chan 0 & 1) and PTT will be active on GPIO 23.

If you are using the HD15 interface you will need to set up Direwolf
channel 0 and PTT will be active on GPIO 12.

From your config it looks like you have the Direwolf channels switched
around for mDin6 & HD15 interfaces.

/Basil n7nix


On Thu, 15 Feb 2018 09:14:56 -0800
"John Spoonhower" <jpspoonhower@...> wrote:

I need some help with configuring direwolf. Let me start by saying
that I have direwolf running well in receive mode on a raspberry pi 3
with udrc-II. The problem lies with the lack of audio on transmit. I
am asking the setup to broadcast my setup with PBEACON on the radio.
With some setup configurations I get the transmitter to key (PTT
works!) but there is no audio (tones are not evident on a separate
second radio). I have setup FLDIGI using the online installation
notes and if I click "tune" in FLDIGI , the transmitter keys and I
hear I nice tone. I can run measure_deviate.sh and also get the
transmitter to key and generate a tone. Measure_deviate.sh is setup
in the "stock" manner with gpio  set to gpio 12. FLDIGI setup is also
"stock" with GPIO hardware control : BCM 23, GPIO 04, pin 16
selection. 

The direwolf.conf file looks like:
ADEVICE plughw:CARD=udrc,DEV=0
ARATE 48000
ACHANNELS 2
#DIN-6
CHANNEL 0
MYCALL NX2I-10
MODEM 1200i
PTT GPIO 23
#HD-15
# note channels set the same
CHANNEL 1
MYCALL NX2I-10
MODEM 1200
PTT GPIO 23
AGWPORT 8000
KISSPORT 8001
PBEACON delay=1 sendto=0 every=10 overlay=R symbol="igate"
lat=28^52.69N long=82^$ #PBEACON delay=1 sendto=1 every=10 overlay=S
symbol="digi" lat=17^51.00N long=102$ #DIGIPEAT 0 0
^WIDE[3-7]-[1-7]$|^TEST$ ^WIDE[12]-[12]$ TRACE #DIGIPEAT 1 1
^WIDE[3-7]-[1-7]$|^TEST$ ^WIDE[12]-[12]$ TRACE #DIGIPEAT 0 1
^WIDE[3-7]-[1-7]$|^TEST$ ^WIDE[12]-[12]$ TRACE #DIGIPEAT 1 0
^WIDE[3-7]-[1-7]$|^TEST$ ^WIDE[12]-[12]$ TRACE IGSERVER noam.aprs2.net
IGLOGIN NX2I 4083  #YOUR INTERNET LOGIN AND PASSCODE FOR APRS
REPORTING # Degrees Decimal minutes format for lat, long
PBEACON sendto=IG delay=0:30 every=30:00 symbol="igate" overlay=R
lat=28^52.69386$ LOGDIR /home/pi/aprslogs
IGTXLIMIT 6 10
GPSD localhost
#IBEACON DELAY=30 EVERY=30 VIA=WIDE1-1

If I have PTT GPIO 23 set (like above) I see the transmitter key but
there is no audio. If I set the GPIO in this file to 12, the
transmitter does not key. Obviously I am doing something wrong, but
none of this makes any sense to me. 73, john, NX2I

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.