Kind of a weird 'bug'? No soundcard detected after upgrade


Art - KC7SDA
 

so last night I was able to load up fldigi no problem, this was after installing stuff for bluetooth and doing a few transfers.

this morning i did an update/upgrade (I had already done the hold back a while ago for the sound) and now fldigi doesn't load and when I do aplay -l I get 'no soundcards found'

the udrc is detected and I've removed power (hard power cycle) to see if that solves the issue, it didn't.

here is my log for the update:



Start-Date: 2018-03-27  15:39:20
Commandline: apt-get upgrade
Upgrade: libraspberrypi-doc:armhf (1.20180125-1compass1, 1.20180326-2compass1), libcurl3:armhf (7.38.0-4+deb8u9, 7.38.0-4+deb8u10), gcc-4.9-base:armhf (4.9.2-10, 4.9.2-10+deb8u1), raspberrypi-kernel:armhf (1.20180125-1compass1, 1.20180326-2compass1), libvorbisfile3:armhf (1.3.4-2, 1.3.4-2+deb8u1), libavresample2:armhf (11.11-1~deb8u1+rpi1, 11.12-1~deb8u1+rpi1), isc-dhcp-client:armhf (4.3.1-6+deb8u2, 4.3.1-6+deb8u3), libraspberrypi-bin:armhf (1.20180125-1compass1, 1.20180326-2compass1), g++-4.9:armhf (4.9.2-10, 4.9.2-10+deb8u1), libatomic1:armhf (4.9.2-10, 4.9.2-10+deb8u1), libgcc-4.9-dev:armhf (4.9.2-10, 4.9.2-10+deb8u1), curl:armhf (7.38.0-4+deb8u9, 7.38.0-4+deb8u10), libavutil54:armhf (11.11-1~deb8u1+rpi1, 11.12-1~deb8u1+rpi1), libstdc++-4.9-dev:armhf (4.9.2-10, 4.9.2-10+deb8u1), libstdc++6:armhf (4.9.2-10, 4.9.2-10+deb8u1), libfreexl1:armhf (1.0.0g-1+deb8u4, 1.0.0g-1+deb8u5), libvorbis-dev:armhf (1.3.4-2, 1.3.4-2+deb8u1), libasan1:armhf (4.9.2-10, 4.9.2-10+deb8u1), libvorbis0a:armhf (1.3.4-2, 1.3.4-2+deb8u1), raspberrypi-bootloader:armhf (1.20180125-1compass1, 1.20180326-2compass1), libcurl3-gnutls:armhf (7.38.0-4+deb8u9, 7.38.0-4+deb8u10), libgomp1:armhf (4.9.2-10, 4.9.2-10+deb8u1), libicu52:armhf (52.1-8+deb8u6, 52.1-8+deb8u7), libraspberrypi0:armhf (1.20180125-1compass1, 1.20180326-2compass1), libgfortran3:armhf (4.9.2-10, 4.9.2-10+deb8u1), libtiff5:armhf (4.0.3-12.3+deb8u4, 4.0.3-12.3+deb8u5), isc-dhcp-common:armhf (4.3.1-6+deb8u2, 4.3.1-6+deb8u3), libswscale3:armhf (11.11-1~deb8u1+rpi1, 11.12-1~deb8u1+rpi1), libvorbisenc2:armhf (1.3.4-2, 1.3.4-2+deb8u1), libgcc1:armhf (4.9.2-10, 4.9.2-10+deb8u1), libavformat56:armhf (11.11-1~deb8u1+rpi1, 11.12-1~deb8u1+rpi1), libraspberrypi-dev:armhf (1.20180125-1compass1, 1.20180326-2compass1), cpp-4.9:armhf (4.9.2-10, 4.9.2-10+deb8u1), gcc-4.9:armhf (4.9.2-10, 4.9.2-10+deb8u1), libavcodec56:armhf (11.11-1~deb8u1+rpi1, 11.12-1~deb8u1+rpi1), libubsan0:armhf (4.9.2-10, 4.9.2-10+deb8u1)
End-Date: 2018-03-27  15:41:46


I did update fldigi but I build from the source and I've never had a problem with it. I have a hunch that part of the kernel updated and broke the install.

can anyone help? is there a way to get the audio driver back into the install or would it be easier to just back everything up and re-install from scratch?


73
Art

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.