Re: amixer questions Re: Set Up Issues #draws #setup #fldigi


Joseph Vilardo
 

Merry Christmas Julian

All of the adjustment I made to the receive signal was through the ADC Level of the alsa mixer. FLDIGI has a go no go "diamond shaped" icon on the bottom tool bar of the main screen.   It lights up "black" for low receive audio, "Green" for ok and "Red" for over driven receive. The ADC Level adjustment got the green diamond to light with plenty of room to spare.

Joe K3JV

On 12/25/2018 2:32 AM, Julian OH8STN wrote:
Excellent write up Joe.
Did you adjust any other setting than adjusting ADC level in alsamixer for receive level?

Outstanding post. 
Thanks for sharing 


On 25 Dec 2018 05:13, Joseph Vilardo <jvilardo@...> wrote:

Gents

I wanted to share the good news of having success with the Beta6 image of draws with Direwolf ,  YAAC and a leap today with fldigi running on a Kenwood TM-V71 dual bander.

I downloaded the beta 6 image today and ran through Basil's "Verify_Config.md". I found a  notation symbol that gave me trouble until I changed it.

Under "check ALSA settings for deviation " instructions go as follows:

cd  ~/n7nix/debug

~/alsa-show.sh

I  removing the tilde and the ~/ for the line alsa-show.sh after trying the command as noted several times and then it ran fine.

At first I couldn't get fldigi to allow me to select udrc under the sound card configuration. It just wasn't there. During the Verify_Config.md the instructions required two changes in the /boot/config.txt to test analog audio un comment, remove the # from dtparam=audio=on and /boot/config.txt  hdmi_drive=2 when your done with the Verify_Config.md make sure you go back to /boot/config.txt and comment out, put the # at the beginning of the lines #dtparam=audio=on and #hdmi_drive=2.Reboot and run:

sudo su

cd ~/bin

./ax25-stop

also run :

sudo su

cd ~/bin

./ax25=disable

Now select fldigi from the "internet menu" on the home screen and you should be able to go to the "configure" menu of fldigi then sound card and select "port audio" in the drop down menu you should see the selection for "udrc". If you dont it either means you have not shut down ax25 or you didn't comment out dtparam=audio=on or hdmi_drive=2

Also from the home screen of pi go to preferences and bring up "Audio Device Settings" and setup PCM, ADC Level and LO Driver Gain.

I found that setting the audio out (Transmit) levels where easy to adjust to -20db using the alsa mixer controls of PCM and Lo Driver Gain. I use  a free audio spectrum analyzer called "Spectrum Lab ver 2.93" for setting the audio drive level on fldigi for FM vhf and uhf.  For HF the best thing is to adjust the xmit drive level so you have NO ALC showing for ssb transmit. The signals sound clean on second TM V71 I have. Also the receive gain was easy to adjust to keep the  audio within range of the green indicator diamond on fldigi.

I had not experienced the issues that people were having with FT817 at Ft 891 ?? but I had not tried fldigi with the beta 5 version of the image. Beta 6 seems to work just fine with  the Kenwood TM V71.

Joe K3JV


On 12/23/2018 10:00 PM, John D Hays - K7VE wrote:
fldigi allows you to key the radio using the gpio pin interface (12) to mini din-6 (left)

On Sun, Dec 23, 2018 at 6:44 PM Jack Spitznagel <kd4iz@...> wrote:

Hi Joe,

 

You have a radio I do not know anything about. I’m only about a week ahead of you in learning how to make DRAWS sing. I just happened to have been working with fldigi and my IC-7000 and the questions you asked were central to making fldigi work with the DRAWS hat audio device and that rig.

 

How did you configure fldigi to key your radio? Since you are no longer using a SignaLink, you can’t rely on the SL VOX keying circuit.  If you want to use VOX for PTT, the radio has to have a VOX function and it has to be set up and adjusted.

 

Only other approach I can think of is to make sure your radio can be controlled and/or keyed by flrig’s CAT control and set it up. Then set fldigi to control and key the radio using flrig. That seemed to work for me with my IC-7000 and Yaesu FT-817.

 

Sorry I can’t be more helpful.

 

KD4IZ

Jack Spitznagel

FM19oo

 

 

 

From: udrc@nw-digital-radio.groups.io <udrc@nw-digital-radio.groups.io> On Behalf Of Joseph Vilardo
Sent: Sunday, December 23, 2018 20:36
To: udrc@nw-digital-radio.groups.io
Subject: Re: [udrc] amixer questions Re: Set Up Issues #setup #fldigi #draws

 

Jack

Next issue is with getting the radio to transmit. First off, I have used Fldigi with the TM-V71 many times on vhf uhf with success using a signalink and a sound cards with simple interfaces. I noticed right of the bat that the squelch on my radio does not stop the waterfall with the DRAWS interface...what is that about? Using the alsa mixer control no value of ADC changes the waterfall appearance, it doesn't dim or get brighter with open squelch. Squelching off the signal of the radio does not stop the water fall ??? I have never seen that before. Lastly I cant key the radio and no value of Lo Drive Gain or PCM makes any difference.

Do you have any suggestions ???

Joe K3JV

On 12/23/2018 5:58 PM, Jack Spitznagel wrote:

Joe,

 

  1. Check to make absolutely sure that Direwolf is not running after your reboot.
  2. If it is not running, you should see PortAudio as a selectable option. Check the box.
  3. Now Select udrc: - (hw:0,0) for both capture and playback.
  4. You can also check “Device supports fell duplex” (it is in mine by default and I just left it that way)

 

Hope that helped.

 

KD4IZ

Jack Spitznagel

FM19oo

 

 

 

From: udrc@nw-digital-radio.groups.io <udrc@nw-digital-radio.groups.io> On Behalf Of Joseph Vilardo
Sent: Sunday, December 23, 2018 16:49
To: udrc@nw-digital-radio.groups.io
Subject: Re: [udrc] amixer questions Re: Set Up Issues #setup #fldigi #draws

 

I am looking for some basic guidance on getting fldigi configured for VHF and UHF. I have been successful with the DRAWS Beta 5 image and running Direwolf/YAAC and now that I know the "core image" checks out and works. I rebooted the PI/DRAWS combo and shut down Direwolf and ax25 with this command sequence: cd bin, sudo su, ./ax25-disable.
I then selected fldigi from the drop down menu on the home screen of beta 5 image. When the configuration helper for fldigi comes to selecting the sound card I am left with one option and that is to select "pulseaudio" and it responds wit no pulseaudio server. It doesn't give me an option to choose udrc 0 or 1.
What do I do from here to get an audio source selected ???
Thanks
Joe K3JV


--
J Spitznagel
Science River LLC
KD4IZ


--
J Spitznagel
Science River LLC
KD4IZ


--


John D. Hays
Edmonds, WA
K7VE

   


Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.