Re: Cant turn off direwolf and ax25 #draws #direwolf #ax25 #configuration #management


Bob Orrett <boborrett@...>
 

Good idea. I will do that. 
Merry Christmas
Ve3obo

On Tue, Dec 25, 2018, 00:29 Art Olson <olson339@... wrote:
Bob

Can’t speak for this implementation as I am waiting for the next DRAW run to be shipped. However my experience with other rpi implementations, my SD card contained a single image. I make sure by reformatting with SD formatter then burn image with etcher. You could try this approach. 

FWIW

Art


On Dec 24, 2018, at 8:58 PM, Bob Orrett <boborrett@...> wrote:

Merry Christmas,  Basil.
I dont expect to hear back from you for a few days.
I am trying to get wsjtx and js8call running. I did have this working so I know the 817 radio is ok. I could not use the supplied cables but I have an alternate cable that worked. However, now, with a new image burned, I cannot get the audio part to work. I do see the correct codec in settings for wsjtx and js8call but not audio appears. I
As you suggested, I tried stating direwolf with ./ax25-start but I get this message
A dependance job for ax25-mheardd.. service failed. See 'journalctl -xe' for details.
I did run journalctl -xe and got a full page report. I can screen capture it but I have no idea how to send it to you.
In red it says "Failed to start AX25 device"

So there must be something wrong with my new image but I have tried several times. 
I did notice that the one time it did work, on first bootup ,I was asked a few questions before it went to the standard desktop. I have never been asked since for anything, no passwords, no timezone, etc, for any new image I have tried, either bata5 or beta5. It just goes directly to the standard desktop upon bootup. Even first time. To burn the image i download zipped file from your download page. Then unzip with windows 10 then burn to the sd card with Etcher. I usually just burn onto the same sd card that had the previous burn. Am I doing this correctly? Does it matter that the sd card was not empty when I burn onto it?
I will try another burn with a new download. 

Btw my return on journalctl -xe also said 
Error setting device : ax0 parks

Same for ax1

Hope that's enough info
Bob ve3obo

On Mon, Dec 24, 2018, 01:21 Basil Gunn <basil@... wrote:

if direwolf & ax-25 are already stopped then running ./ax25-stop does
not respond with anything.

type pidof direwolf
if no process id is printed direwolf is not running

try starting & stopping it.
./ax25-start
./ax25-stop

Is your radio set for AFOUT or DISCOUT?
 - On your radio what is Menu #39 (PKT MIC) set to?
 - On your radio what is Menu #40 (PKT RATE) set to?
Are you using VHF/UHF or HF?
Which audio port are you using left or right?

Send me the console output of
cd
cd bin
./showudrc.sh
./alsa-show.sh

draws-beta5 image defaulted to using DISCOUT (IN1)
draws-beta6 image defaults to using AFOUT (IN2)

/Basil

Bob Orrett <boborrett@...> writes:

> I am a newbie to RPi and linux.
> I have the beta6 installed and running. I cannot seem to be able to stop
> direwolf and ax25 so that ft8 and js8call will get access to the draws
> sound card.
> I entered
>
> cd
> cd bin
> sudo su
> ./ax25-stop
>
> The pi returns the command prompt but not anything like "ax25 has stopped".
> I see the correct sound card input and output codec in the settings for
> these programs (ft8 and js8call) but no audio from the ft817 radio. I had
> this working before. What am I missing?
>
> Bob ve3obo



Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.