Re: Cant turn off direwolf and ax25 #draws #direwolf #ax25 #configuration #management


Joseph Vilardo
 

Bob

I have been had more than once with the underscore. Depending on what you view it with, printed or on a screen, it can disappear! I found that the disappearing act is most vulnerable on a screen, the cursor can hide it.

There are some other, what I call nuances but an experienced Linux programmer calls "notation conventions"  in Basil's instructions. I am not an experienced Linux programmer and if I repeatedly try a command and get stumped, sometimes I trying variations of the commands until I get it to work. Many times I have to walk away and come back later.  The red tilde is still a mystery for me and if you print the instructions the red tilde show up as a mere suggestion, it is really hard to see.

I found some other anomalies in getting FLDIGI to work that are not shown in the instructions that I will try to get clarified by Basil but for now I have it running without issues but also not as the instructions tell you. I hate to burden the guy with "MY" concerns or problems when there are many guys wrestling with stopping direwolf and ax25 or just getting the image core verified.

If you venture into fldigi and run into problems let me know I have some minor changes that worked for me.

73 K3JV Joe

On 12/26/2018 9:25 AM, Bob Orrett wrote:
Finally after many frustrating  days, wsjtx and js8call are working with the draws hat. It was my fault and probably a rookie mistake but I will explain in case others are making the same mistake.  It is in Basil's script. I read the script each time that I loaded a new image but I misinterpreted  how to use it. 
There is a line that says, "if you want direwolf functionality, do this". Well , I didnt want direwolf so I didn't do the script below. A mistake! When I finally decided to run that script everything worked. I was always wondering  why I was never asked for a password (nwcompass). 
But even then it took many tries before i finally noticed that between "app" and "config" there is an underscore "_" not a dash"-". I have never seen and underscore in a command before and the print is very small. I realize now that i should get my email with the raspberry pi so that i can cut and paste instead of read and type. Linux doesn't help you when you make a typing error. Just says that the command does not exist. That make me think there is something wrong with the program, not my typing. 
I am a retired teacher and one thing i learned is that giving foolproof instructions is very difficult. There are often assumptions made by the reader and the writer that can result is complete misunderstandings. Adding the reason for a given command is a big help. Don't worry about insulting the reader, give hints and examples. Explain what the response to a given command should be.
Well, i feels good to be over this hurdle, on to the next. 
Bob ve3obo.

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.