GPS not working #gpsd #gps

oe8bck
 

Hi,

I got my DRAWS last week after waiting 4 weeks on customs. Today I wanted to check XAstir, but GPS is not working:
---
pi@draws:~ $ sudo service gpsd status
● gpsd.service - GPS (Global Positioning System) Daemon
   Loaded: loaded (/lib/systemd/system/gpsd.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2019-01-14 21:19:10 CET; 37s ago
  Process: 1282 ExecStart=/usr/local/sbin/gpsd $GPSD_OPTIONS $OPTIONS $DEVICES (code=exited, status=0/SUCCESS)
 Main PID: 1283 (gpsd)
   CGroup: /system.slice/gpsd.service
           └─1283 /usr/local/sbin/gpsd -n /dev/ttySC0 /dev/pps0

Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: SER: read-only device open of /dev/pps0 failed: No such file or directory
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: initial GPS device /dev/pps0 open failed
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: SER: device open of /dev/ttySC0 failed: No such file or directory - retrying read-only
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: SER: read-only device open of /dev/ttySC0 failed: No such file or directory
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: /dev/ttySC0: device activation failed.
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: /dev/ttySC0: activation failed, freeing device
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: SER: device open of /dev/pps0 failed: No such file or directory - retrying read-only
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: SER: read-only device open of /dev/pps0 failed: No such file or directory
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: /dev/pps0: device activation failed.
Jan 14 21:19:11 draws gpsd[1283]: gpsd:ERROR: /dev/pps0: activation failed, freeing device
pi@draws:~ $ lsmod
Module                  Size  Used by
fuse                  110592  3
rfcomm                 49152  4
bnep                   20480  2
hci_uart               36864  1
btbcm                  16384  1 hci_uart
serdev                 20480  1 hci_uart
bluetooth             368640  29 hci_uart,bnep,btbcm,rfcomm
ecdh_generic           28672  1 bluetooth
xt_tcpudp              16384  4
ip6table_filter        16384  0
ip6_tables             24576  1 ip6table_filter
iptable_filter         16384  1
brcmfmac              307200  0
brcmutil               16384  1 brcmfmac
cfg80211              573440  1 brcmfmac
rfkill                 28672  6 bluetooth,cfg80211
snd_bcm2835            32768  1
snd_pcm                98304  1 snd_bcm2835
snd_timer              32768  1 snd_pcm
snd                    69632  5 snd_timer,snd_bcm2835,snd_pcm
uio_pdrv_genirq        16384  0
fixed                  16384  0
uio                    20480  1 uio_pdrv_genirq
ax25                   69632  0
i2c_dev                16384  0
ip_tables              24576  1 iptable_filter
x_tables               32768  5 ip_tables,iptable_filter,xt_tcpudp,ip6table_filter,ip6_tables
ipv6                  425984  38
---
Any idea what's wrong? I have just the USB plug as power connector. Do I need to attach a 12V supply?

73 de OE8BCK Christof

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.