Re: #ax25 Getting It Started After Config #ax25


Basil Gunn
 

Ed,

I think I have a solution to your problem.

You will need to get the latest versions of a couple of scripts, turn
ax25 off, reboot then turn ax25 back on and verify.
It will be helpful if you could send me the console output for the
commands below.

# Get the latest versions of scripts
cd
cd n7nix
git pull

# Refresh the local bin directory
cd config
./bin_refresh.sh

# Check the ax25 status
ax25-status

# stop direwolf & ax.25
sudo su
./ax25-stop

# Check the ax25 status
./ax25-status

### REBOOT your RPi
shutdown -r now

### login and start direwolf & ax.25
cd
cd bin
sudo su
./ax25-start

# Check you ax25 status
./ax25-status

# check that ax25-status is in your path
# Leave user root & become user pi
exit
ax25-status

Thanks,
/Basil


Ed Bloom, KD9FRQ <@KD9FRQ> writes:

Basil,

Here are the two files as requested.

Thanks again. 73s, Ed, KD9FRQ


On 1/23/2019 10:50 AM, Ed Bloom, KD9FRQ wrote:
Basil,
Thank you for working on this. I will get the results for you when I
get home from work.
journalctl -u ax25dev.service > journalctl.log
head -n 20 /etc/ax25/ax25-upd > head.log
As to your question "What did I enter for :
"If you do not understand or care about the following just hit enter
for default values"
"Enter ip address for AX.25 interface ax0 followed by [enter]"
I just pressed enter with no values provided. If I should have
entered a value, I respectfully request an update to
the Get Started with a"recommended value" if this is the cause of my
system issue.
Ed Bloom
@KD9FRQ <mailto:@KD9FRQ>
Sent from Webmail access
-----Original Message-----
From: Basil Gunn <@basil860>
To: udrc <udrc@nw-digital-radio.groups.io>
Sent: Wed, Jan 23, 2019 10:44 am
Subject: Re: [udrc] #ax25 Getting It Started After Config


Thanks for the files. kissattach is failing because one of the
parameters is not in the correct format. The defaults should work
so I need to determine which parameter kissattach is barfing on.

Could you please send the console output of the following commands:
journalctl -u ax25dev.service
head -n 20 /etc/ax25/ax25-upd

Do you recall what you entered when this prompt was displayed during
your initial configuration?

"If you do not understand or care about the following just hit enter for
default values"
"Enter ip address for AX.25 interface ax0 followed by [enter]"

When you can display some active ax25 sockets you can proceed with other
tests.
netstat --ax25

/Basil

I don't have enough information yet to figure out what your problem is.

Please send me the contents of the following files:

/var/log/udr_install.log
/etc/ax25/axports

and the output of

ax25-status -d

/Basil

Ed Bloom, KD9FRQ <@KD9FRQ <mailto:@KD9FRQ>>
writes:

Following up....

I have "no AX.25 ports defined" when running ./btest.sh -P udr0 as
part
of the Test & Verification.

So I missed something.

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.