Re: error during udrc-dkms


 

It should also be mentioned, you can use apt-get upgrade package-name to upgrade packages without upgrading everything.  Eg. sudo apt-get upgrade nano only upgrades the nano editor (and packages that it depends upon) and will not do a general upgrade.

The general rule of thumb should be to only upgrade when needed, eg. to address a bug/new feature or security issue, not just because there is a newer version.



On Wed, May 29, 2019 at 11:33 AM Basil Gunn <basil@...> wrote:

On the systems I have tried to do the apt-get upgrade, the kernel
upgrade failed ... which is a good thing. The 4.14.98-v7+ kernel is
working fine for me on those systems.  What I'm saying is if you try to
do an apt-get upgrade it is not catastrophic. The kernel upgrade should
fail & you will be left with a working system.

I will let you know when an 'apt-get upgrade' is working as expected.
I am thinking this will be several months out. A patch must be accepted
in the Linux kernel (see kernel.org) and then Raspbian will choose a
kernel to include in their distribution.

/Basil
Steve, N9VW <steve@...> writes:

> Basil,
> It seems that I was bitten by the upgrade issue as well. Will a notice
> be sent out to all when it is safe to do an "apt-get upgrade" on the system?
>
> Thanks
> Steve, N9VW
>
> On 5/28/2019 10:02 PM, Basil Gunn wrote:
>> Bernard,
>>
>> The tlv320aic3204 driver in the 4.19.42 kernel will NOT work
>> reliably. You need to stick with the  4.14.98 kernel until all of Anna's
>> patches work their way into the main stream kernel.
>>
>>  From  Anna:
>>
>>> ALSA changed the API to some of their calls, and the old TLV320 driver
>>> doesn’t have the calls.  The new TLV320 driver is in the Raspbian
>>> kernel, but it won’t work reliably until I get the final patch pushed
>>> in the kernel.
>> Do NOT do an apt-get upgrade for a while until this gets fixed.
>> I have taken apt-get upgrade out of prog_refresh.sh script.
>>
>> /Basil
>>
>> f6bvp <f6bvp@...> writes:
>>
>>> Here are my Compass beta 13 current software versions:
>>>
>>> Linux compass-f6bvp 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 GMT 2019
>>> armv7l GNU/Linux
>>>
>>> Gnu C                  6.3.0
>>> Gnu make               4.1
>>> binutils               2.28
>>> util-linux             2.29.2
>>> mount                  debug
>>> module-init-tools      23
>>> e2fsprogs              1.43.4
>>> Linux C Library        2.24
>>> Dynamic linker (ldd)   2.24
>>> Net-tools              2.10-alpha
>>> Kbd                    2.0.3
>>> Sh-utils               8.26
>>> wireless-tools         30
>>> Modules Loaded         fuse rfcomm bnep hci_uart btbcm serdev bluetooth
>>> ecdh_generic pps_ldisc xt_tcpudp ip6table_filter ip6_tables
>>> iptable_filter joydev evdev ads1015 sg hwmon sc16is7xx tlv320aic32x4_i2c
>>> uas tlv320aic32x4 brcmfmac brcmutil cfg80211 rfkill udrc
>>> snd_soc_bcm2835_i2s snd_soc_core snd_compress snd_pcm_dmaengine snd_pcm
>>> snd_timer snd i2c_bcm2835 pps_gpio pps_core uio_pdrv_genirq fixed uio
>>> ax25 i2c_dev ip_tables x_tables ipv6
>>
>>
>>
>
>
>





--
John D. Hays
Kingston, WA
K7VE

 

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.