Re: paclink-unix incoming messages


Keith Williamson
 

Hi Basil,

I don't know how the dovecot 10-auth.conf file got scrozzled but I found CSV data from the WWARA repeater list appended. I ended up copying over it with the copy in /usr/share/dovecot/conf.d and after a reboot, dovecot comes up fine. However, I don't know what mods your install may have made to it to work in this environment.

Can you send me a copy of /etc/dovecot/conf.d/10-auth.conf or is it identical to the one in /usr/sharedovecot/conf.d?

Thanks,

Keith


On Tue, Jun 4, 2019 at 4:59 PM Keith Williamson via Groups.Io <hkwilliamson=gmail.com@groups.io> wrote:


On Tue, Jun 4, 2019 at 3:27 PM Basil Gunn <basil@...> wrote:

> I ran "app_config.sh plu" not "app_config.sh pluimap". So are the above
> services configured? I haven't messed with any config
> files you haven't specifically told me to modify.

The plu config script sets wl2k.conf like this:

   ## Set email=user_name@localhost

   sed -i -e "s/^#email=.*/email=$USER@localhost/" $PLU_CFG_FILE

And your wl2k.conf file had your gmail account in it. How did that happen?

As I mentioned in my previous email, I was trying to get paclink to successfully authenticate. My callsign and password matched the working config of Winlink Express but the email address is my gmail address in WE but the email address in the wl2k.conf was pi@localhost. Was grasping at straws so changed it to match. Then after updating paclink to latest and resolving the issue, forgot to go back in and change it back. Doh. When retrieving a message from the CMS, I noticed the detail output from wl2ktelnet showing it invoking sendmail to my gmail address. 

> We verified with netstat -tulpn that nothing is listening on ports 143 or
> 993.

Can you determine if claws-mail has been installed?
Dovecot gets installed from claws-mail install script.
Is there a desktop icon for claws-mail?

Yes, I have claws-mail on the desktop. However, Ill need to configure it based on:
once we have the IMAP server running. 

I looked in /lib/systemd/system and see there is dovecot.service. Running "systemctl status dovecot.service":

root@Compass:/home/pi# systemctl status dovecot.service
● dovecot.service - Dovecot IMAP/POP3 email server
   Loaded: loaded (/lib/systemd/system/dovecot.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2019-06-04 09:05:44 PDT; 7h ago
     Docs: man:dovecot(1)
           http://wiki2.dovecot.org/
  Process: 415 ExecStart=/usr/sbin/dovecot (code=exited, status=89)

Jun 04 09:05:42 Compass systemd[1]: Starting Dovecot IMAP/POP3 email server...
Jun 04 09:05:44 Compass dovecot[415]: doveconf: Fatal: Error in configuration file /etc/dovecot/conf.d/10-auth.conf line 14: Expecting '{'
Jun 04 09:05:44 Compass systemd[1]: dovecot.service: Control process exited, code=exited status=89
Jun 04 09:05:44 Compass systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
Jun 04 09:05:44 Compass systemd[1]: dovecot.service: Unit entered failed state.
Jun 04 09:05:44 Compass systemd[1]: dovecot.service: Failed with result 'exit-code'.
root@Compass:/home/pi#

I haven't touched any dovecot config files.


If not perhaps that part of the script had a problem. Try installing claws-mail
separately and capture all the console output as user pi (not root)

cd
cd n7nix/email/claws
./claws_install.sh pi KF7DRV

> I do see that pluweb is running. It seems to work fine to check outbox and
> run wl2k*.

Good.
Can you determine if rainloop is installed?
In a browser type this url: localhost/?admin

Yep, rainloop answers up with a login/password page.

/Basil





Virus-free. www.avg.com

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.