Re: gpsd, amixer, sensor, and other issues


Basil Gunn
 

Julie,

Could you please run this command:

i2cdetect -y 1

Should have devices at addresses: 0x18, 0x48 & 0x50
Thanks,
/Basil

Bryan Hoyer <@K7UDR> writes:

Hi Julie,

ADC, CODEC and Serial (GPS) rely on I2C, which is tested in manufacture. I’m with Basil, it sounds defective.

Please return to:

NW Digital Radio
RMA <order number>
245 Highlands Drive
Friday Harbor WA 98250

Thanks,
Bryan K7UDR

On Jun 7, 2019, at 8:47 AM, Basil Gunn <@basil860> wrote:


Hi Julie,

I'm reasonably sure that the draws board you are helping with is
defective. I have an email out to the other NW Digital people to
confirm my suspicion noting these symptoms:

* The rPi is powered via the draws card which is reading 14.12 vdc
* Pin 2 on the gpio is reading 5.047 vdc
* Replaced the rpi unit with a new one - no change.
* Replaced the SDCard with a new 32 GB card with fresh Beta 13 build - twice - no change
* aplay -l enumerates the udrc sound device ok
* amixer gives an error message I have never seen before
* gps, sensors & sound codec appear to be not responding

Thanks for your patience.
/Basil

Julie McGrew via Groups.Io <juliemcgrew=mac.com@groups.io> writes:

Good morning Basil,

The rPi is powered via the draws card which is reading 14.12 vdc
Pin 2 on the gpio is reading 5.047 vdc

pi@K7TMV-draws:~ $ amixer -c udrc get "LO Driver Gain"
amixer: Mixer hw:1 load error: Remote I/O error

Many thanks,
julie
ac0wn


Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.