Re: no transmit #wsjt-x


Basil Gunn
 

Rob,

Verify that transmit is working with the simplest program possible.
Use the measure_deviate.sh script to output a tone on a specific
channel. Assuming you are using the mDin6 connector closest to the gps
SMA connector. If you tune a second radio to the same frequency as the
first you should hear a tone.

cd
cd n7nix/deviation
./measure_deviate.sh -c left

To see the command line parameter options:
./measure_deviate.sh -h

Also send the console output of showudrc.sh

/Basil

Rob Lapham <ke6jus@...> writes:

I've been trying to get my Raspberry Pi 3 working with my DRAWS hat but I think either my connection is messed up or my audio setup / levels wrong.

I think Im doing something wrong I have used the draws manager and no transmit

## Symptoms
- receive work
- Nothing on ALC meter when I tune with WSJT-X

## Hardware

- Yaesu FT-817
- Raspberry Pi 3
- DRAWS hat

## Settings

- 24 Dig Disp: 0Hz
- 25 Dig Mic: 61
- 26 Dig Mode: User-U
- 27 Dig Shift: 0Hz
- 38 Op Filter: Off
- AGC: Fast
- Noise Blanker: Off

## Connections

-with and without Pin 6 removed from the Data cable
- Data cable in Left (facing the connectors) jack
- USB Serial CAT cable
- into antenna or dummy load

## WSJT-X Setup

- CAT control set up and working
- Input: plughw:CARD=udrc,DEV=0 in left
- Output: plughw:CARD=udrc,DEV=0 in left

I've tried Left, Right, and other udrc input devices to no success)

## ALSA Setup

I ran the setup-ft817.sh script to set my levels:

===== ALSA Controls for Radio Transmit =====
LO Driver Gain L:[-6.00dB]R:[-6.00dB]
PCM L:[-16.50dB]R:[-16.50dB]
DAC Playback PTL:[PTM_P3]R:[PTM_P3]
LO Playback CM[Full Chip CM]
===== ALSA Controls for Radio Receive =====
ADC LevelL:[-2.00dB]R:[-2.00dB]
IN1L:[Off]R:[Off]
IN2L:[10 kOhm]R:[Off]
CML:[10 kOhm]R:[10 kOhm]
Thanks,
Rob
k6jus

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.