Re: Using the DRAWS hat with a Raspberry Pi 4 #draws #yaac #install #js8call #replacecompass

Edouard Lafargue
 

One thing I have noticed about those discussions whether udrc/draws works or not on various Pis: the necessary codecs for the DRAWS/UDRC seem to be hit or miss in the latest kernel module distributions on Raspbian:
 
root@raspberrypi:/lib/modules# find . -name "*tlv*"
./4.19.66+/kernel/sound/soc/codecs/snd-soc-tlv320aic32x4-i2c.ko
./4.19.66+/kernel/sound/soc/codecs/snd-soc-tlv320aic32x4.ko
./4.19.66-v7+/kernel/sound/soc/codecs/snd-soc-tlv320aic32x4-i2c.ko
./4.19.66-v7+/kernel/sound/soc/codecs/snd-soc-tlv320aic32x4.ko
./4.19.69+/kernel/sound/soc/codecs/snd-soc-tlv320aic32x4-i2c.ko
./4.19.69+/kernel/sound/soc/codecs/snd-soc-tlv320aic32x4.ko
./4.19.66-v7l+/kernel/sound/soc/codecs/snd-soc-tlv320aic32x4-i2c.ko
./4.19.66-v7l+/kernel/sound/soc/codecs/snd-soc-tlv320aic32x4.ko
root@raspberrypi:/lib/modules#
 
   For instance, the modules are missing from 4.19.69-v8+ which is the current latest RPi kernel as of Sept 4th.
 
  -> If you type 'uname -a' and your kernel version does not match one of the versions that contain the right modules, you'll be out of luck. My impression is that this might be one of the reasons why some people get the DRAWS working right away, and some just can't get it to load: it all depends on when you did your latest kernel update through "apt-get upgrade"

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.