Re: Setting Up PAT with the #draws

K4KDR
 

Hi Ed!

There are two issues to take care of here.  As was mentioned, 0.0.0.0 is not the address for you to use.  When you are accessing a web page on the same machine you are using, the "loopback" or "localhost" address is 127.0.0.1

The other thing to take care of is that it's necessary to change the default port used by PAT since, as you mentioned, 8080 is used by the DRAWS Manager.

So, as you might have already done to setup your call sign in PAT,  type "pat configure" from a command prompt.  Scroll down a few lines and change the port to something other than "8080".  Here is what that line looks like in my setup, for example:

"http_addr": "localhost:8888",

... so, if you use 8888, the URL to type into your browser (after typing "pat http" in a terminal window) would be:


And you'll be all set!

-Scott,  K4KDR

=====================


On Sat, Sep 14, 2019 at 4:16 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta 13. I've made a video tutorial, but need to edit before posting. It will release on my YouTube channel Tuesday Aug 27 at 1600 central.

73,
KM4ACK
Find me on YouTube

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.