Re: #ax25 #direwolf system failing suggested checks #direwolf #ax25


Ryan Matthew Headley
 

I will get all of that together tomorrow.

I did check that the udrc was appearing is alsa.  I will send you everything tomorrow.

On Tue, 3 Dec 2019, 17:33 Basil Gunn, <basil@...> wrote:

> Something is going wrong from the very beginning.

What OS & program are you using to flash the microSD card?

> I have done three straight flashes on the NW Digital image. I have
> followed the steps in 'Getting Started' to the letter. I have powered
> the hat with 13.8v and had consistent good CPU temps.

I'm trying to help you which is difficult if you don't do what I ask you
to do. See previous post.

Before you run any configuration scripts determine if the drivers have
enumerated the hardware by running aplay -l (from previous post)
If you do NOT see udrc with this command there is no script that will
fix that problem.

> ~/n7nix/git pull (not in instructions, but recommended in forums)
> ~/n7nix/config/app_config.sh core
> reboot
> ~/n7nix/config/cfgcheck.sh shows that I have not run app_config.sh core

In an email addressed to me only can you copy the entire console output
of running app_config.sh core?
If you use the script command it will put all console output into a
file. See previous post.

> ~/bin/ax25-start
> ~/n7nix/debug/btest -P udr0 shows that udr0 does not exist.

Please follow the instructions I previously gave you. There is no use in
running the config script if the DRAWS hat is not enumerated.

> There are only three possibilities:
>
> 1)There is a problem in the image
I don't think so as I test it often

> 2)There is a problem in the config scripts
Possibly. If you share your console output I will have a chance to
understand the problem

> 3)There is a problem with the DRAW hat itself
Possibly but unlikely given the symptoms you have supplied.



Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.