Re: DRAWS Image 15 and Xastir

Basil Gunn
 

Jack,
Not sure if this worked or not. Guessing it didn't.
Some files in your file system are corrupted.

As a last attempt do this:

dpkg -l "rpi-eeprom*"
# Note asterisk at end of rpi-eeprom

sudo su

# Note asterisks at end of lines

rm /var/lib/dpkg/info/rpi-eeprom-images*
rm /var/cache/apt/archives/rpi-eeprom-images*

apt-get remove rpi-eeprom-images
apt-get install rpi-eeprom rpi-eeprom-images

dpkg -l "rpi-eeprom*"
# Note asterisk at end of rpi-eeprom

Jack Spitznagel <@flyingfrawg> writes:

Ran the commands and here is the console output:

pi@kd4izdraws2:~ $ sudo su
root@kd4izdraws2:/home/pi# dpkg -l "rpi-eeprom"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-==================================
ii rpi-eeprom 5.0-2 all Raspberry Pi 4 boot EEPROM updater
root@kd4izdraws2:/home/pi# apt-get remove rpi-eeprom-images
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
flashrom libftdi1-2 libusb-0.1-4
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
rpi-eeprom rpi-eeprom-images
0 upgraded, 0 newly installed, 2 to remove and 0 not upgraded.
After this operation, 7,798 kB disk space will be freed.
Do you want to continue? [Y/n] y
dpkg: unrecoverable fatal error, aborting:
files list file for package 'rpi-eeprom-images' contains empty filename
E: Sub-process /usr/bin/dpkg returned an error code (2)
root@kd4izdraws2:/home/pi# apt-get install rpi-eeprom rpi-eeprom-images
Reading package lists... Done
Building dependency tree
Reading state information... Done
rpi-eeprom is already the newest version (5.0-2).
rpi-eeprom-images is already the newest version (5.0-2).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@kd4izdraws2:/home/pi# dpkg -l "rpi-eeprom"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-==============-============-============-==================================
ii rpi-eeprom 5.0-2 all Raspberry Pi 4 boot EEPROM updater
root@kd4izdraws2:/home/pi#

Hope we aren't chasing a princess riding a unicorn... sure seems like
it. Maybe better to just start with a clean image? Only thing bothers
me is that this happened twice on two different units. Only messing
with one to try to fix it.

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.