Re: Icom 706MKIIG Setup #ptt #icom


 

I just got to this.   You probably needed to upgrade nodejs ?

# Using Debian, as root
curl -sL https://deb.nodesource.com/setup_13.x | bash -
apt-get install -y nodejs

On Sun, Apr 5, 2020 at 10:46 AM KB5ZUR <kb5zur@...> wrote:
I got it fixed sorry for the prior post.
looks like I am up and going now.
-Kb5zur-David

On Sun, Apr 5, 2020 at 12:22 PM David Savells <kb5zur@...> wrote:
Well I have manages to break draws-manager. I get the following messages when I check the status:
● draws-manager.service - DRAWS™ Manager - A web application to manage the DRAW™ HAT configuration.
   Loaded: loaded (/etc/systemd/system/draws-manager.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Sun 2020-04-05 12:15:39 CDT; 2min 26s ago
     Docs: https://github.com/nwdigitalradio/draws-manager
  Process: 456 ExecStart=/usr/bin/npm start (code=exited, status=1/FAILURE)
 Main PID: 456 (code=exited, status=1/FAILURE)

Apr 05 12:15:39 DRAWS15 npm[456]: npm ERR! errno 1
Apr 05 12:15:39 DRAWS15 npm[456]: npm ERR! webapp@0.0.1 start: `node ./bin/www`
Apr 05 12:15:39 DRAWS15 npm[456]: npm ERR! Exit status 1
Apr 05 12:15:39 DRAWS15 npm[456]: npm ERR!
Apr 05 12:15:39 DRAWS15 npm[456]: npm ERR! Failed at the webapp@0.0.1 start script.
Apr 05 12:15:39 DRAWS15 npm[456]: npm ERR! This is probably not a problem with npm. There is likely additional logging output above.
Apr 05 12:15:39 DRAWS15 npm[456]: npm ERR! A complete log of this run can be found in:
Apr 05 12:15:39 DRAWS15 npm[456]: npm ERR!     /root/.npm/_logs/2020-04-05T17_15_39_643Z-debug.log
Apr 05 12:15:39 DRAWS15 systemd[1]: draws-manager.service: Main process exited, code=exited, status=1/FAILURE
Apr 05 12:15:39 DRAWS15 systemd[1]: draws-manager.service: Failed with result 'exit-code'.

additional log info:
0 info it worked if it ends with ok
1 warn npm npm does not support Node.js v10.15.2
2 warn npm You should probably upgrade to a newer version of node as we
3 warn npm can't make any promises that npm will work with this version.
4 warn npm Supported releases of Node.js are the latest release of 4, 6, 7, 8, 9.
5 warn npm You can find the latest version at https://nodejs.org/
6 verbose cli [ '/usr/bin/node', '/usr/bin/npm', 'start' ]
7 info using npm@5.8.0
8 info using node@...
9 verbose run-script [ 'prestart', 'start', 'poststart' ]
10 info lifecycle webapp@0.0.1~prestart: webapp@0.0.1
11 info lifecycle webapp@0.0.1~start: webapp@0.0.1
12 verbose lifecycle webapp@0.0.1~start: unsafe-perm in lifecycle true
13 verbose lifecycle webapp@0.0.1~start: PATH: /usr/share/npm/node_modules/npm-lifecycle/node-gyp-bin:/usr/local/var/draws-manager/webapp/node_modules/.bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin
14 verbose lifecycle webapp@0.0.1~start: CWD: /usr/local/var/draws-manager/webapp
15 silly lifecycle webapp@0.0.1~start: Args: [ '-c', 'node ./bin/www' ]
16 silly lifecycle webapp@0.0.1~start: Returned: code: 1  signal: null
17 info lifecycle webapp@0.0.1~start: Failed to exec start script
18 verbose stack Error: webapp@0.0.1 start: `node ./bin/www`
18 verbose stack Exit status 1
18 verbose stack     at EventEmitter.<anonymous> (/usr/share/npm/node_modules/npm-lifecycle/index.js:283:16)
18 verbose stack     at EventEmitter.emit (events.js:189:13)
18 verbose stack     at ChildProcess.<anonymous> (/usr/share/npm/node_modules/npm-lifecycle/lib/spawn.js:55:14)
18 verbose stack     at ChildProcess.emit (events.js:189:13)
18 verbose stack     at maybeClose (internal/child_process.js:970:16)
18 verbose stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:259:5)
19 verbose pkgid webapp@0.0.1
20 verbose cwd /usr/local/var/draws-manager/webapp
21 verbose Linux 4.19.97-v7+
22 verbose argv "/usr/bin/node" "/usr/bin/npm" "start"
23 verbose node v10.15.2
24 verbose npm  v5.8.0
25 error code ELIFECYCLE
26 error errno 1
27 error webapp@0.0.1 start: `node ./bin/www`
27 error Exit status 1
28 error Failed at the webapp@0.0.1 start script.
28 error This is probably not a problem with npm. There is likely additional logging output above.
29 verbose exit [ 1, true ]



Any ideas on how to fix this ?

-Kb5zur David


On Sat, Apr 4, 2020 at 1:22 PM John D Hays - K7VE <john@...> wrote:
As I recall WSJT-X uses Hamlin/CAT for PTT. 

On Sat, Apr 4, 2020, 10:55 KB5ZUR <kb5zur@...> wrote:
I'm struggling with the TX audio settings in JS8Call. When i use the recommended settings based on the 0.4V Peak to Peak value for my ICOM 706, I don't seem to output any power. When I adjust the values up, I get power output but no replies to my CQ's or replies to other stations I can hear.

I would like to do some testing in WSJT-X Ver 2.1.2 but don't see a way PTT with the script file.  

2 Questions: 
Can you recommend TX Audio setting for my ICOM706MkIIG 
Do you know if WSJT-X supports Advanced PTT settings for the script file for keying?

On Sat, Apr 4, 2020 at 11:10 AM David Savells <kb5zur@...> wrote:
Couldnt find advanced PTT setting in WSJT-X 

which ptt_ctrl.sh showed  /home/pi/bin/ptt_ctrl.sh
So I set that path in JS8Call and it is now keying the radio.
Just now getting into the TX audio adjustments but looks like I can TX using the Test PTT button in JS8Call setup.
Ill follow up once I can confirm proper operation
Thanks again for your help.
-Kb5zur David


On Sat, Apr 4, 2020 at 10:55 AM Basil Gunn <basil@...> wrote:

Hi David,

> Try using the path that comes back from the above command for js8call
> /home/pi/bin/ptt_ctrl.sh %1
>
> I'll test this later on today.

Using full path seems to work fine for script /home/pi/bin/ptt_ctrl.sh
%1 and js8call

Have you used wstx?
What did you use for PTT control when using wstx and ICOM 706MKIIg?

/Basil n7niix





--
John D. Hays
Kingston, WA
K7VE

 

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.