Direwolf Update Script Errors


Troy - K4JDA
 

Im running the direwolf update script
sudo ./dw_update.sh
and get the following errors (snip of the last several lines of output):

...
 inflating: direwolf-dev/test/scripts/check-modem9600  
  inflating: direwolf-dev/tnc-test-cd-results.png  
finishing deferred symbolic links:
  direwolf-dev/debian/changelog -> ../CHANGES.md
Building direwolf in directory /usr/local/src/direwolf-dev
As of Jan 6 (May 2) build will fail with "
   /usr/local/src/direwolf-dev/src/dwgpsd.c:65:2: error: #error libgps API version might be incompatible.
See direwolf github issues #241
 
mkdir: cannot create directory ‘build’: File exists
CMake Error: The source directory "/usr/local/src" does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.
 
direwolf version was: version is now: Dire Wolf DEVELOPMENT version 1.6 E (May 11 2020)
 

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.