Re: Update for ADC Config File #sensors #adc


Jack Spitznagel
 

Bryan,

 

That’s the problem! Most of the critical lines are missing in that file.

 

Mine reads:

chip "ads1015-*"

label in3 "User ADC Differential“

label in4 "+12V"               

label in6 "User ADC 1"

label in7 "User ADC 2"

compute in4 ((48.7/10)+1)*@, @/((48.7/10)+1)

 

Nothing about label ln5 or the “compute” for that line. I’ll create those lines and see what happens.

 

Jack – KD4IZ

 

From: udrc@nw-digital-radio.groups.io <udrc@nw-digital-radio.groups.io> On Behalf Of Bryan Hoyer
Sent: Tuesday, July 21, 2020 15:02
To: udrc@nw-digital-radio.groups.io
Subject: Re: [draws and udrc] Update for ADC Config File #sensors #ADC

 

Check This File carefully, the last line performs the 2X

 

pi@K7UDR:~ $ cat /etc/sensors.d/draws 

#DRAWS uses the TL024 Which is SW Compatible with thw ADS1015

#It's an 8 Channel ADC, but only 4 Channels are pinned out

 

chip "ads1015-*"

        label in4 "+12V"                       

                        label in5 "+5V"

                        label in6 "User ADC 1"

                        label in7 "User ADC 2"

                        compute in4 ((48.7/10)+1)*@, @/((48.7/10)+1)

        compute in5 ((10/10)+1)*@, @/((10/10)+1)

 



On Jul 21, 2020, at 11:53 AM, Jack Spitznagel <kd4iz@...> wrote:

 

Bryan and John,

Essentially the same as yours Bryan! The one line different says:

in5:         +2.50 V

Same as on the Dashboard.

 

The very first thing I did when I re-checked it just now was to update the DRAWS manager “just in case”. I also came back and rebooted the Pi just in case and it still reads in5: +2.50 V. I also had run the manager update yesterday, but had not rebooted – same result. 

 

I wonder if being behind one image version might be an issue? I have lost track, but think this is v16.

 

Also, are you both running Pi3’s or also Pi4’s?

 

Jack – KD4IZ

 

From: udrc@nw-digital-radio.groups.io <udrc@nw-digital-radio.groups.io> On Behalf Of Bryan Hoyer
Sent: Tuesday, July 21, 2020 14:00
To: udrc@nw-digital-radio.groups.io
Subject: Re: [draws and udrc] Update for ADC Config File #sensors #ADC

 

What does sensors report?

 

pi@K7UDR:~ $ sensors

rpi_volt-isa-0000

Adapter: ISA adapter

in0:              N/A  

 

ads1015-i2c-1-48

Adapter: bcm2835 I2C adapter

+12V:        +13.52 V  

+5V:          +5.06 V  

User ADC 1:   +0.00 V  

User ADC 2:   +0.00 V  







On Jul 21, 2020, at 10:34 AM, Jack Spitznagel <kd4iz@...> wrote:

 

Bryan,

 

That’s very interesting! Here is what the new board I just received is reporting:

<image003.jpg>

 

I see “in5: +2.50V” not “+5V: +5.06V” on that top line. Maybe I need to run an update of code here?

Jack – KD4IZ

 

From: udrc@nw-digital-radio.groups.io <udrc@nw-digital-radio.groups.io> On Behalf Of Bryan Hoyer
Sent: Tuesday, July 21, 2020 13:11
To: udrc@nw-digital-radio.groups.io
Subject: Re: [draws and udrc] Update for ADC Config File #sensors #ADC

 

Jack,

 

I just ran DRAWS Manager with the updated config and it works fine.

 

<image004.png>





On Jul 17, 2020, at 12:45 PM, Jack Spitznagel <kd4iz@...> wrote:

 

Great! 

I missed that he was building. Best success to him!

-Jack

 

From: udrc@nw-digital-radio.groups.io <udrc@nw-digital-radio.groups.io> On Behalf Of Bryan Hoyer
Sent: Friday, July 17, 2020 15:06
To: udrc@nw-digital-radio.groups.io
Subject: Re: [draws and udrc] Update for ADC Config File #sensors #ADC

 

John will add it to a future release, after he finishes his new home in Kingston WA






On Jul 17, 2020, at 12:01 PM, Jack Spitznagel <kd4iz@...> wrote:

 

Bryan,

 

Quick Question on that: Has John implemented this in the DRAWS Manager? Does not appear to be the case. At the bottom of current version, the status bar says:

 

Digital Radio Amateur Work Station | Adapter: bcm2835 I2C adapter • +12V: +13.68 V • in5: +2.50 V • User ADC 1: +0.01 V • User ADC 2: +0.00 V 

Raspberry Pi 4 Model B Rev 1.2 | CPU Temp: 108.24° F (42.36° C) • Uptime: 21 hrs 49 mins • Load AVG: 1m:1.07 5m:1.19 15m:1.17 

 

Not in a hurry to do this, but the replacement board is working well… Many thanks.

 

Jack Spitznagel – KD4IZ

Trustee for NR3DT

The USCGC W-37 Amateur Radio Group

 

 

 

From: udrc@nw-digital-radio.groups.io <udrc@nw-digital-radio.groups.io> On Behalf Of Bryan Hoyer
Sent: Friday, July 17, 2020 14:51
To: udrc@nw-digital-radio.groups.io
Subject: [draws and udrc] Update for ADC Config File #sensors #ADC

 

Hello All,

DRAWS Has an on-board ADC to monitor the 12V supply. Sometime after the first run, 5V monitoring was added, but the config file wasn't updated so the sensors command doesn't work correctly.

the fix is to change /etc/sensors.d/draws as follows:

pi@K7UDR:/etc/sensors.d $ cat draws 

#DRAWS uses the TL024 Which is SW Compatible with thw ADS1015

#It's an 8 Channel ADC, but only 4 Channels are pinned out

 

chip "ads1015-*"

        label in4 "+12V"

 label in5 "+5V"

label in6 "User ADC 1"

label in7 "User ADC 2"

compute in4 ((48.7/10)+1)*@, @/((48.7/10)+1)

        compute in5 ((10/10)+1)*@, @/((10/10)+1)

 

rpi_volt-isa-0000

Adapter: ISA adapter

in0:              N/A  

 

ads1015-i2c-1-48

Adapter: bcm2835 I2C adapter

+12V:        +13.52 V  

+5V:          +5.06 V  

User ADC 1:   +0.00 V  

User ADC 2:   +0.00 V  


To learn more about this, check out the man page for lm-sensors

Cheers,
Bryan K7UDR

 

 

 

 

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.