Re: DRAWS - not able to receive APRS #aprs #direwolf #ax25


Basil Gunn
 

I just did a verification using 2M (144.390) APRS on my IC-706MkIIG.
I used both the 13 pin Aux socket & 6 pin miniDin socket connected to
the left mDin6 connector on the DRAWS hat.
I was able to receive APRS packets on both sockets.

direwolf was reporting that the receive signal was a little hot so I
dialed ADC Level down to 0.0dB

Make sure squelch is off.

This is my DRAWS hat version
$ udrcver.sh
Found a DRAWS

HAT ID EEPROM
Name: hat
Product: Digital Radio Amateur Work Station
Product ID: 0x0004
Product ver: 0x0108
UUID: ca33c9d0-765a-434b-870a-0dbebedf01f4
Vendor: NW Digital Radio

Tomorrow I will try to replicate from a fresh install.

Basil Gunn <@basil860> writes:

Mark J Culross <mjculross@...> writes:

Basil (n7nix):
Thanks for your advice. I believe that I understand all of your
instructions & have executed them as directed, but APRS RX is still
not working.
In a console run this command:

tail -f /var/log/direwolf/direwolf.log

In another window run alsamixer for the udrc sound device
Increase the ADC level control until you see packets arriving in
direwolf.log

If you are NOT able to see packets in the direwolf log file then confirm
that BOTH your radio & DRAWS hat are using pin 5 (AF) of the mDin6 connector,
ie. 1200 baud receive.

To confirm the DRAWS hat config assuming you are using the left mDin6
connector run 'alsa-show.sh'. You should see:

IN1 L:[Off]
IN2 L:[10 kOhms]


I did find that I could make quicker modifications of the
connections/resistors using the DRAWS Manager selection for the desired
audio pin . . . does that have the same effect as the changes you
described & is it OK to use the DRAWS Manager to switch between
resistors connected to IN1_L & IN2_L ??
As long as you confirm changes with alsa-show.sh

As Corky suggested, I tested the receive path using fldigi (after
stopping AX25/direwolf) & BTW, I also had to manually install libjpeg
for fldigi to work,
libjpeg is installed on the image. If you ever run 'sudo apt autoremove'
it will be removed and you will have to reinstall it.

even though I am using the latest image (I found your reply with
instructions elsewhere on the forum). Using the waterfall display in
fldigi (with the radio still on 144.390), I did confirm that audio is
present on both pins (4/DISC & 5/AF) from the IC-7000 in VHF/FM
mode. Using either pin (4/5), I see the waterfall change whenever I
hear a packet on the radio & the waterfall goes completely blank as
expected when I select "OFF" for the left side DIN6 audio pin (udr0).
As I mentioned to Corky, I have not yet done anything with the
transmit path, other than cause a test position message to be sent to
verify PTT functionality. For now, I'm just concentrating on trying to
get RX of APRS to work, since I really thought that would be the easy
case !!
It should be easy. But each radio needs to be configured and the ALSA
settings need to match and that, I think, is where your problem lies.

You also might change your DAC Playback PT back to default.
DAC Playback PT L:[P3] R:[P3]

Make sure the radio receive preamp is turned off.
P.AMP/ATT button to left of screen

Mark J CulrossKD5RXT
On Sunday, September 13, 2020, 2:08:08 PM CDT, Basil Gunn <@basil860> wrote:


First thanks for all the console output.

The radio (IC-7000) is attached to the left side DIN6 connector
(udr0). I also ran the "setalsa-ic7000.sh" setup script.
This could be your problem since that script tries to set up deviation
for the HF radio. You need to set deviation for the VHF/UHF radio in the
IC-7000. I would turn off discriminator receiver routing and turn on
compensated audio. I am not sure if the IC-7000 radio supports
discriminator out for vhf.

This is what you currently have, set by the setalsa script.

IN1 L:[10 kOhm] R:[10 kOhm]
IN2 L:[Off] R:[Off]

You want to flip these controls for Left channel manually. ie. turn off
IN1 & have 10 kOhm for IN2.

Run alsamixer from a console
press F6, select sound card
- select udrc
scroll to the right until you find:
IN1_L to Left Mixer Positive Resistor [10 kOhm]
- turn that off by typing <down-arrow>

Continue scrolling to the right until you find:
IN2_L to Left Mixer Positive Resistor [10 kOhm]
- turn that ON by typing <up-arrow> once only

exit to save new settings

Be aware that there are both positive & negative resister controls ie.
IN1_L to Left Mixer Positive Resistor [Off]
IN1_L to Right Mixer Negative Resistor [Off]

You only want to set Left Mixer Positive Resistor control.

Verify by running alsa-show.sh

You need to confirm your deviation.

Go to this link
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

This will lead you through how to output a steady audio tone that you will
monitor with an HT or some other radio in your shack.
Be sure to read the John Ackermann N8UR link.

/Basil n7nix





Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.