Re: DRAWS - not able to receive APRS #aprs #direwolf #ax25


Mark J Culross
 

Corky (AF4PM):

Thanks for your most recent post.  I am in a training class all week so I won't be able to get back to tinkering with my DRAWS until this weekend, but I'll definitely try to duplicate your setup & I will also post my direwolf.conf contents.

Thanks again for your assistance !!

Mark J Culross
KD5RXT


On Monday, September 14, 2020, 10:27:25 PM CDT, Corky Searls <af4pm@...> wrote:


Mark, I hooked up the IC-7000 to the DRAWS today and tested the system for ax25 packet with Direwolf. I am using the radio on the right-hand miniDIN connector with the setalsa-ic7000.sh settings, which is the same setup that I use for HF. Other than getting the squelch set properly, I was able to decode both APRS traffic and ax25 packet. Since you are able to hear the APRS packets, I do not believe this is a squelch problem.

There are two differences in the alsa settings from yours below:
     1) The DAC playback is set to [P1] as the in the script, and
     2) the Receive IN2 R is set to [10 kOhm] instead of being off.

The radio is set for 1200 Baud data.

Can you attach a copy of /etc/direwolf.conf to make sure something is not amiss there?

Thanks and 73,
-Corky, AF4PM
On 9/13/20 4:25 PM, Mark J Culross wrote:
Basil (n7nix):

Thanks again for your reply.  I am definitely using alsa-show.sh to confirm the settings as I make changes, both with alsamixer as well as with the DRAWS Manager.



Here's the current capture from alsa-show.sh:

= = = = = = = = = = = = =   start snippet   = = = = = = = = = = = = =

root@drawsMJC:/home/pi# /home/pi/bin/alsa-show.sh
 ===== ALSA Controls for Radio Transmit =====
LO Driver Gain  L:[-6.00dB]    R:[-6.00dB]
PCM            L:[-26.50dB]    R:[-26.50dB]
DAC Playback PT    L:[P3]        R:[P3]
LO Playback CM    [Full Chip]

 ===== ALSA Controls for Radio Receive =====
ADC Level    L:[-2.00dB]    R:[-2.00dB]
IN1        L:[Off]        R:[Off]
IN2        L:[10 kOhm]    R:[Off]
CM        L:[10 kOhm]    R:[10 kOhm]

= = = = = = = = = = = = =    end snippet    = = = = = = = = = = = = =



As I mentioned to Corky in an earlier post, I open several terminals & have used "tail -f /var/log/direwolf/direwolf.log", "mheard", & "listen -a -h -i -p udr0 -r -t" (each in separate terminals) to try to detect any successful APRS receptions.



Here's the current capture from the direwolf.log:

= = = = = = = = = = = = =   start snippet   = = = = = = = = = = = = =

root@drawsMJC:/home/pi# !tail
tail -f /var/log/direwolf/direwolf.log
Sep 13 16:17:06 drawsMJC direwolf[526]: KISS protocol set TXtail = 10 (*10mS units = 100 mS), port 1
Sep 13 16:17:06 drawsMJC direwolf[526]: KISS protocol set Persistence = 32, port 1
Sep 13 16:17:06 drawsMJC direwolf[526]: KISS protocol set SlotTime = 20 (*10mS units = 200 mS), port 1
Sep 13 16:17:06 drawsMJC direwolf[526]: KISS protocol set FullDuplex = 0, port 1
Sep 13 16:17:11 drawsMJC direwolf[526]: Can't get address for IGate server noam.aprs2.net, Temporary failure in name resolution
Sep 13 16:17:16 drawsMJC direwolf[526]: Can't get address for IGate server noam.aprs2.net, Temporary failure in name resolution
Sep 13 16:17:21 drawsMJC direwolf[526]: Now connected to IGate server noam.aprs2.net (173.242.239.3)
Sep 13 16:17:21 drawsMJC direwolf[526]: Check server status here http://173.242.239.3:14501
Sep 13 16:17:26 drawsMJC direwolf[526]: [ig] # aprsc 2.1.8-gf8824e8
Sep 13 16:17:26 drawsMJC direwolf[526]: [ig] # logresp KD5RXT verified, server T2NALA

= = = = = = = = = = = = =    end snippet    = = = = = = = = = = = = =



The IC-7000 radio has "9600" mode turned off & the pre-amp is also turned off.  I am using the left side DIN6 on the DRAWS.

As you requested, I ran the "ADC Level" control across the entire range, from -12.00dB to +20.00dB (in 0.5dB steps), allowing two "packet sounds" per setting to see if anything was received.  When done, I left it back at the -2.00dB level (as you see in the alsa-show.sh report above).  Unfortunately, still no APRS RX at any level.

BYW, you nailed it on the "apt-get autoremove" causing libjpeg to be removed: GUILTY AS INDICATED !!

I just have to be missing something stupidly simple !!

Mark J Culross
KD5RXT


On Sunday, September 13, 2020, 4:55:40 PM CDT, Basil Gunn <basil@...> wrote:



Mark J Culross <mjculross@...> writes:

>  Basil (n7nix):
> Thanks for your advice. I believe that I understand all of your
> instructions & have executed them as directed, but APRS RX is still
> not working.

In a console run this command:

tail -f /var/log/direwolf/direwolf.log

In another window run alsamixer for the udrc sound device
Increase the ADC level control until you see packets arriving in
direwolf.log

If you are NOT able to see packets in the direwolf log file then confirm
that BOTH your radio & DRAWS hat are using pin 5 (AF) of the mDin6 connector,
ie. 1200 baud receive.

To confirm the DRAWS hat config assuming you are using the left mDin6
connector run 'alsa-show.sh'. You should see:

IN1 L:[Off]
IN2 L:[10 kOhms]


>I did find that I could make quicker modifications of the
>connections/resistors using the DRAWS Manager selection for the desired
>audio pin . . . does that have the same effect as the changes you
>described & is it OK to use the DRAWS Manager to switch between
>resistors connected to IN1_L & IN2_L ??

As long as you confirm changes with alsa-show.sh

> As Corky suggested, I tested the receive path using fldigi (after
> stopping AX25/direwolf) & BTW, I also had to manually install libjpeg
> for fldigi to work,

libjpeg is installed on the image. If you ever run 'sudo apt autoremove'
it will be removed and you will have to reinstall it.

> even though I am using the latest image (I found your reply with
> instructions elsewhere on the forum). Using the waterfall display in
> fldigi (with the radio still on 144.390), I did confirm that audio is
> present on both pins (4/DISC & 5/AF) from the IC-7000 in VHF/FM
> mode. Using either pin (4/5), I see the waterfall change whenever I
> hear a packet on the radio & the waterfall goes completely blank as
> expected when I select "OFF" for the left side DIN6 audio pin (udr0).

> As I mentioned to Corky, I have not yet done anything with the
> transmit path, other than cause a test position message to be sent to
> verify PTT functionality. For now, I'm just concentrating on trying to
> get RX of APRS to work, since I really thought that would be the easy
> case !!

It should be easy. But each radio needs to be configured and the ALSA
settings need to match and that, I think, is where your problem lies.

You also might change your DAC Playback PT back to default.
DAC Playback PT    L:[P3]        R:[P3]

Make sure the radio receive preamp is turned off.
P.AMP/ATT button to left of screen

> Mark J CulrossKD5RXT
>    On Sunday, September 13, 2020, 2:08:08 PM CDT, Basil Gunn <basil@...> wrote:
>
>
> First thanks for all the console output.
>
>> The radio (IC-7000) is attached to the left side DIN6 connector
>> (udr0). I also ran the "setalsa-ic7000.sh" setup script.
>
> This could be your problem since that script tries to set up deviation
> for the HF radio. You need to set deviation for the VHF/UHF radio in the
> IC-7000. I would turn off discriminator receiver routing and turn on
> compensated audio. I am not sure if the IC-7000 radio supports
> discriminator out for vhf.
>
> This is what you currently have, set by the setalsa script.
>
> IN1  L:[10 kOhm] R:[10 kOhm]
> IN2  L:[Off]  R:[Off]
>
> You want to flip these controls for Left channel manually. ie. turn off
> IN1 & have 10 kOhm for IN2.
>
> Run alsamixer from a console
> press F6, select sound card
>  - select udrc
> scroll to the right until you find:
> IN1_L to Left Mixer Positive Resistor [10 kOhm]
>  - turn that off by typing <down-arrow>
>
> Continue scrolling to the right until you find:
> IN2_L to Left Mixer Positive Resistor [10 kOhm]
>  - turn that ON by typing <up-arrow> once only
>
> exit to save new settings
>
> Be aware that there are both positive & negative resister controls ie.
>  IN1_L to Left Mixer Positive Resistor [Off]
>  IN1_L to Right Mixer Negative Resistor [Off]
>
> You only want to set Left Mixer Positive Resistor control.
>
> Verify by running alsa-show.sh
>
> You need to confirm your deviation.
>
> Go to this link
> https://github.com/nwdigitalradio/n7nix/tree/master/deviation
>
> This will lead you through how to output a steady audio tone that you will
> monitor with an HT or some other radio in your shack.
> Be sure to read the John Ackermann N8UR link.
>
> /Basil n7nix
>
>
>
>
>
>




Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.