Re: Can't access Draws Manager


Basil Gunn
 

It looks like you are not using an NWDR image?

nodejs comes installed on an NWDR image and is a version that works with
most things, ie. it's in the Debian repository. It looks like you
installed nodejs from source, is that true?

nodejs is already the newest version (15.4.0-1nodesource1)
Show me the version of nodejs & npm on your unit.

nodejs --version
npm --version

For example from the NWDR18 image

$ nodejs --version
v10.21.0
$ npm --version
6.14.9


Tim Huffaker <thuffaker@mindspring.com> writes:

Hi Basil,it looks like some dependency is missing see below.

=== Installing required PACKAGES
Reading package lists...
Building dependency tree...
Reading state information...
git is already the newest version (1:2.20.1-2+deb10u3).
nodejs is already the newest version (15.4.0-1nodesource1).

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nodejs : Conflicts: npm
npm : Depends: node-gyp (>= 3.6.2~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
Package install failed. Please try this command manually:
apt-get -y nodejs npm git
root@KM4ESU:/home/pi/n7nix/manager#

Tim
KM4ESU

Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.