Re: Pat ARDOP configure issues #pat #rigctld


KI5EVJ - Richard
 

Viola! Helps to used the correct cable. USB0 is there 😂😋
Thanks
Richard

On Jul 11, 2021, at 2:55 PM, Richard Gilbert via groups.io <rpgilbert1=verizon.net@groups.io> wrote:

/dev/tyyUSB* no such file or directory
On Jul 11, 2021, at 2:53 PM, RICHARD GILBERT <rpgilbert1@verizon.net> wrote:

I am using the 6-pin cable that came with the DRAWS plugged into the right socket on the hat and the data port on the 818.

Sent from my iPhone

On Jul 11, 2021, at 2:02 PM, Basil Gunn <basil@pacabunga.com> wrote:


Trying to set up Pat following the KM4ACK videos and descriptions
listed here
. ARDOP loads, rigctld gives the error below
port_open: serial_open status=-6
errno 6 is No such device or address

Pat http loads but says it can't get the frequency from rigctld.
Because rigctld is not running

I'm using a FT-818ND. Hardware id is 1041. There is no ttyUSB0 in the
/dev/ folder so I must have missed something somewhere.
Do this to see if the device is enumerated at some other USB number

ls /dev/ttyUSB*

Either you are using the wrong device name (ie. could be /dev/ttyUSB1)
OR you don't have the CAT cable for your FT-818ND plugged into the radio
or RPi.

If the above command comes back like this:
ls /dev/ttyUSB*
ls: cannot access '/dev/ttyUSB*': No such file or directory

then you don't have a CAT cable for your radio.

Yaesu USB FTDI CT-62 CAT Cable FT-818,
https://www.amazon.com/gp/product/B0035DV1ZM/ref=ask_ql_qh_dp_hza

pi@draws:~ $ rigctld -m 1041 -r /dev/ttyUSB0 -s 4800
rig_open: error = IO error
port_open: serial_open status=-6
iofunc.c(80):port_open return(-6)
rig.c(773):rig_open return(-6)







Join udrc@nw-digital-radio.groups.io to automatically receive all group messages.