Date   

Re: Dashboard won't start

 

It has nothing to do with IP address/provider.

On Tue, Jan 30, 2018 at 12:04 PM, John D. Hays <john@...> wrote:
This down in a loaded library -- probably the easiest attempt to fix it would be to simply remove the current install and install again which will load updated libraries.


On Tue, Jan 30, 2018 at 11:16 AM, Dave N2OA <kdcarlso@...> wrote:
I connected a new modem to my repeater using a new service provider, changed the IP and found that the dashboard no longer works.

When I try to run it I get the following.

/var/www-node/ircNodeDashboard $ sudo node webserver.js
/var/www-node/ircNodeDashboard/node_modules/touch/index.js:3
const EE = require('events').EventEmitter
^^^^^
SyntaxError: Use of const in strict mode.
    at Module._compile (module.js:439:25)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/var/www-node/ircNodeDashboard/webserver.js:1:178)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)

Does anyone have any ideas?

Thanks,

Dave
N2OA




--


John D. Hays
Edmonds, WA
K7VE

   




--


John D. Hays
Edmonds, WA
K7VE

   


Re: Dashboard won't start

 

This down in a loaded library -- probably the easiest attempt to fix it would be to simply remove the current install and install again which will load updated libraries.


On Tue, Jan 30, 2018 at 11:16 AM, Dave N2OA <kdcarlso@...> wrote:
I connected a new modem to my repeater using a new service provider, changed the IP and found that the dashboard no longer works.

When I try to run it I get the following.

/var/www-node/ircNodeDashboard $ sudo node webserver.js
/var/www-node/ircNodeDashboard/node_modules/touch/index.js:3
const EE = require('events').EventEmitter
^^^^^
SyntaxError: Use of const in strict mode.
    at Module._compile (module.js:439:25)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/var/www-node/ircNodeDashboard/webserver.js:1:178)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)

Does anyone have any ideas?

Thanks,

Dave
N2OA




--


John D. Hays
Edmonds, WA
K7VE

   


Dashboard won't start

Dave N2OA
 

I connected a new modem to my repeater using a new service provider, changed the IP and found that the dashboard no longer works.

When I try to run it I get the following.

/var/www-node/ircNodeDashboard $ sudo node webserver.js
/var/www-node/ircNodeDashboard/node_modules/touch/index.js:3
const EE = require('events').EventEmitter
^^^^^
SyntaxError: Use of const in strict mode.
    at Module._compile (module.js:439:25)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at Object.<anonymous> (/var/www-node/ircNodeDashboard/webserver.js:1:178)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)

Does anyone have any ideas?

Thanks,

Dave
N2OA


Re: DR!X AND UDRC2

Johnny
 

This is a little late, but I just wanted to put out this screenshot of what happens when the repeater drops TX. As you can see the last few lines of, (Current DC Offset). is when there is no TX, But still showing RX, and then, the next person keys up and most everytime it starts to work ok.
I havent had much luck with any other groups regarding this problem with dstarrepeater software.


Re: Alsamixer controls for receive audio UDRCII

Bernard f6bvp / ai7bg
 

Hi,

Exactly as it has been reported by TG9AOR on 16/01/2018 at 22:05 :

THANKS CORKY!! My issue is solved. The interesting part is that what solved the decode issue was running the script, which looks like the one in step 2 under BASIC CONFIGURATION from the UDRC Wiki page.
I found that from time to time when manipulating direwolf with different configuration files and different options, UDRC would eventually stop behaving as it should. For example, no more audio output.
In that case do not hesitate to run again basic configuration script set-udrc-din6.sh from N7NIX's GitHub Page
This will reset all alsamixer and UDRC default parameters including audio levels but I my case it always put back my UDRC in excellent working conditions ! You may then restore saved audio level parameters.

Bernard, f6bvp


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

Thank you, Bernard.

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

Bernard f6bvp / ai7bg
 

Hi,

I am using audacity in order to check proper wiring of din6 and HD15 UDRC-II interfaces with my radios set.

It does not actually provide supplementary information for optimal audio level setting necessary for receive or transmit.

73 de Bernard, f6bvp

Le 16/01/2018 à 22:08, TG9AOR a écrit :
And Thank you as well, Bernard F6BVP for your suggestion with audacity. I still would like to know what values to use as to know when the audio level is properly set, using audacity. So as to use this method with my next radio and UDRC combo.

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

And Thank you as well, Bernard F6BVP for your suggestion with audacity. I still would like to know what values to use as to know when the audio level is properly set, using audacity. So as to use this method with my next radio and UDRC combo.

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

THANKS CORKY!! My issue is solved. The interesting part is that what solved the decode issue was running the script, which looks like the one in step 2 under BASIC CONFIGURATION from the UDRC Wiki page.

To summarize what I did and how I got it solved:

I ran into N7NIX's GitHub Page as I wanted to measure deviation. After having done that I did read the Introduction and I felt it applied to me, as I wanted to run DireWolf only on this UDRC. So I went ahead and ran a freshly installed image on another SD Card(not the one I used for the original deviation excercise, which was before posting here). Under the assumption that the script would preset the pin levels I did not go to the UDRC Wiki Page. So I was running alsamixer with the stock settings, and therefore my ICOM only transmitted properly but did not decode anything it heard. I can  now see the decode in the DireWolf terminal.

Thank you very much, and Thank you John K7VE as well for your support.

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

Corky, thank you very much. I will get on this and let you know!

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

Corky Searls
 

Here are the settings I am using with the radio:

Direwolf.conf (Only the channel and basic setup portions)
ACHANNELS 2
CHANNEL 0
MYCALL xxxxx-1
MODEM 1200
PTT GPIO 12

CHANNEL 1
PTT GPIO 23
MODEM 1200
MYCALL xxxxx-2

AGWPORT 8000
KISSPORT 8001

Note: I have my system currently configured for 1200 baud communications on both channels. Channel 1 is the din-6 connector.

The IC-208H radio is configured as follows:
From the initial set mode:
BPS-96  (Set to 9600 baud comms, data on Pin 4 of the din-6)
MIC - H  (Mic sensitivity set to high)
ATT-ON (Squelch attenuator is on)
ACB-AL (All bands active)
NTX-ON (Enable narrow band TX, though I am not using narrow tx)
I am running with the a low level of squelch so that some level of signal is required to open the squelch. This way I do not have continuous noise in the shack.

Alsamixer settings for the UDRC-II
PCM 30<>29 [dB gain -5.00, -6.000]
ADC Level 10<>10
set to 0<>0 (AGC settings, HP Drive, LO Drive and PGA Level)
All others are off (I have ignored the MM and OO settings for now)
Please maker sure that you have run the following script to ensure that Alsamixer is set up properly for the UDRC-II. Without this you will get no audio from the board to the radio and hence no decode.
cd ~
curl -L -s https://goo.gl/7rXUFJ  > my-udrc-setup.sh
chmod +x my-udrc-setup.sh
~/my-udrc-setup.sh
Also, as I indicated previously if you have access to an oscilloscope, monitor the signal on pin 4 on the din-6 to make sure that you have audio signal coming from the radio to the board so that there is a signal for direwolf to decode.

I hope this helps you to get things running properly,
Thanks.
-Corky, AF4PM



On 1/15/2018 0:09 AM, TG9AOR wrote:
Thank you , Corky. I have used the n7nix script to generate both 1200 & 2200 tones and used Visual Analiser along with an rtl-sdr and have seen the signal come out. I was not able to set the bezel 0 and set the numbers in VA to get the peak to peak % fm deviation, the sine wave went out almost as a square wave. So I ended up using the Xastir Wiki method and got it as close to the 3khz deviation numbers, toggling the LO Drive and PCM numbers, and am able to decode its aprs transmissions with my ft1. It just does not decode anything it hears. SQL ATT is off and I left the squelch open as I recall in direwolf’s user guide. Narrow TX is off and it is not listening in narrow mode.

The cable in use is the one I ordered directly from NWDR. I thank you for your reply and will wait on your settings info.

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

Thank you , Corky. I have used the n7nix script to generate both 1200 & 2200 tones and used Visual Analiser along with an rtl-sdr and have seen the signal come out. I was not able to set the bezel 0 and set the numbers in VA to get the peak to peak % fm deviation, the sine wave went out almost as a square wave. So I ended up using the Xastir Wiki method and got it as close to the 3khz deviation numbers, toggling the LO Drive and PCM numbers, and am able to decode its aprs transmissions with my ft1. It just does not decode anything it hears. SQL ATT is off and I left the squelch open as I recall in direwolf’s user guide. Narrow TX is off and it is not listening in narrow mode.

The cable in use is the one I ordered directly from NWDR. I thank you for your reply and will wait on your settings info.

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

Corky Searls
 

Sorry for the problems. Yes you can just set the radio to 9600 baud and use it for both 1200 and 9600. The difference between the two setting is that the 9600 baud setting provides direct access to the discriminator with no preemphasis.

I am currently using the IC-208H with the UDRC-II and Direwolf as a Winlink Packet Node and all works quite well. Since you did not see anything on Audacity - which in stereo mode should have shown the signal - it sounds as though something may be wrong with the cable or the radio. At the very least if you open up the squelch you should be able to see the noise in the audio.

Do you have access to an oscilloscope to make sure that the radio is providing output on the mini din 6 output pins?  When I return home tomorrow I can check all of the settings on both the radio and the code to perhaps give you a closer starting point.

Thanks,
-Corky

On Jan 14, 2018, at 12:04 PM, TG9AOR <qrz@...> wrote:

Corky: So even if I plan to use it for 1200 Baud I set it to 9600 Baud? LO is almost at 0 and PCM some lower. I will try that as well. Din6 is assigned 1200 in direwolf.conf, but I guess it is a value I can switch between connectors.

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

Initially (at my beginning to calibrate deviation)the radio would not emit tone, until I unmuted LO DAC and LOR Outp, why woud it work with the Mini Din if it is on the left channel? I calibrated transmition deviation using LO Drive and PCM. So for decode it would need adjusments in ADC and HP Drive and LO Drive? these are the only items with values other than 0 under the capture menu in alsamixer.

John: Am I able to use 9600 baud with the mini din 6 cable I bought from NWDR? 

Bernard: I did install audacity but when I record and transmit an APRS packet with my handheld, the radio receives but there is nothing showing on the audacity record VU meter. What number or value am I looking for here?


Re: Alsamixer controls for receive audio UDRCII

 

Alsamixer - I don't own a 208 so don't know it's settings.

Usually with direwolf and the UDRC-II I use the 9600-baud pin in the radio (Page 73 of the 208H manual) -- As documented here https://nw-digital-radio.groups.io/g/udrc/wiki/UDRC%E2%84%A2-II-Cabling-For-2-radios  the Mini Din on the UDRC is Left channel and the HD-15 is right channel.


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

Yes, John, I count myself among the people with problems. I could not run it as a gateway radio for DSTAR and wanted to try APRS with it. When you mean left or right channel is this referring to direwolf.conf or alsamixer?

I will try it out while I get your reply.


73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

Corky: So even if I plan to use it for 1200 Baud I set it to 9600 Baud? LO is almost at 0 and PCM some lower. I will try that as well. Din6 is assigned 1200 in direwolf.conf, but I guess it is a value I can switch between connectors.

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

TG9AOR
 

Thanks Bernard. I did read your post a few days ago and I appreciate it. I will see if I am able to know the exact items that affect receive audio from the list in alsamixer, as you know there are some more items either MM(muted) or with Off value or with 10k value, and so I do not want to complicate it more than necessary. I will give the program a try(audacity). 

73 de TG9AOR


Re: Alsamixer controls for receive audio UDRCII

 

Some people have had problems with that model of radio.

Depending on 1200 vs 9600 baud it could be left or right channel. 

On Jan 14, 2018 10:28, "TG9AOR" <qrz@...> wrote:
Besides the information on  message #1261(ADC), what else may affect receive decode? I have this IC-208H and it will not decode APRS. It does send, I calibrated it via the wiki (n7nix/deviation/)


José Roberto Ruíz García Salas
TG9AOR



Re: Alsamixer controls for receive audio UDRCII

Corky Searls
 

I have found that the IC-208H works quite well. The two things to check are 1) make sure it is in 9k6 mode, 2) It seems to be sensitive to being overdriven and this will cause problems with the decode. You may need to set LO to 0 and back the PCM down significantly. F6BVP's suggestion of using Audacity to check the audio is a very good place to start.

-Corky, AF4PM

On Jan 14, 2018, at 8:28 AM, TG9AOR <qrz@...> wrote:

Besides the information on  message #1261(ADC), what else may affect receive decode? I have this IC-208H and it will not decode APRS. It does send, I calibrated it via the wiki (n7nix/deviation/)


José Roberto Ruíz García Salas
TG9AOR