Date   

Re: +12V polarity? #12vsupply

 

Yessir, that worked like a charm. Making a powerpole adapter as we type. I'm honored to learn from you more experienced folks.

David KE7RGP


Re: +12V polarity? #12vsupply

Budd Churchward
 

It’s a good thing that you caught that. You can take a small sharp pointed tool and press down on the tab that holds the wire into the plug and slide it out. Reverse the leads and push them back into the plug.
 
As you can see from the photo below, I have run into this problem before. Sometimes we have to watch out for what our friends in China send us.
 
jstProblems
 
Budd Churchward WB7FHC
 

Sent: Saturday, April 06, 2019 2:44 PM
Subject: Re: [udrc] +12V polarity? #12vsupply
 
Mr. Gary is correct according to Mr. Budd's continuity test. My pigtail leads are switched, yikes. Thanks all!

David, KE7RGP


Re: +12V polarity? #12vsupply

 

Mr. Gary is correct according to Mr. Budd's continuity test. My pigtail leads are switched, yikes. Thanks all!

David, KE7RGP


Re: +12V polarity? #12vsupply

 

Thanks, will do!


Re: +12V polarity? #12vsupply

Budd Churchward
 

A simple multi-meter will tell you everything you need to know. Set the meter up to show continuity. Mine beeps steady when I touch the two probes together. With a stand-alone board, not connected to anything, place one probe on top of one metal 6 pin mini DIN case. This is ground. Touch the other probe to either of the pins in the white JST power jack. If you hear a steady tone, that pin is ground. NOTE: you may hear a short beep when you touch the 12 Volt pin, but it will not keep sounding. That is normal.
 
Budd WB7FHC
 

Sent: Saturday, April 06, 2019 2:02 PM
Subject: Re: [udrc] +12V polarity? #12vsupply
 
Well, my pigtail black goes to square solder pad. Maybe wait to hear from the engineer before I plug in.


Re: +12V polarity? #12vsupply

 

Well, my pigtail black goes to square solder pad. Maybe wait to hear from the engineer before I plug in.


Re: +12V polarity? #12vsupply

Gary KC3PO
 

The PCB is actually marked.

If you look at the solder pads under the white power connector, you'll see that one is square (the one nearest the GPS). Square = positive.

- Gary  KC3PO


Re: +12V polarity? #12vsupply

 

Thanks so much!


Re: +12V polarity? #12vsupply

 

OK - then the red positive should work.  After that be sure to review https://nw-digital-radio.groups.io/g/udrc/wiki/DRAWS%3A-Image-getting-started


On Sat, Apr 6, 2019 at 1:40 PM Richard Waller via Groups.Io <rewaller=verizon.net@groups.io> wrote:
For what it’s worth, I just powered up my draws hat which is a relatively recent production ( I assume) because I received it last week. The Rpi received power from the hat and functioned normally. No smoke was released. I attached the 12 volt supply using the standard red black convention. Now the draws hat is a different matter altogether. Other than working as a buck converter , I couldn’t get it to do anything else. Rick Ka4ohm.
> On Apr 6, 2019, at 4:15 PM, Loring Kutchins <lor.kutchins@...> wrote:
>
> Now I’m concerned. I have not yet powered my DRAWS/Pi yet, and the post about “smoke” makes me want to wait until we get some clarification on the confusion. Labeling on the board obviously doesn’t exist. I bet there are a couple different board versions/batches, or plug+pigtails got assembled improperly. Please set us straight!
>
> —Lor W3QA
>
>






--


John D. Hays
Edmonds, WA
K7VE

   


Re: +12V polarity? #12vsupply

Richard Waller <rewaller@...>
 

For what it’s worth, I just powered up my draws hat which is a relatively recent production ( I assume) because I received it last week. The Rpi received power from the hat and functioned normally. No smoke was released. I attached the 12 volt supply using the standard red black convention. Now the draws hat is a different matter altogether. Other than working as a buck converter , I couldn’t get it to do anything else. Rick Ka4ohm.

On Apr 6, 2019, at 4:15 PM, Loring Kutchins <lor.kutchins@...> wrote:

Now I’m concerned. I have not yet powered my DRAWS/Pi yet, and the post about “smoke” makes me want to wait until we get some clarification on the confusion. Labeling on the board obviously doesn’t exist. I bet there are a couple different board versions/batches, or plug+pigtails got assembled improperly. Please set us straight!

—Lor W3QA


Re: +12V polarity? #12vsupply

 

I don't have one of the latest shipment of boards to physically examine, but red should be positive on the leads.  I have alerted the engineer to confirm, but perhaps someone else has already wired theirs' up and can confirm?


On Sat, Apr 6, 2019 at 1:29 PM Loring Kutchins <lor.kutchins@...> wrote:
Now I’m concerned. I have not yet powered my DRAWS/Pi yet, and the post about “smoke” makes me want to wait until we get some clarification on the confusion. Labeling on the board obviously doesn’t exist. I bet there are a couple different board versions/batches, or plug+pigtails got assembled improperly. Please set us straight!

—Lor W3QA




--


John D. Hays
Edmonds, WA
K7VE

   


Re: +12V polarity? #12vsupply

Loring Kutchins
 

Now I’m concerned. I have not yet powered my DRAWS/Pi yet, and the post about “smoke” makes me want to wait until we get some clarification on the confusion. Labeling on the board obviously doesn’t exist. I bet there are a couple different board versions/batches, or plug+pigtails got assembled improperly. Please set us straight!

—Lor W3QA


Re: Update DRAWS™ Manager #drawsmanager

 

There is no feedback when a systemctl command is successful.  However, you can run

sudo systemctl status draws-manager

Which will tell you if it is running.

DRAWS™ Manager is a web application.  From the Pi you would open a browser and go to

http://localhost:8080



On Sat, Apr 6, 2019 at 1:16 PM Richard Waller via Groups.Io <rewaller=verizon.net@groups.io> wrote:
When I go to /n7nix/ bin and type the command “sudo systemctl start draws-manager” nothing  happens. When I type “ sudo ./setalsa-ft817.sh” a bunch of settings flash by as in Johns video but I never see the draws- manager app. Also, when I go to fldigi with my ft817 connected to minidin (left) under soundcard audio settings I don’t see any options that would allow me to select the draws hat. Please advise. Rick. Ka4ohm 


On Apr 6, 2019, at 3:42 PM, Richard Waller via Groups.Io <rewaller@...> wrote:

John, when I entered the command as suggested under application help I got the message “ no such file or directory.” Rick. Ka4ohm 


On Apr 5, 2019, at 7:46 PM, John D Hays - K7VE <john@...> wrote:

New feature "Application Help" in DRAWS™ Manager

From command line

cd /usr/local/var/draws-manager
sudo git pull
sudo systemctl restart draws-manager

Or select "Update DRAWS™ Manager" button on left menu within DRAWS™ Manager

<Annotation 2019-04-05 164352.png>



--


John D. Hays
Edmonds, WA
K7VE

   


Re: Update DRAWS™ Manager #drawsmanager

 

Which command?  

Which beta are you using?

On Sat, Apr 6, 2019 at 12:42 PM Richard Waller via Groups.Io <rewaller=verizon.net@groups.io> wrote:
John, when I entered the command as suggested under application help I got the message “ no such file or directory.” Rick. Ka4ohm 


On Apr 5, 2019, at 7:46 PM, John D Hays - K7VE <john@...> wrote:

New feature "Application Help" in DRAWS™ Manager

From command line

cd /usr/local/var/draws-manager
sudo git pull
sudo systemctl restart draws-manager

Or select "Update DRAWS™ Manager" button on left menu within DRAWS™ Manager

<Annotation 2019-04-05 164352.png>



--


John D. Hays
Edmonds, WA
K7VE

   


Re: Update DRAWS™ Manager #drawsmanager

Richard Waller <rewaller@...>
 

When I go to /n7nix/ bin and type the command “sudo systemctl start draws-manager” nothing  happens. When I type “ sudo ./setalsa-ft817.sh” a bunch of settings flash by as in Johns video but I never see the draws- manager app. Also, when I go to fldigi with my ft817 connected to minidin (left) under soundcard audio settings I don’t see any options that would allow me to select the draws hat. Please advise. Rick. Ka4ohm 


On Apr 6, 2019, at 3:42 PM, Richard Waller via Groups.Io <rewaller@...> wrote:

John, when I entered the command as suggested under application help I got the message “ no such file or directory.” Rick. Ka4ohm 


On Apr 5, 2019, at 7:46 PM, John D Hays - K7VE <john@...> wrote:

New feature "Application Help" in DRAWS™ Manager

From command line

cd /usr/local/var/draws-manager
sudo git pull
sudo systemctl restart draws-manager

Or select "Update DRAWS™ Manager" button on left menu within DRAWS™ Manager

<Annotation 2019-04-05 164352.png>


Re: +12V polarity? #12vsupply

 

And to further confuse me, the red and black pigtail wires on the board in this video are opposite the board I received.

https://www.youtube.com/watch?v=8jzHA_cjuwM


Re: Basic Direwolf question #draws #direwolf #ax25

Dave N2OA
 

Thank you. I did a search on SSID so I missed the SID and thought it pulled it with the call.

Here is the results of beacmin.sh with debug turned on.

pi@n2oa-draws-1:~/n7nix/debug $ ./beacmin.sh
Read 1 lines of gps data
gpsdata: 43.01159
-78.189806667
lat: 43.01159
lon: -78.189806667
./beacmin.sh: line 52: 01159: value too great for base (error token is "01159")
axports: found line: udr0 N2OA-1 9600 255 2 Direwolf port
udr1 N2OA-10 9600 255 2 Winlink port
Found callsign: N2OA
Set callsign N2OA
 Sent: /usr/local/sbin/beacon -c N2OA-1 -d 'APUDR1 via WIDE1-1' -l -s udr0 !43.01159N/78.189806667Wp06 15:46:43 EDT, Seq: 21


Dave
N2OA


On Fri, Apr 5, 2019 at 5:36 PM Basil Gunn <basil@...> wrote:

Dave,
Thanks for trying out my script.
I will fix the errors you are seeing but I need some more info.
Could you please do the following:

# Go to the directory where beacmin.sh lives.

cd
cd n7nix/debug

# Using your favorite text editor change the following two lines near
#  the top of the file.

# 1. Get rid the hash symbol in front of DEBUG=1
#DEBUG=1

# 2. Change the SID number to what ever you want to use.
SID=15

Now run the the beacmin.sh script and copy & paste the console output to me in
an email.

Thanks, Dave.
/Basil


Dave N2OA <kdcarlso@...> writes:

> On Fri, Apr 5, 2019 at 12:09 PM, Basil Gunn wrote:
>
> Thanks for the answers and Basil for the scrips. I tried thebeacmin.sh script and it does beacon but I am not getting a location on my TH-D74 or FTM-400. I also notice that the SSID is always is always 15 even though my SSID in axports is set to -1.
>
> The message sent is Sent: /usr/local/sbin/beacon -d N2OA-15 -d 'APUDR1 via WIDE1-1' -l -s udr0 !43.01165833N/78.1899Wp05 16:19:08 EDT, Seq: 15
>
> I do get an error in line 52: 01165833: value too great for base (error token is "011658333")
>
> I also noticed int your example you show beacon -c and mine is showing -d and the decimal is 2 digits in for lat and long which I would expect but your example show 4 digits and then a decimal. Am I missing something?
>
> Thanks,
>
> Dave
> N2OA




Re: Update DRAWS™ Manager #drawsmanager

Richard Waller <rewaller@...>
 

John, when I entered the command as suggested under application help I got the message “ no such file or directory.” Rick. Ka4ohm 


On Apr 5, 2019, at 7:46 PM, John D Hays - K7VE <john@...> wrote:

New feature "Application Help" in DRAWS™ Manager

From command line

cd /usr/local/var/draws-manager
sudo git pull
sudo systemctl restart draws-manager

Or select "Update DRAWS™ Manager" button on left menu within DRAWS™ Manager

<Annotation 2019-04-05 164352.png>


+12V polarity? #12vsupply

 

Trying to get up and running with my new DRAWS hat. A DRAWS brochure from 9/18, http://nwdigitalradio.com/wp-content/uploads/2018/09/DRAWSBrochure.pdf , labels the 12V plug, looking down onto the board, with + on the left, going into the round solder pad. - on the right, going into the square solder pad. A DRAWS Brochure from 11/18, http://nwdigitalradio.com/wp-content/uploads/2018/09/DRAWSBrochure-1.pdf ,  on the current website, labels the polarity as opposite. On the draws board I received a couple days ago, the red lead on the power pigtail is on the left, going to the round solder pad, black is on the right going to the square solder pad. There is also a caution under one of the #power threads to mind the polarity of the pigtail, https://nw-digital-radio.groups.io/g/udrc/message/2227 . Which solder pad is +? the round on the left or the square on the right? My pigtail with the red lead going to the round solder pad matches the older brochure, assuming red leads are + like on powerpoles.

TIA
David


Re: DRAWS™ and YAESU FTM-100 for analog and digital modes

John Spoonhower
 

Bernard,
I am curious about what are the audio level settings for this radio. Can you please post the results of "alsa-show.sh"?
73,
John,
NX2I

On Sat, Apr 6, 2019 at 12:15 PM f6bvp <f6bvp@...> wrote:
Hi,

I just want to report the successful use of
Data Cable, 10-pin mini-DIN to 6-pin mini-DIN, for FTM-400DR/FTM-100DR,
from https://www.dxengineering.com/parts/ysu-ct-164
This lets you use DRAWS hat modem and Direwolf for AX.25 packet
applications.

FTM-100DE is an interesting mobile VHF/UHF FM rig that I am using at
home for 1200/9600 bauds AX.25 APRS application.
As a transition device it has both "analog" and new digital C4FM modes.
Data plug is a 10 pin mini DIN while UDRC II and DRAWS have mini DIN 6
plugs. This is the reason I had to use a compatible data cable.

Bernard, f6bvp
https://radiotelescopelavillette.wordpress.com/photos/stars-song-le-chant-des-etoiles/