Date   

Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

Jonathan Magee
 

Hi
I just wanted to let the group know that I have made good progress. I started from scratch with a clean buster image and using my Pi3B (to rule out any issues specific to my PI4). With just the out of the box image I added in the lines
dtoverlay=draws,alsaname=udrc
force_turbo=1  
to config.txt and rebooted.

With just those lines the the DRAWS sound card was not detected. I then added in the line dtdebug=1 at the start of config.txt, rebooted and looked at the debug output. I saw that it was trying to load the device tree for HAT but it failed with the error
dterror: can't find symbol 'cprman'
and then it unloaded HAT

I then added in the line 
dtoverlay= 
to the start of my config.txt and rebooted. This time the sound card was detected. I then tried the sd card in my Pi4 and the DRAWS sound card was detected ok.  
I still have to set up the rest of the software but I am now heading in the right direction. 

It looks like the automatic loading of the drive tree based on the data in the DRAWS eeprom was failing and that had a knock on effect that stopped the  line dtovwerlay=draws,alsaname=udrc from working.
I also had a look at the config.txt on the image I am actively using with DRAWS for wsjtx and I notice that it also has the line
dtoverlay= 
in it. 

73 de Jonathan GI7KMC 


On Fri, 30 Aug 2019 at 04:47, John D Hays - K7VE <john@...> wrote:
And make sure the lines are added at the end of /boot/config.txt in that order.


dtoverlay=draws,alsaname=udrc
force_turbo=1


On Thu, Aug 29, 2019 at 7:36 AM Basil Gunn <basil@...> wrote:

Mitch Winkle <ab4mw@...> writes:

> Second that notion. There is a lot of what I consider unwanted fluff
> in this image since I don't care about packet radio. I would really
> like to have a clean image with only the necessary drivers and such and
> then I could install my own programs, and select the HF programs that I
> want to use. So perhaps a "minimal" image that gets the DRAWS
> functioning properly on the RPi??

Use the latest Raspbian image that supports Debian buster and add these
lines in /boot/config.txt

dtoverlay=draws,alsaname=udrc
force_turbo=1

/Basil n7nix





--
John D. Hays
Kingston, WA
K7VE

 


Re: no transmit #wsjt-x

Rob Lapham
 

just did a rest on the radio and still no transmit powers and also don't see how it can be the radio if it works with other soundcards.
just tried the setalsa-ft817.sh command again no joy I have also tried a new memory card and started over I have been at this for
about two months now. I have also tried the draws manager and turned the gain up to max and no transmit.

starting to think I made mistake buying this

rob k6jus



 


Re: no transmit #wsjt-x

 

The FT-817 is probably the most tested for the DRAWS™ HAT.

Are you using the left DIN-6 port and selecting the same in your program?

There is a possibility that one of the flags in the CODEC was set incorrectly, at some point.  Try using n7nix/bin/setalsa-ft817.sh  

Occasionally, we have seen the FT-817 where a parameter is changed from default, sometimes doing a full reset on the radio gets it to a working mode.



On Thu, Aug 29, 2019 at 9:14 AM Rob Lapham <ke6jus@...> wrote:
It’s a ft-817nd



--
John D. Hays
Kingston, WA
K7VE

 


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

 

And make sure the lines are added at the end of /boot/config.txt in that order.


dtoverlay=draws,alsaname=udrc
force_turbo=1


On Thu, Aug 29, 2019 at 7:36 AM Basil Gunn <basil@...> wrote:

Mitch Winkle <ab4mw@...> writes:

> Second that notion. There is a lot of what I consider unwanted fluff
> in this image since I don't care about packet radio. I would really
> like to have a clean image with only the necessary drivers and such and
> then I could install my own programs, and select the HF programs that I
> want to use. So perhaps a "minimal" image that gets the DRAWS
> functioning properly on the RPi??

Use the latest Raspbian image that supports Debian buster and add these
lines in /boot/config.txt

dtoverlay=draws,alsaname=udrc
force_turbo=1

/Basil n7nix





--
John D. Hays
Kingston, WA
K7VE

 


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

Frank Ivan
 

Hi Basil,

Sorry to have wasted your time.

73 - Frank - K0FEI


Re: no transmit #wsjt-x

Rob Lapham
 

yes over and over went home to day and rechecked the radio settings. I would think if the radio work in receive and with a signal link the radio
settings should be right. last night had the drive turned all the way up and would not drive the radio just keys and no power. keep going over the 
settings and instruction's. 
Rob k6jus


Re: Eureka!!!! She works perfectly!!

Michael Narges
 

Thanks for the documentation of the DRAWS Hat! Several questions are answered here.  

Thanks, 

Mike WF8O 


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

Basil Gunn
 

Just adding the lines to /boot/config.txt didn't get the tlv modules
to load and I could not see the sound card. If I put those lines
before the drtparam=audio=-on then aplay -l said there is no sound
card found.
Provide the output of showudrc.sh describing what you did doesn't work
for me.

lsmod | grep -i tlv320*

snd_soc_tlv320aic32x4_i2c 16384 27
snd_soc_tlv320aic32x4 40960 1 snd_soc_tlv320aic32x4_i2c
snd_soc_core 192512 5 vc4,snd_soc_simple_card_utils,snd_soc_bcm2835_i2s,snd_soc_tlv320aic32x4,snd_soc_simple_card
snd_pcm 102400 8 vc4,snd_pcm_dmaengine,snd_soc_bcm2835_i2s,snd_soc_tlv320aic32x4,snd_bcm2835,snd_soc_core
snd 73728 14 snd_compress,snd_timer,snd_soc_tlv320aic32x4,snd_bcm2835,snd_soc_core,snd_pcm

This works with the latest version of Raspbian which uses this Linux
kernel

uname -r
4.19.57-v7l+

If you do not see the udrc driver enumerated:

aplay -l | grep udrc

card 1: udrc [udrc], device 0: bcm2835-i2s-tlv320aic32x4-hifi
tlv320aic32x4-hifi-0 []

then you are not using the latest Raspbian image it's that simple.

Also Beta image 13 works as long as you do NOT do an upgrade.

It would not be to blow it off until after some hamfest more than a
month down the way.
It's 2 weeks a way, thanks for your concern.

/Basil


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

Frank Ivan
 

I'm sorry Jonathan,

You did show the showudrc and it shows some of the modules, and the /boot/config.txt.

If could show all the modules the sudo lsmod and the /etc/modules file that would be interesting.

Thanks - Frank - K0FEI


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

Frank Ivan
 

Hi Basil,

Just adding the lines to /boot/config.txt didn't get the tlv modules to load and I could not see the sound card. If I put those lines before the drtparam=audio=-on then aplay -l said there is no sound card found.

In the Stretch version there is a module udrc loaded.  What does that do and do we still need it?

I am presenting my 3d printed case for the draws hat on a Pi4 at the Tech Connect 285 club the first Saturday in September and would like to tell everyone how great the product is.  We have a lot of SOTA folks (Colorado is SOTA heaven) and the draws hat is one of the smallest interfaces available.  The following Saturday we will be having our annual picnic on a SOTA peak and showing off equipment.

The long and short of it is you have a show stopping problem and it would appear you can not duplicate it.  I am not the only one who is having the problem.  I know what I would do if it were my product.  It would not be to blow it off until after some hamfest more than a month down the way.

Frank - K0FEI
 


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

Frank Ivan
 

Hi Jonathan,

Could you look at a couple of things and tell me what you are seeing.

1. Could you enter sudo lsmod.  That should display a list of kernel modules loaded.
2. Could you cat /boot/config.txt to type out the config.txt file.
3. Could you enter the nx7nix/bin/showudrc.sh.  Its a lot of stuff but it tells pretty much the story.
4. Finally could you cat /etc/modules and get a list of kernel modules that are being loaded.

Thanks
Frank - K0FEI


Re: no transmit #wsjt-x

Basil Gunn
 

Have you read this to set up a "USER" defined digital mode on your
radio?

https://github.com/nwdigitalradio/n7nix/blob/master/docs/RADIO_APP_NOTES.md

/Basil n7nix


Re: no transmit #wsjt-x

Rob Lapham
 

It’s a ft-817nd


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

Jonathan Visser
 

Frank, 

I am using the card with the GPS antenna on what I would consider the back.  The GPS antenna antenna is on the same side as the power. 

Thanks, 
Jonathan

On Aug 29, 2019, at 10:40 AM, Frank Ivan via Groups.Io <k0fei@...> wrote:

Hi Jonathan,

Are you using the hat with the gps antenna on the side with the sockets or on the back of the card?

Thanks
Frank - K0FEI


Re: Eureka!!!! She works perfectly!!

 


On Thu, Aug 29, 2019 at 8:55 AM Michael Narges <mnarges23@...> wrote:
I read several posts here about the need to remove pin six.  John Hays and Bryan Hoyer particularly seemed to have solid reasons, and I merely took their helpful advice.  The Draws Hat is essentially a “black box” since there are no schematics published. However nothing succeeds like success!  Hope this trick works for you!

73. Mike Wf8o 



--
John D. Hays
Kingston, WA
K7VE

 


Re: Eureka!!!! She works perfectly!!

Michael Narges
 

I read several posts here about the need to remove pin six.  John Hays and Bryan Hoyer particularly seemed to have solid reasons, and I merely took their helpful advice.  The Draws Hat is essentially a “black box” since there are no schematics published. However nothing succeeds like success!  Hope this trick works for you!

73. Mike Wf8o 


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

 

Stretch is the best path for Pi 3 and Pi 2.  If you have a Pi 4, you will need to use Buster and the edit that Basil lists.

Now that the DRAWS™ support is directly in the Buster kernel, it is configuration to activate it.

We may put out some images specific to some application groupings on top of Buster with DRAWS™, but they will start on top of Buster.

Pi 4 is still leading edge at this point.

On Thu, Aug 29, 2019 at 7:36 AM Basil Gunn <basil@...> wrote:

Mitch Winkle <ab4mw@...> writes:

> Second that notion. There is a lot of what I consider unwanted fluff
> in this image since I don't care about packet radio. I would really
> like to have a clean image with only the necessary drivers and such and
> then I could install my own programs, and select the HF programs that I
> want to use. So perhaps a "minimal" image that gets the DRAWS
> functioning properly on the RPi??

Use the latest Raspbian image that supports Debian buster and add these
lines in /boot/config.txt

dtoverlay=draws,alsaname=udrc
force_turbo=1

/Basil n7nix





--
John D. Hays
Kingston, WA
K7VE

 


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

 

I have had both recognized with the Buster version.

On Thu, Aug 29, 2019 at 8:41 AM Frank Ivan via Groups.Io <k0fei=me.com@groups.io> wrote:
Hi Jonathan,

Are you using the hat with the gps antenna on the side with the sockets or on the back of the card?

Thanks
Frank - K0FEI
_._,_._,_

--
John D. Hays
Kingston, WA
K7VE

 


Re: Using the DRAWS hat with a Raspberry Pi 4 #yaac #replacecompass #draws #install #js8call

Frank Ivan
 

Hi Jonathan,

Are you using the hat with the gps antenna on the side with the sockets or on the back of the card?

Thanks
Frank - K0FEI


Re: no transmit #wsjt-x

Mitch Winkle
 

FT-450D

On 8/29/19 9:39 AM, John D Hays - K7VE wrote:
What radio model are you trying to drive?

On Thu, Aug 29, 2019, 04:34 Mitch Winkle <ab4mw@...> wrote:

sounds very much like my issue, only I have badly distored audio to the transmitter.  mine is in a box ready to be mailed back for eval.

On 8/28/19 10:08 PM, Rob Lapham wrote:
I did use Johns web app and it came up with the same values as the draws manager. I have turned  the gain up all the way and no clean tone.
the radio works fine with my other rp4 and a signal link so I think the radio is ok. also install another cable still no clean audio.
I lost
Rob k6jus