Date   

Re: Setting Up AARDOP with the #draws

Basil Gunn
 

Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> writes:

As a followup to setting up PAT with the DRAWS....

Is the ARDOP install that comes with teh DRAWS Compass package
"installed" and available to PAT once PAT is installed?
DRAWS Compass refers to the current and now deprecated image.
That image does not have piardopc installed.
The next image most likely will since I am working with paclink-unix &
ardop on the RPi.

I ask because I see ARDOP available in the drop down of PAT.

If not, what does it take to active the ARDOP install in Compass so PAT
would see it without installing it again (using K4KDR instructional
video, for example)?
John Wiseman's documentation is excellent and I had no problems getting
it to work with UDRC or DRAWS on an RPi.

http://www.cantab.net/users/john.wiseman/Documents/ARDOPC.html

Below are my brief notes for using an UDRC II. The only thing to be
aware of for the DRAWS hat is the gpio setting for left or right mDin6
connector.

Command line used to start piardopc

./piardopc 8515 plughw:1,0 plughw:1,0 -p GPIO=23

Added this to .asoundrc
ref: ARDOPC.txt

pcm.ARDOP {
type rate
slave {
pcm "hw:1,0"
rate 12000
}
}

/Basil


Re: Setting Up AARDOP with the #draws

Ed Bloom, KD9FRQ
 

AH...........Yes, KM4ACK.............
 
Coffee had not kicked in yet....................
 
Ed Bloom, KD9FRQ
ewbloom@...
Sent from Webmail access
 
 

-----Original Message-----
From: K4KDR <scott23192@...>
To: udrc <udrc@nw-digital-radio.groups.io>
Sent: Mon, Sep 16, 2019 8:44 am
Subject: Re: [draws and udrc] Setting Up AARDOP with the #DRAWS

Hey Ed!

I believe you're referring to the excellent YouTube videos from KM4ACK.

I can't speak to what might have already been installed on the DRAWS Compass
image in regard to ARDOP... all I did was follow the steps in the KM4ACK
videos for both ax25 & ARDOP and both methods are working perfectly for me.
(I am also using the DRAWS SD Card image but followed the KM4ACK steps to
get those 2 PAT protocols configured & working)

-Scott,  K4KDR

=============================

-----Original Message-----
From: Ed Bloom, KD9FRQ via Groups.Io
Sent: Monday, September 16, 2019 7:20 AM
Subject: [draws and udrc] Setting Up AARDOP with the #DRAWS

As a followup to setting up PAT with the DRAWS....

Is the ARDOP install that comes with teh DRAWS Compass package
"installed" and available to PAT once PAT is installed?

I ask because I see ARDOP available in the drop down of PAT.

If not, what does it take to active the ARDOP install in Compass so PAT
would see it without installing it again (using K4KDR instructional
video, for example)?

Respectfully,

Ed, KD9FRQ





Re: Setting Up AARDOP with the #draws

K4KDR
 

Hey Ed!

I believe you're referring to the excellent YouTube videos from KM4ACK.

I can't speak to what might have already been installed on the DRAWS Compass image in regard to ARDOP... all I did was follow the steps in the KM4ACK videos for both ax25 & ARDOP and both methods are working perfectly for me. (I am also using the DRAWS SD Card image but followed the KM4ACK steps to get those 2 PAT protocols configured & working)

-Scott, K4KDR

=============================

-----Original Message-----
From: Ed Bloom, KD9FRQ via Groups.Io
Sent: Monday, September 16, 2019 7:20 AM
To: udrc@nw-digital-radio.groups.io
Subject: [draws and udrc] Setting Up AARDOP with the #DRAWS

As a followup to setting up PAT with the DRAWS....

Is the ARDOP install that comes with teh DRAWS Compass package
"installed" and available to PAT once PAT is installed?

I ask because I see ARDOP available in the drop down of PAT.

If not, what does it take to active the ARDOP install in Compass so PAT
would see it without installing it again (using K4KDR instructional
video, for example)?

Respectfully,

Ed, KD9FRQ


Setting Up AARDOP with the #draws

Ed Bloom, KD9FRQ
 

As a followup to setting up PAT with the DRAWS....

Is the ARDOP install that comes with teh DRAWS Compass package "installed" and available to PAT once PAT is installed?

I ask because I see ARDOP available in the drop down of PAT.

If not, what does it take to active the ARDOP install in Compass so PAT would see it without installing it again (using K4KDR instructional video, for example)?

Respectfully,

Ed, KD9FRQ


Re: DRAWS™ Latest Board Run Defect (Standby) #recall #draws

Edouard Lafargue
 

  Thanks for the update!

  Could this explain why my recent DRAWs board (2 weeks old) doesn't work at all with the default TM-V71A alsa settings that ship with your image ? I mean the `setalsa-tmv71a.sh` script. I had to create a very different set of settings in order to get other stations to demodulate my AFSK-1200 properly...

Ed


On Sun, Sep 15, 2019 at 12:30 PM John D Hays - K7VE <john@...> wrote:

We have discovered that a capacitor was installed in the audio filter chain that can prevent certain applications from functioning properly.

We apologize that this was not detected before the boards were shipped.

In the next few days we will publish instructions for those who would like to do a field repair.

At the same time we will provide instructions on how to have NW Digital Radio perform the repair.

Please do not return your boards before instructions are provided.


--


John D. Hays
Director

  


DRAWS™ Latest Board Run Defect (Standby) #recall #draws

 


We have discovered that a capacitor was installed in the audio filter chain that can prevent certain applications from functioning properly.

We apologize that this was not detected before the boards were shipped.

In the next few days we will publish instructions for those who would like to do a field repair.

At the same time we will provide instructions on how to have NW Digital Radio perform the repair.

Please do not return your boards before instructions are provided.


--


John D. Hays
Director

  


Re: Setting Up PAT with the #draws

 


On Sat, Sep 14, 2019 at 5:20 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:


My next thing to learn is how to create a desktop icon to run pat http.?? 

--
John D. Hays
Kingston, WA
K7VE

 


Re: Setting Up #PAT with the #draws #pat

Ed Bloom, KD9FRQ
 

John,

Ah!!!?? Good to know.?? I will shut it down.

Thank you.

Regards, Ed

On 9/14/2019 7:19 PM, John D Hays - K7VE wrote:
DRAWS??? Manager does not need to run all of the time.?? It is a setup tool, then you can shut it down.??

sudo systemctl stop draws-manager

and to prevent it starting??up on next??reboot

sudo systemctl disable draws-manager

Or you can move it to a different port, as documented here

# If you want to set the port, edit /etc/default/draws-manager and add a line with the port number, e.g. PORT=80 (it defaults to 8080)??

And restart.
??
sudo systemctl restart draws-manager

On Sat, Sep 14, 2019 at 4:41 PM K4KDR <scott23192@...> wrote:
Hi Ed!

There are two issues to take care of here.?? As was mentioned, 0.0.0.0 is not the address for you to use.?? When you are accessing a web page on the same machine you are using, the "loopback" or "localhost" address is 127.0.0.1

The other thing to take care of is that it's necessary to change the default port used by PAT since, as you mentioned, 8080 is used by the DRAWS Manager.

So, as you might have already done to setup your call sign in PAT,?? type "pat configure" from a command prompt.?? Scroll down a few lines and change the port to something other than "8080".?? Here is what that line looks like in my setup, for example:

"http_addr": "localhost:8888",

... so, if you use 8888, the URL to type into your browser (after typing "pat http" in a terminal window) would be:


And you'll be all set!

-Scott,?? K4KDR

=====================

On Sat, Sep 14, 2019 at 4:16 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ



--
John D. Hays
Kingston, WA
K7VE

??


Re: Setting Up PAT with the #draws

Ed Bloom, KD9FRQ
 

Basil,

Thank you. I do not know enough about networking to know I could actually do that.

Regards, Ed

On 9/14/2019 4:56 PM, Basil Gunn wrote:
Ed,

IP address 0.0.0.0 is a "special IP address" for defining an unknown or
invalid target OR all IPV4 addresses on all interfaces on the local
machine.

Why don't you use some non-routable address from 192.168.0.0 address
space, ie. 192.168.1.1

/Basil n7nix

Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> writes:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already
in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager
web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config
(address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming
exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta
13. I've made a video tutorial, but need to edit before posting. It
will release on my YouTube channel <https://www.youtube.com/km4ack>
Tuesday Aug 27 at 1600 central.


Re: Setting Up PAT with the #draws

Ed Bloom, KD9FRQ
 

Scott,

Thank you. That is what I was going to do next. But was not 100% sure. So I stopped and asked the question.

Networking is not my IT strong suit. I am an application programmer generally speaking.

My next thing to learn is how to create a desktop icon to run pat http.?? I also need to double check the ARDOP install.?? It is included in the DRAWS package but I an not sure if it is fully setup and available to PAT.

I will need to watch your video again to look at the connections to radio. I will using an FT-897.

73s, Ed, KD9FRQ

On 9/14/2019 6:41 PM, K4KDR wrote:
Hi Ed!

There are two issues to take care of here.?? As was mentioned, 0.0.0.0 is not the address for you to use.?? When you are accessing a web page on the same machine you are using, the "loopback" or "localhost" address is 127.0.0.1

The other thing to take care of is that it's necessary to change the default port used by PAT since, as you mentioned, 8080 is used by the DRAWS Manager.

So, as you might have already done to setup your call sign in PAT,?? type "pat configure" from a command prompt.?? Scroll down a few lines and change the port to something other than "8080".?? Here is what that line looks like in my setup, for example:

"http_addr": "localhost:8888",

... so, if you use 8888, the URL to type into your browser (after typing "pat http" in a terminal window) would be:


And you'll be all set!

-Scott,?? K4KDR

=====================

On Sat, Sep 14, 2019 at 4:16 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta 13. I've made a video tutorial, but need to edit before posting. It will release on my YouTube channel Tuesday Aug 27 at 1600 central.

73,
KM4ACK
Find me on YouTube


Re: Setting Up #PAT with the #draws #pat

 

DRAWS™ Manager does not need to run all of the time.  It is a setup tool, then you can shut it down. 

sudo systemctl stop draws-manager

and to prevent it starting up on next reboot

sudo systemctl disable draws-manager

Or you can move it to a different port, as documented here

# If you want to set the port, edit /etc/default/draws-manager and add a line with the port number, e.g. PORT=80 (it defaults to 8080) 

And restart.
 
sudo systemctl restart draws-manager

On Sat, Sep 14, 2019 at 4:41 PM K4KDR <scott23192@...> wrote:
Hi Ed!

There are two issues to take care of here.  As was mentioned, 0.0.0.0 is not the address for you to use.  When you are accessing a web page on the same machine you are using, the "loopback" or "localhost" address is 127.0.0.1

The other thing to take care of is that it's necessary to change the default port used by PAT since, as you mentioned, 8080 is used by the DRAWS Manager.

So, as you might have already done to setup your call sign in PAT,  type "pat configure" from a command prompt.  Scroll down a few lines and change the port to something other than "8080".  Here is what that line looks like in my setup, for example:

"http_addr": "localhost:8888",

... so, if you use 8888, the URL to type into your browser (after typing "pat http" in a terminal window) would be:


And you'll be all set!

-Scott,  K4KDR

=====================

On Sat, Sep 14, 2019 at 4:16 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ



--
John D. Hays
Kingston, WA
K7VE

 


Re: Setting Up PAT with the #draws

K4KDR
 

Hi Ed!

There are two issues to take care of here.  As was mentioned, 0.0.0.0 is not the address for you to use.  When you are accessing a web page on the same machine you are using, the "loopback" or "localhost" address is 127.0.0.1

The other thing to take care of is that it's necessary to change the default port used by PAT since, as you mentioned, 8080 is used by the DRAWS Manager.

So, as you might have already done to setup your call sign in PAT,  type "pat configure" from a command prompt.  Scroll down a few lines and change the port to something other than "8080".  Here is what that line looks like in my setup, for example:

"http_addr": "localhost:8888",

... so, if you use 8888, the URL to type into your browser (after typing "pat http" in a terminal window) would be:


And you'll be all set!

-Scott,  K4KDR

=====================


On Sat, Sep 14, 2019 at 4:16 PM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta 13. I've made a video tutorial, but need to edit before posting. It will release on my YouTube channel Tuesday Aug 27 at 1600 central.

73,
KM4ACK
Find me on YouTube


Re: Setting Up PAT with the #draws

Basil Gunn
 

Ed,

IP address 0.0.0.0 is a "special IP address" for defining an unknown or
invalid target OR all IPV4 addresses on all interfaces on the local
machine.

Why don't you use some non-routable address from 192.168.0.0 address
space, ie. 192.168.1.1

/Basil n7nix

Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> writes:

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already
in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager
web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config
(address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming
exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta
13. I've made a video tutorial, but need to edit before posting. It
will release on my YouTube channel <https://www.youtube.com/km4ack>
Tuesday Aug 27 at 1600 central.


Setting Up PAT with the #draws

Ed Bloom, KD9FRQ
 

KM4ACK,

Do you have any suggestions on the IP Address for PAT with the DRAWS.

When I enter 0.0.0.0 I get an error when starting PAT (address already in use).

When I enter 0.0.0.0:8080 in the browser, I am given the DRAWS Manager web interface page when 0.0.0.0 is used in the config.

The same results are received when I use localhost in the config (address already in use and same web page).

I am connected directly to the Pi as I would be in the field (upcoming exercise).

Respectively,

Ed, KD9FRQ

On 8/25/2019 7:04 AM, km4ack wrote:
I have ARDOP setup and running with Pat on the DRAWS hat using beta 13. I've made a video tutorial, but need to edit before posting. It will release on my YouTube channel Tuesday Aug 27 at 1600 central.

73,
KM4ACK
Find me on YouTube


Re: DRAWS and Allstar?

 

DRAWS™ CODEC is available under ALSA (and pulseaudio), anyone who wants to try this should look at chan_alsa and app_rpt 

Can app_rpt do PTT and SQUELCH DETECT using Raspberry Pi GPIO pins?

On Tue, Jun 4, 2019 at 9:25 AM Steve KC1AWV <smiller@...> wrote:
So, I've given this some more thought. you could probably do this through chan_alsa, chan_oss, or chan_usrp depending on how DRAWS configures its sound card.

Easiest would be GNU Radio USRP, the set up would be similar to that as DVSwitch.

On Tue, Jun 4, 2019 at 12:17 PM Christopher AI6KG <ch@...> wrote:
The issue I see is not with the Allstar distribution, but rather getting DRAWS to show up as a compatible device for app_rpt.

Agreed.  This is essentially what I was asking.

-ch
73 de AI6KG


--
John D. Hays
Kingston, WA
K7VE

 


Re: Eureka!!!! She works perfectly!!

Chris Brown <tcbrown68@...>
 

I have had success sending and receiving on the 891 without removing pin 6.


Re: minimum install to get the DRAWS gps working?

Jonathan Magee
 

Hi Tom,
I have the gps working and I don't have the battery installed

Regards
Jonathan GI7KMC

On Sun, 8 Sep 2019 at 19:55, Tom Early <n7tae@...> wrote:
Silly me. I thought I only needed to install the CR1220 if I wanted the RTC to continue to operate while the power was off. Apparently, the battery has to be installed for the GPS to operate. The GPS sensitivity seems really good. The DRAWS pulled in 10 satellites within a minute of powering up and had my position and altitude exactly right. In the same location, my ID-51p2 takes significantly longer.


Re: minimum install to get the DRAWS gps working?

 

Silly me. I thought I only needed to install the CR1220 if I wanted the RTC to continue to operate while the power was off. Apparently, the battery has to be installed for the GPS to operate. The GPS sensitivity seems really good. The DRAWS pulled in 10 satellites within a minute of powering up and had my position and altitude exactly right. In the same location, my ID-51p2 takes significantly longer.


Re: #DRAWS PAT via DRAWS #draws

Ed Bloom, KD9FRQ
 

Thank you!!! I am interested in ARDOP via HF and ax25 on 2m.

On 9/8/2019 11:39 AM, K4KDR wrote:
Hi Ed!

PAT works extremely well on the Pi/DRAWS using telnet, ax25, & ARDOP.?? The following video walks through the setup and there are many others from the same author going in to more detail on particular aspects of the same:


-Scott,?? K4KDR

=====================

On Sun, Sep 8, 2019 at 9:14 AM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:
Has anyone setup PAT via DRAWS??? I have not seen this but admit I may
have missed it.

73s, Ed, KD9FRQ


Re: #DRAWS PAT via DRAWS #draws

K4KDR
 

Hi Ed!

PAT works extremely well on the Pi/DRAWS using telnet, ax25, & ARDOP.  The following video walks through the setup and there are many others from the same author going in to more detail on particular aspects of the same:


-Scott,  K4KDR

=====================


On Sun, Sep 8, 2019 at 9:14 AM Ed Bloom, KD9FRQ via Groups.Io <ewbloom=verizon.net@groups.io> wrote:
Has anyone setup PAT via DRAWS??? I have not seen this but admit I may
have missed it.

73s, Ed, KD9FRQ