Date   
Re: No audio in or out of UDRC-II

 

Play with different combinations of TX and RX invert in dstarrepeaterconfig (remember to shutdown dstarrepeater, change, start dstarrepeater)

Play with RX first, and see if you can get log data of incoming packets (RX is pretty forgiving on the PCM input level). If you get that working, then play with TX invert and see if you can get copy on your radio (adjusting alsamixer levels).

On Wed, Dec 28, 2016 at 4:41 PM, Randy Wilkinson <randy@...> wrote:

It says:

    hw:0,0 (udrc)

for both RX device, and TX device.




--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

Re: No audio in or out of UDRC-II

 

It says:

    hw:0,0 (udrc)

for both RX device, and TX device.

Re: No audio in or out of UDRC-II

 

Double check that the Soundcard selected for XMIT and Receive are set to UDRC for dstarrepeaterconfig

On Wed, Dec 28, 2016 at 3:34 PM, Randy Wilkinson <randy@...> wrote:

Thank you for that suggestion.  Done.

Ran the measure_deviate.sh script.  The TX light on the UDRC-II lights up, it keys up the node radio and transmits any tone I want for any length of time.  I can hear it if I listen using an analog FM receiver.

It still does not work for dstarrepeater.

  • My two d-star radios cannot decode ANY d-star voice of data it transmits.
  • When I key up the d-star radios, the node radio indicates it is receiving, the dstarrepeater log file does not register any receive.  I do not see any receive light on the UDRC-II (not sure there is one).

Stuck in Spokane

Randy




--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

Re: No audio in or out of UDRC-II

 
Edited

Thank you for that suggestion.  Done.

Ran the measure_deviate.sh script.  The TX light on the UDRC-II lights up, it keys up the node radio and transmits any tone I want for any length of time.  I can hear it if I listen using an analog FM receiver.

It still does not work for dstarrepeater.

  • My two d-star radios cannot decode ANY d-star voice or data it transmits.
  • When I key up the d-star radios, the node radio indicates it is receiving, the dstarrepeater log file does not register any receive.  I do not see any receive light on the UDRC-II (not sure there is one).

Stuck in Spokane

Randy

Re: No audio in or out of UDRC-II

ml000-0013@...
 

  Hi Randy,

In response to your question on the other thread, yes the replacement did solve my issue.

However, in a previous message you questioned why your radio was not keying when you run 'speaker-test'.  The reason is that speaker-test does not assert the GPIO line needed to connect the PTT lines in the radio.  There is a test utility called measure_deviate.sh that will generate a test tone, and key/unkey PTT for testing purposes.  I suggest you stop all of the dstar processes and try testing with measure_deviate.sh (see the wiki link below):

https://nw-digital-radio.groups.io/g/udrc/wiki/Generate-a-Tone-to-Set-Radio-Deviation-via-the-UDRC™

Be sure to read the script and properly set your ALSA device in the script.


  Cheers

  Mike

Re: No output on UDRC-II

 

Did the replacement unit resolve your problem?

Re: No audio in or out of UDRC-II

 

Still trying with no success.

further troubleshooting I've done:

  • Verified node radio is in 9600 bps mode
  • Set dstarrepeater for 2 minute voice beaconing:  
    • On an analog receiver, I hear the characteristic short beep, followed by white noise modem tones.
    • Compared the white noise modem tones from the beconing node radio to a TX from another d-star radio.  The node radio transmission sounds slightly chuddered, but about the same volume.
    • Using two different dstar receivers, no decoded d-star TX is received.  Only the receive light illuminates, no voice beacon heard, no callsign or message received.
    • Tried various alsamixer settings as described in the troubleshooting steps in the UDRC™ For Simplex Hotspots and Converted Analog Repeaters guide.  Tried various LO and PCM settings, moving only a little at a time.

In this thread, another UDRC-II user advised that the UDRC-II he received was determined by NW DR to have a hardware defect, and was replaced with a different unit.  He never responded indicating if the replacement unit worked better than the original.  Mine was purchased from NW Digital Radio at about the same time.  In his description, his symptoms are similar to mine except he has better test instruments.  I have none.

Randy

Nice utility - multitail to monitor dstarrepeaterd and ircddbgatewayd logs in same session

Jeff - K2AK <k2ak@...>
 

Greetings to all,

 

For monitoring both the repeater and gateway logs in one session, I use multitail. I think you can load and monitor 4 at one time.

 

See example below using two logs.

 

73,

Jeff

 

 

Re: No audio in or out of UDRC-II

 

OK...learning.  Did that.  I turned off the dstarrepeaterd instance. Now it looks like the speaker-test program is generating audio and sending it to the udrc.

The udrc TX light does not come on.  The node radio does not key up.

Re: No audio in or out of UDRC-II

 



On Mon, Dec 26, 2016 at 11:17 PM, Randy Wilkinson <randy@...> wrote:


I tried to use the speaker-test utility:

    speaker-test -Dplughw:udrc -c2 -f1200 -tsine -l0

it fails and says:  Playback open error: -16,Device or resource busy

Any ideas?

Randy-W4LKS


The error means the udrc is in use by another program, likely dstarrepeaterd.

If you are running it in GUI mode, shut it down.  If daemon mode:

sudo systemctl stop dstarrepeaterd@1
 
--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

No audio in or out of UDRC-II

 

I'm trying to set up a simplex hotspot.  I'd like to replace the MoenComm Star*board in my current hotspot setup using an RPi2 an ICOM 208H transceiver.  It has a 6-pin mini DIN that worked with the MoenComm board and an Echolink node prior to that.  I recently received a UDRC-II board with the 6-pin to 6-pin cable.

I followed all of the setup instructions for Compass and UDRC.  Ran the 6-pin config script. 

I get no audio in or out.  When I key up my d-star HT, I see the receive indicator on the node radio, but the dstarrepeater log does not register any receive.  The dstarrepeater keys up the node radio every 10 minutes to beacon, but no voice or data is transmitted.

I have verified the alsamixer settings as others have suggested in another thread.

I tried to use the speaker-test utility:

    speaker-test -Dplughw:udrc -c2 -f1200 -tsine -l0

it fails and says:  Playback open error: -16,Device or resource busy

Any ideas?

Randy-W4LKS



Re: IRCddB Android remote

 

Duff,

Does the UDRC register with ircDDBGateway?

Remote control works with all repeaters and hotspots connected to a given ircDDBGateway.

dstarrepeater controlling the DR-1X through a UDRC doesn't have any direct connection to remote control, it is all on ircddbgateway.



On Tue, Dec 20, 2016 at 9:37 AM, Duff <wa7bfn@...> wrote:
Could you tell me what port you have assigned 
I have a DVAP on #1 works great just can't seem to get the DRCII to connect. 
Thanks



Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: Jeff - K2AK <k2ak@...>
Date: 12/20/16 5:09 AM (GMT-08:00)
Subject: Re: [udrc] IRCddB Android remote

Duff,

I have been using the Android version (1.3.88) here for a while and it works great.

 

Jeff – K2AK

 

From: udrc@....io [mailto:udrc@nw-digital-radio.groups.io] On Behalf Of Duff
Sent: Monday, December 19, 2016 8:36 PM
To: udrc@....io
Subject: [udrc] IRCddB Android remote

 

I'm running UDRC2 on system fusion...repeater.  and a DVAP both on D-Star...  I'm wanting to use the IRCddB remote on android phone to change ref/xref etc..

anyone using it? 

Thanks 

Duff WA7BFN

 




--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

Re: IRCddB Android remote

Duff <wa7bfn@...>
 

Could you tell me what port you have assigned 
I have a DVAP on #1 works great just can't seem to get the DRCII to connect. 
Thanks



Sent from my Verizon, Samsung Galaxy smartphone


-------- Original message --------
From: Jeff - K2AK <k2ak@...>
Date: 12/20/16 5:09 AM (GMT-08:00)
To: udrc@nw-digital-radio.groups.io
Subject: Re: [udrc] IRCddB Android remote

Duff,

I have been using the Android version (1.3.88) here for a while and it works great.

 

Jeff – K2AK

 

From: udrc@nw-digital-radio.groups.io [mailto:udrc@nw-digital-radio.groups.io] On Behalf Of Duff
Sent: Monday, December 19, 2016 8:36 PM
To: udrc@nw-digital-radio.groups.io
Subject: [udrc] IRCddB Android remote

 

I'm running UDRC2 on system fusion...repeater.  and a DVAP both on D-Star...  I'm wanting to use the IRCddB remote on android phone to change ref/xref etc..

anyone using it? 

Thanks 

Duff WA7BFN

 

Re: IRCddB Android remote

Jeff - K2AK <k2ak@...>
 

Duff,

I have been using the Android version (1.3.88) here for a while and it works great.

 

Jeff – K2AK

 

From: udrc@nw-digital-radio.groups.io [mailto:udrc@nw-digital-radio.groups.io] On Behalf Of Duff
Sent: Monday, December 19, 2016 8:36 PM
To: udrc@nw-digital-radio.groups.io
Subject: [udrc] IRCddB Android remote

 

I'm running UDRC2 on system fusion...repeater.  and a DVAP both on D-Star...  I'm wanting to use the IRCddB remote on android phone to change ref/xref etc..

anyone using it? 

Thanks 

Duff WA7BFN

 

Re: IRCddB Android remote

 

It works fine with ircddbgateway I have both the Android and iOS versions. 

On Dec 19, 2016 21:04, "Duff" <wa7bfn@...> wrote:

I'm running UDRC2 on system fusion...repeater.  and a DVAP both on D-Star...  I'm wanting to use the IRCddB remote on android phone to change ref/xref etc..

anyone using it? 

Thanks 

Duff WA7BFN


IRCddB Android remote

Duff <wa7bfn@...>
 

I'm running UDRC2 on system fusion...repeater.  and a DVAP both on D-Star...  I'm wanting to use the IRCddB remote on android phone to change ref/xref etc..

anyone using it? 

Thanks 

Duff WA7BFN


Re: Deviation for packet

ml000-0013@...
 

  Hi John,

Thanks for your feedback; I have read the febo.com article, and it is the reason I was questioning the deviation spread between low and high tones.  On other systems that I've tested, the split was much smaller (like 500Hz).  You make a good point, and I think I should be testing deviation using the discriminator input; after all the UDRC can't help what the radio is going to do with preemphasis.  I will give that a shot and report back.

BTW, I'm switching from an old hardware TNC to Direwolf.  I've been amazed at the performance; Direwolf decodes between 70% to 90% more packets.


  Thanks

  Mike


Re: ircnodedashboard updated

 

tar -xzvf icons.tgz
They were a quick solution for those who wanted some desktop Icons. Modify to your specific installation.
... and modify the docs/wiki if there are different better easier ways
to get the systems up and running...

Bill

Re: ircnodedashboard updated

 



On Fri, Dec 16, 2016 at 10:08 AM, John M Wysocki ZL2TWS <zl2tws@...> wrote:

John

Thank you for your help.

The systemctl disable functions work perfectly. I used systemctl enable to bring back the d versions as required. Noted while monitoring using top or htop that Yes they both run as "opendv"

When I issue disable they close down and stop as active running applications.

ircDDBGateway and DStarRepeater 1 can be started in GUI from the Icons already on the dashboard installed during the initial set up of the UDRC and compass like this:

If you want a set of desktop Icons to start the GUI applications, see: https://nw-digital-radio.groups.io/g/udrc/files

and download file icons.tgz to the 'pi' user home directory /home/pi then

tar -xzvf icons.tgz
They were a quick solution for those who wanted some desktop Icons.  Modify to your specific installation.
 

Yes they start but according to top and htop they are running as "root"

Question: Why has my install of easy to use icons as per the instruction above run as "root" and not "opendv"

if that was the NW teams intention in the first place?


Let me repeat, none of ircddbgateway, dstarrepeater, or ircnodedashboard are products of NW Digital Radio.

Any 'advice', scripts, etc. are provided simply to help people get started.  The peculiarities of specific installations are the responsibility of the administrators and operators of those installations. 

And from the ircnodedashboard README.md

These instructions are meant as a general guide for setup. Familiarity with Linux commands, administration and troubleshooting are recommended.

With d versions shut down gui version runs well as "root" and the dashboard continues to function.

Well I guess I am happy with that but seems to be different to your comment about the dashboard files not being found unless running as d version.


My comment was that they will have the wrong permissions set, not that they cannot be found.  Here is the problem, if you run ircddbgateway with the GUI, and it creates files they will be owned by 'root', other programs which run using a more secure account like opendv (which ircnodedashboard and the daemon versions of ircddbgateway and dstarrepeater do) may be prevented from writing to those files.  The log files are readable.   The latest version of the dashboard tries to insure that the log files exist, as I said the 'touch' lines can be removed and the dashboard will run with pre-existing files.

Tried sudo -u opendv ircddbgateway but this error is returned:

pi@compass:~ $ sudo -u opendv ircddbgateway

No protocol specified

07:04:20: Error: Unable to initialize GTK+, is DISPLAY set properly?


This depends on how things are setup on your system (eg. understanding Linux setup and administration). Does your opendv account have a home directory, eg /home/opendv ? -- it will need an .Xauthority file to allow the opendv account to open the gui using sudo.  A cheat is

sudo mkdir /home/opendv
sudo chown opendv:opendv /home/opendv
cd ~
sudo cp .Xauthority /home/opendv
sudo chown opendv:opendv /home/opendv/.Xauthority




 

pi@compass:~ $ 

As you say. Use d running as "opendv" and gui if needed but be warned it is "root"

73, John ZL2TWS/ZL2TWT
_._,_._,_


--


John D. Hays
K7VE

PO Box 1223, Edmonds, WA 98020-1223
   

Re: ircnodedashboard updated

 

John

Thank you for your help.

The systemctl disable functions work perfectly. I used systemctl enable to bring back the d versions as required. Noted while monitoring using top or htop that Yes they both run as "opendv"

When I issue disable they close down and stop as active running applications.

ircDDBGateway and DStarRepeater 1 can be started in GUI from the Icons already on the dashboard installed during the initial set up of the UDRC and compass like this:

If you want a set of desktop Icons to start the GUI applications, see: https://nw-digital-radio.groups.io/g/udrc/files

and download file icons.tgz to the 'pi' user home directory /home/pi then

tar -xzvf icons.tgz

Yes they start but according to top and htop they are running as "root"

Question: Why has my install of easy to use icons as per the instruction above run as "root" and not "opendv"

if that was the NW teams intention in the first place?

With d versions shut down gui version runs well as "root" and the dashboard continues to function.

Well I guess I am happy with that but seems to be different to your comment about the dashboard files not being found unless running as d version.

Tried sudo -u opendv ircddbgateway but this error is returned:

pi@compass:~ $ sudo -u opendv ircddbgateway

No protocol specified

07:04:20: Error: Unable to initialize GTK+, is DISPLAY set properly?

pi@compass:~ $ 

As you say. Use d running as "opendv" and gui if needed but be warned it is "root"

73, John ZL2TWS/ZL2TWT