Date   
Re: #claws-mail ICS Forms #claws-mail

Basil Gunn
 

I just confirmed what I last posted worked as expected.
If you want more help please be more specific.
ie. what ICS form are you using and as much detail as you can describe.
What version of Linux: uname -a
What version of flmsg:
Which browser:

/Basil n7nix


Ryan Matthew Headley <headley.ryan@...> writes:

OK.

After a restart of the Raspberry Pi, the ICS form now appears on the CUSTOM
list in flmsg.

However, once the form is completed and I click 'Submit' at the bottom of
the webpage, I am returned to flmsg where instead of my entered text
appearing, something such as '�� �������� �� � ' appears.

On Fri, Nov 22, 2019 at 12:39 PM Ryan Matthew Headley via Groups.Io
<headley.ryan=gmail.com@groups.io> wrote:

Sorry for the hasty response. The meat of it holds though.

After downloading the html files, moving them to the CUSTOM folder,
running flmsg, and selecting 'CUSTOM'; nothing shows up except 'Transfer
FORM.'

I promise that I am not being purposefully obtuse. What steps and I
missing?


Re: #claws-mail ICS Forms #claws-mail

Basil Gunn
 

This is what I did:

cd
cd .nbems/CUSTOM
wget https://downloads.winlink.org/User%20Programs/Standard_Forms.zip
unzip Standard_Forms.zip

flmsg <Using 'Simple User' Interface>
click file > template folder

All the Winlink files are there.
Perhaps you are using the 'Expert UI' & you didn't click 'All files'?
/Basil n7nix


Ryan Matthew Headley <headley.ryan@...> writes:

Sorry for the hasty response. The meat of it holds though.

After downloading the html files, moving them to the CUSTOM folder, running flmsg, and selecting 'CUSTOM'; nothing shows up except 'Transfer FORM.'

I promise that I am not being purposefully obtuse. What steps and I missing?

Re: #claws-mail ICS Forms #claws-mail

Ryan Matthew Headley
 

OK.

After a restart of the Raspberry Pi, the ICS form now appears on the CUSTOM list in flmsg.

However, once the form is completed and I click 'Submit' at the bottom of the webpage, I am returned to flmsg where instead of my entered text appearing, something such as '�� �������� �� � ' appears.


On Fri, Nov 22, 2019 at 12:39 PM Ryan Matthew Headley via Groups.Io <headley.ryan=gmail.com@groups.io> wrote:
Sorry for the hasty response.  The meat of it holds though.

After downloading the html files, moving them to the CUSTOM folder, running flmsg, and selecting 'CUSTOM'; nothing shows up except 'Transfer FORM.' 

I promise that I am not being purposefully obtuse.  What steps and I missing? 



--
***************************
Ryan Matthew Headley
1705 Granby Road
Cayce, SC 29033 USA

mobile - +1803-386-1799

Re: #claws-mail ICS Forms #claws-mail

Ryan Matthew Headley
 

Sorry for the hasty response.  The meat of it holds though.

After downloading the html files, moving them to the CUSTOM folder, running flmsg, and selecting 'CUSTOM'; nothing shows up except 'Transfer FORM.' 

I promise that I am not being purposefully obtuse.  What steps and I missing? 

Re: #claws-mail ICS Forms #claws-mail

Ryan Matthew Headley
 

These instruction simply do not work. 

I put the form download form into the 'CUSTOM' folder, and nothing shows up.


On Fri, Nov 22, 2019 at 12:26 PM Basil Gunn <basil@...> wrote:

> You have peaked by curiosity though when you wrote 'flmsg allows you
> to act on the forms.'
>
> My simple question is, how?

FLMSG Users Manual 4.0
http://www.w1hkj.com/flmsg-help/





--
***************************
Ryan Matthew Headley
1705 Granby Road
Cayce, SC 29033 USA

mobile - +1803-386-1799

Re: #claws-mail ICS Forms #claws-mail

Basil Gunn
 

You have peaked by curiosity though when you wrote 'flmsg allows you
to act on the forms.'

My simple question is, how?
FLMSG Users Manual 4.0
http://www.w1hkj.com/flmsg-help/

Re: #claws-mail ICS Forms #claws-mail

Mitch Winkle
 

Scott,

Typically, ICS-213s are normalized down to numbered lines per the PDF forms provided by the form owners.  What gets transmitted OTA is simply the numeral followed by the data.

See the attached snip.

Mitch

On 11/22/19 11:50 AM, K4KDR wrote:
Hi Mitch!

Sorry, I'm not positive what you mean by "numbered format", but I did notice there was a field <msgseqnum> that seemed to be assigned by the sender (me) and incremented with each subsequent message.  So, I mentioned in my how-to that we should track that value and increase it on the next message, etc.

Hope that's what you're referring to.

In any event, it's cool to send via PAT and, when received on a Windows Winlink client, have the form pop open exactly as it should.  That was my metric to gauge whether I was successful or not.  I also contacted the net control station at one of our "Winlink Wednesday" stations that gives anyone interested a place to stay sharp on using Winlink.  He also confirmed that my ICS-213 was received correctly when I did a test send from the Pi.

-Scott


===============================

-----Original Message----- From: Mitch Winkle
Sent: Friday, November 22, 2019 11:30 AM
To: udrc@nw-digital-radio.groups.io
Subject: Re: [draws and udrc] #claws-mail ICS Forms

I can certainly add the current ICS-213 to my UI client for PAT. Are you
simply using the numbered format for the OTA transmission?

1.
2. etc.

On 11/22/19 10:51 AM, K4KDR wrote:
Good day!

Just to show myself that it could be done, I successfully sent an ICS-213 using PAT on the Rasp Pi/DRAWS.

Here is my write up on the manual steps I did to make it happen.  Not difficult at all but someone could certainly automate the process to reduce the amount of editing by hand for a new message.

http://k4kdr.github.io/pdf/2019-10-17--ics-forms-from-pat.pdf

73!

-Scott,  K4KDR



Re: #claws-mail ICS Forms #claws-mail

Ryan Matthew Headley
 

Perhaps my statement regarding the necessity of Winlink Express was too strong; is it possible and will it work technically?  Yes.  Is it a solution deployable in a time sensitive situation? Not from what I have been able to gather.

You have peaked by curiosity though when you wrote 'flmsg allows you to act on the forms.'

My simple question is, how? 

Re: #claws-mail ICS Forms #claws-mail

K4KDR
 

Hi Mitch!

Sorry, I'm not positive what you mean by "numbered format", but I did notice there was a field <msgseqnum> that seemed to be assigned by the sender (me) and incremented with each subsequent message. So, I mentioned in my how-to that we should track that value and increase it on the next message, etc.

Hope that's what you're referring to.

In any event, it's cool to send via PAT and, when received on a Windows Winlink client, have the form pop open exactly as it should. That was my metric to gauge whether I was successful or not. I also contacted the net control station at one of our "Winlink Wednesday" stations that gives anyone interested a place to stay sharp on using Winlink. He also confirmed that my ICS-213 was received correctly when I did a test send from the Pi.

-Scott


===============================

-----Original Message-----
From: Mitch Winkle
Sent: Friday, November 22, 2019 11:30 AM
To: udrc@nw-digital-radio.groups.io
Subject: Re: [draws and udrc] #claws-mail ICS Forms

I can certainly add the current ICS-213 to my UI client for PAT. Are you
simply using the numbered format for the OTA transmission?

1.
2. etc.

On 11/22/19 10:51 AM, K4KDR wrote:
Good day!

Just to show myself that it could be done, I successfully sent an ICS-213 using PAT on the Rasp Pi/DRAWS.

Here is my write up on the manual steps I did to make it happen. Not difficult at all but someone could certainly automate the process to reduce the amount of editing by hand for a new message.

http://k4kdr.github.io/pdf/2019-10-17--ics-forms-from-pat.pdf

73!

-Scott, K4KDR

Re: #claws-mail ICS Forms #claws-mail

Basil Gunn
 

I'm trying to understand your problem.
If you need the latest Winlink ICS standard forms just download and use
them.
https://downloads.winlink.org/User%20Programs/Standard_Forms.zip

flmsg allows you to act on the forms. Now using your paclink-unix or pat
mail client, attach the form to your Winlink message and send the
message.

What we found was that the various state agencies used different forms
so we needed to use those forms.

Your statement that you need to run Winlink Express to use ICS forms is
not true. Winlink has done a nice job of integrating forms into Winlink
Express so as Scott K4KDR points out the method you would use on your
Linux system is not as turn key as the Winlink Express program but still
doable.

/Basil n7nix


Ryan Matthew Headley <headley.ryan@...> writes:

I am trying to find a solution to this as well. I have been messing
with the html files that can be downloaded from winlink.org with no
results.

I also thought that flmesg could be a solution. It does indeed work,
but the fields in the form are old and are no longer acceptable under
ICS operations in my state (or probably any state).

Unfortunately--while pat and paclink-unix work for person to person
communication--if you are part of any official support effort you will
still need a Windows computer running Winlink Express in order to do
your job.

Re: #claws-mail ICS Forms #claws-mail

Mitch Winkle
 

I can certainly add the current ICS-213 to my UI client for PAT. Are you simply using the numbered format for the OTA transmission?

1.
2. etc.

On 11/22/19 10:51 AM, K4KDR wrote:
Good day!

Just to show myself that it could be done, I successfully sent an ICS-213 using PAT on the Rasp Pi/DRAWS.

Here is my write up on the manual steps I did to make it happen.  Not difficult at all but someone could certainly automate the process to reduce the amount of editing by hand for a new message.

http://k4kdr.github.io/pdf/2019-10-17--ics-forms-from-pat.pdf

73!

-Scott,  K4KDR

Re: #claws-mail ICS Forms #claws-mail

Ryan Matthew Headley
 

This a great proof of concept, and it does work; but not really ready for prime-time.  I hate having to carry a Windows laptop just for ICS forms.

Re: #claws-mail ICS Forms #claws-mail

K4KDR
 

Good day!

Just to show myself that it could be done, I successfully sent an ICS-213 using PAT on the Rasp Pi/DRAWS.

Here is my write up on the manual steps I did to make it happen.  Not difficult at all but someone could certainly automate the process to reduce the amount of editing by hand for a new message.


73!

-Scott,  K4KDR

============================


On Fri, Nov 22, 2019 at 10:01 AM Ryan Matthew Headley <headley.ryan@...> wrote:
I am trying to find a solution to this as well.  I have been messing with the html files that can be downloaded from winlink.org with no results.

I also thought that flmesg could be a solution.  It does indeed work, but the fields in the form are old and are no longer acceptable under ICS operations in my state (or probably any state). 

Unfortunately--while pat and paclink-unix work for person to person communication--if you are part of any official support effort you will still need a Windows computer running Winlink Express in order to do your job.

Re: #claws-mail ICS Forms #claws-mail

Ryan Matthew Headley
 

I am trying to find a solution to this as well.  I have been messing with the html files that can be downloaded from winlink.org with no results.

I also thought that flmesg could be a solution.  It does indeed work, but the fields in the form are old and are no longer acceptable under ICS operations in my state (or probably any state). 

Unfortunately--while pat and paclink-unix work for person to person communication--if you are part of any official support effort you will still need a Windows computer running Winlink Express in order to do your job.

Re: #draws #audio #ax25 #draws #audio #ax25

Basil Gunn
 

Apologies ahead of time if I am rehashing anything already extant on
the boards. I have attempted to search for solutions, but have not
been able to find anything.
Search forum: https://nw-digital-radio.groups.io/g/udrc/topics
Check Wiki: https://nw-digital-radio.groups.io/g/udrc/wiki/home
Check docs: https://github.com/nwdigitalradio/n7nix/tree/master/docs

I received my DRAWS hat yesterday, loaded the DRAWS image, and
followed the configuration steps listed on the boards. Most things
worked exactly as indicated.

In testing to set levels, I set up an Alinco 135 connected to the
DRAWS, and a Yaesu FT-991A for monitoring--both on 144.390Mhz. I had
to set the output gain to +15db before it was even audible--and +29db
is decodable, but still well below the other AX25 signals I was
receiving from elsewhere. I switched the radios with virtually the
same result. I cannot imagine that this is normal.
I have an Alinco DR-235 mkIII and found these settings to work:
https://github.com/nwdigitalradio/n7nix/tree/master/deviation#notes-alinco-dr-x35-mk-iii

Calculate the proper settings to use:
If you are using the NW Digital Radio image & are using a monitor

open a browser
url: localhost:8080
Click: Toggle TX calculator.

Re: Just starting out #draws

Ryan Matthew Headley
 

This is the image you should use if you need and X server:

https://downloads.raspberrypi.org/raspbian_latest

If you can get by without a desktop, this install is a little over half the size of the above version with the X server.

https://downloads.raspberrypi.org/raspbian_lite_latest

Either way, make sure that you make the changes to /boot/config.txt to enable to DRAWS hat.

When you go to configure your specific software packages, the DRAWS board shows up as the ALSA device 'UDRC.'

Re: Just starting out #draws

Paul Noa
 

Ryan,

Thanks for that advice, I was hoping there would be a minimal configuration as well, so this sounds good.

To clarify, so there is no need to download the latest image from NWDR/support, correct?

Could you be more specific on the Raspian with Desktop? I already have an image with a Debian blend, the option not in NOOBS but from RPI.org.

Thanks fro your support in advance,

Paul

Re: Just starting out #draws

Ryan Matthew Headley
 

If your only application will be as you describe, I would suggest foregoing the DRAWS image.

Download Raspbian with Desktop (NOT the one with 'recommeded software'); install gpsd, direwolf, and FoxtrotGPS; and you are good to go without a lot of complication.

Be sure to make the changes in /boot/config.txt to enable the DRAWS hat described at the bottom of the 'Getting Started' page.

This may not be what you are looking for, but this is what I would do with for such a straightforward single application.

#draws #audio #ax25 #draws #audio #ax25

Ryan Matthew Headley
 

Apologies ahead of time if I am rehashing anything already extant on the boards.  I have attempted to search for solutions, but have not been able to find anything.

I received my DRAWS hat yesterday, loaded the DRAWS image, and followed the configuration steps listed on the boards.  Most things worked exactly as indicated. 

Using the scripts indicated in 'Getting Started,' I configured AX25 and got ALSA working, but with a few curiosities.  Mysteriously, the default configuration sets AX25 to use the right connector.  (That one took a few minutes to figure out).  ALSA audio was is curious as well. 

In testing to set levels, I set up an Alinco 135 connected to the DRAWS, and a Yaesu FT-991A for monitoring--both on 144.390Mhz.  I had to set the output gain to +15db before it was even audible--and +29db is decodable, but still well below the other AX25 signals I was receiving from elsewhere.  I switched the radios with virtually the same result.  I cannot imagine that this is normal. 

I am probably going to set up my own imagine later today for further testing.

Any thoughts?

Re: Stream Audio Using VNC Command Line to Local Network #audio

Paul Noa
 

Basil,
I am reaching out for a little direction getting started with my Draws (Hat Only) install on RPi 3 B+ as I see you are very active and obviously much more knowledgeable than myself in this area.

The more I  read the more unsure I become as where to start. This is where I have started :
Could you be so kind as to direct me to the best most reliable version of Buster w/NWDR code for the Draws hat if this is not the best place to start?

Thanks in advance for your support,

Paul

Paul 


On Sat, 16 Nov 2019 at 11:05, Basil Gunn <basil@...> wrote:

Where in the command that you gave is the syntax for the USB device you
are using? dsnoop:1 ?

If I use cvlc --longhelp it lists alsa audio devices so I'm guessing you
would replace dsnoop:1 with dsnoop:CARD=udrc

cvlc --longhelp | grep -i alsa-audio-device
VLC media player 3.0.7 Vetinari (revision 3.0.7-0-g86cee31099)
      --alsa-audio-device {null,default:CARD=ALSA,sysdefault:CARD=ALSA,dmix:CARD=ALSA,DEV=0,dmix:CARD=ALSA,DEV=1,dsnoop:CARD=ALSA,DEV=0,dsnoop:CARD=ALSA,DEV=1,hw:CARD=ALSA,DEV=0,hw:CARD=ALSA,DEV=1,plughw:CARD=ALSA,DEV=0,plughw:CARD=ALSA,DEV=1,default:CARD=udrc,sysdefault:CARD=udrc,dmix:CARD=udrc,DEV=0,dsnoop:CARD=udrc,DEV=0,hw:CARD=udrc,DEV=0,plughw:CARD=udrc,DEV=0,default}

/Basil

Anthony Sutera <tsutera@...> writes:

> I am using my Draws Hat mainly for WSJT-X. I have a quick question: I
> would like to stream audio to my local network. On my other setups
> (Raspberry Pi3) using a signal link USB audio card, I succesfully use
> this command:

cvlc -vvv alsa://dsnoop:1 --sout '#transcode{acodec=mp3,ab=64,channels=1}:standard{access=http,dst=192.168.165.126/out.mp3}'

> to stream audio out to my local network. Can someone let me know the
> correct audio device to list in the command line using the Draws Hat
> sound card? Thank you! Tony Sutera KF7VLT