Date   

Re: #Desktop file manager and screen blanking issues #desktop

Ruben .
 

Thank you for voicing these issues, I thought it was my inexperience.

Ruben
WA2NBL


On Feb 2, 2020, at 10:17 AM, David Lowry <huskyrunnr@...> wrote:

I had the same problem with file manager. I had a fresh image, nwdr15, the piwiz ran through almost all downloads then failed. Basil had said the core config does the same thing as the piwiz, if I understood correctly, so I left it. After core config, I tried to use the file manager for the first time and noticed the problem.

the problem went away after running

sudo apt update
sudo apt full-upgrade
sudo reboot

david, Ke7rgp 


Re: #Desktop file manager and screen blanking issues #desktop

 

I had the same problem with file manager. I had a fresh image, nwdr15, the piwiz ran through almost all downloads then failed. Basil had said the core config does the same thing as the piwiz, if I understood correctly, so I left it. After core config, I tried to use the file manager for the first time and noticed the problem.

the problem went away after running

sudo apt update
sudo apt full-upgrade
sudo reboot

david, Ke7rgp 


Re: #Desktop file manager and screen blanking issues #desktop

Jonathan Visser
 

Bernard, 

For the file manager I noticed this to.  We did a quick reinstall of the file manager and it took care if it.   When I get back home later today I will look up the command we used and send it over. 

73’s Jonathan N9TJX

On Feb 2, 2020, at 05:31, f6bvp <f6bvp@...> wrote:

Hi,
With nwdr15.img and recently with nwdr14.img I observed same desktop issues on two different Raspberry Pi models 3B+ and 4 and two different screen displays models.
These issues are not present on latest RaspBian distro september 2019 with same 4.19.93 kernel and all applications updated.

First issue is with screen blanking. I had to disable it in preference menu for it was impossible to recover a display after it was blanked. Sometime unplugging the UDMI plug could recover a normal display but usually a reboot was needed.

Second issue is with File Manager desktop icon. When clicking on the icon it opens a file window very briefly and close it right away. At the same time all desktop icons disappear for a brief moment and reappear on the desktop.

73 de Bernard, f6bvp


#Desktop file manager and screen blanking issues #desktop

Bernard f6bvp / ai7bg
 

Hi,
With nwdr15.img and recently with nwdr14.img I observed same desktop issues on two different Raspberry Pi models 3B+ and 4 and two different screen displays models.
These issues are not present on latest RaspBian distro september 2019 with same 4.19.93 kernel and all applications updated.

First issue is with screen blanking. I had to disable it in preference menu for it was impossible to recover a display after it was blanked. Sometime unplugging the UDMI plug could recover a normal display but usually a reboot was needed.

Second issue is with File Manager desktop icon. When clicking on the icon it opens a file window very briefly and close it right away. At the same time all desktop icons disappear for a brief moment and reappear on the desktop.

73 de Bernard, f6bvp


Re: Draws problems

Richard Waller <rewaller@...>
 

I will follow your suggestion but I had been using the ft 817 without removing any pins on mini din and audio was fine.

On Jan 29, 2020, at 10:31 AM, Basil Gunn <@basil860> wrote:


When I last looked at the Yaesu FT-817 over a year ago I had to
disconnect pin 6 on the mDin6 cable which controls squelch on that radio
to get receive audio to work.

See Running FLdigi with the Yaesu FT-817 at this link:
https://github.com/nwdigitalradio/n7nix/blob/master/docs/RADIO_APP_NOTES.md

Also run the measure_deviate.sh script to verify transmit as previously
described.

/Basil

Basil, yes I reimaged the micro sd card. The rPi otherwise is
functioning normally. To be clear, I haven’t tried transmitting. When
I monitor I’m not getting evidence of signals ( which I can hear ) on
the screen. I had been using left minidin. Switched to right in draws
manager, same result. I selected preset for ft 817 af. Audio in out in
wsjt plughwCARD=udrc, DEV=0. Rick
On Jan 29, 2020, at 1:01 AM, Basil Gunn <@basil860> wrote:

Richard Waller via Groups.Io <rewaller=verizon.net@groups.io> writes:

I “crashed” my micro sd card using a non- draws related program.
I reloaded the earlier version of software that I had been using which
had been working on to that sd card.
What exactly did you do? Did you re-image the mSD card?

The wsjt-x program comes up and
runs like before but Now I’m not getting audio from my ft 817 to
wsjt-x program. I’m using the exact same cables and settings I was
using before. I updated the software with the same results.
Is there a way to check the draws hat to see if it is
working?Thanks. Rick Ka4ohm
A basic test is to use the measure_deviate.sh script
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

This will generate a tone and enable PTT. There are options to test left
& right channels.
Use a second radio to hear the generated tone.

/Basil n7nix






Re: Nixtracker

Basil Gunn
 

I got it now Basil. Thanks. My ignorance of Linux is shining
through. Every user including the system gets their own crontab. I was
using the system’s crontab.

time to go read about Linux os
I would suggest to learn about Linux have an idea about something that
you want your Linux system to do then google away until you figure it
out.

got all my wires and coax fished in the truck. Install tomorrow!
Terrific!! Send me a pic when it's done.

i notice in the YouTube you pointed me to, there is no debug panel. Do
you toggle that panel on/off or leave it there all the time?
I currently leave it there all the time. I'll have to look into getting
rid of it.

also, one of the rotating beacon messages indicates a digipeating setting?
That's just a filler I think left over from Dan Smith's configuration
from a number of years ago.

You can easily customize your beacons by looking in the
/etc/tracker/aprs_tracker.ini file in the [comments] section
You set up which beacons you want to rotate through then enable them
with the enabled = line
I would change the #4 beacon to something else.
Variables are defined between pairs of $.

enabled = 1,2,3,4
1=Using nixtracker $ver$, gps sats $sats$
2=https://github.com/n7nix/nixtracker
3=Software $ver$
4=Set path to TEMP1-1,WIDE2-1 to digi
5=Test: Number of sats $sats$, version $ver$, date $date$, time $time$, voltage, $voltage$, index $index$, temperature $temp1$, sig qual $digiq$, call sign $mycall$

/Basil


Re: Nixtracker

 

I got it now Basil. Thanks. My ignorance of Linux is shining through. Every user including the system gets their own crontab. I was using the system’s crontab.

time to go read about Linux os

got all my wires and coax fished in the truck. Install tomorrow!

i notice in the YouTube you pointed me to, there is no debug panel. Do you toggle that panel on/off or leave it there all the time?

also, one of the rotating beacon messages indicates a digipeating setting?

david


Re: Draws problems

Basil Gunn
 

When I last looked at the Yaesu FT-817 over a year ago I had to
disconnect pin 6 on the mDin6 cable which controls squelch on that radio
to get receive audio to work.

See Running FLdigi with the Yaesu FT-817 at this link:
https://github.com/nwdigitalradio/n7nix/blob/master/docs/RADIO_APP_NOTES.md

Also run the measure_deviate.sh script to verify transmit as previously
described.

/Basil

Basil, yes I reimaged the micro sd card. The rPi otherwise is
functioning normally. To be clear, I haven’t tried transmitting. When
I monitor I’m not getting evidence of signals ( which I can hear ) on
the screen. I had been using left minidin. Switched to right in draws
manager, same result. I selected preset for ft 817 af. Audio in out in
wsjt plughwCARD=udrc, DEV=0. Rick
On Jan 29, 2020, at 1:01 AM, Basil Gunn <@basil860> wrote:


Richard Waller via Groups.Io <rewaller=verizon.net@groups.io> writes:

I “crashed” my micro sd card using a non- draws related program.
I reloaded the earlier version of software that I had been using which
had been working on to that sd card.
What exactly did you do? Did you re-image the mSD card?

The wsjt-x program comes up and
runs like before but Now I’m not getting audio from my ft 817 to
wsjt-x program. I’m using the exact same cables and settings I was
using before. I updated the software with the same results.
Is there a way to check the draws hat to see if it is
working?Thanks. Rick Ka4ohm
A basic test is to use the measure_deviate.sh script
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

This will generate a tone and enable PTT. There are options to test left
& right channels.
Use a second radio to hear the generated tone.

/Basil n7nix




Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

Jack Spitznagel
 

Basil,

 

Thanks for refreshing my memory with the link below – it had been a good while and my focus has been significantly elsewhere since before Dayton/Xenia last year:

 

In a previous post it was mentioned that the contents of that email were captured here:

https://github.com/nwdigitalradio/n7nix/blob/master/docs/RADIO_APP_NOTES.md#alsa-settings-for-ic-7000

Again my very faulty recall was that I did test these settings and found that it still did not allow me to adjust the ALC to the “nil” reading for minimum sig distortion without the noise issue cropping up. OTOH, I am pretty sure I used the discriminator output for receive… but RX was never the issue here. Since I have not tried the new image, I will give it a go and configure from the ground up. If that can be made to work well, then I’ll tackle the 7100 to see if it is different.

 

Thanks,

 

KD4IZ

Jack Spitznagel

FM19oo

 

 

 


Re: Draws problems

Richard Waller <rewaller@...>
 

Basil, yes I reimaged the micro sd card. The rPi otherwise is functioning normally. To be clear, I haven’t tried transmitting. When I monitor I’m not getting evidence of signals ( which I can hear ) on the screen. I had been using left minidin. Switched to right in draws manager, same result. I selected preset for ft 817 af. Audio in out in wsjt plughwCARD=udrc, DEV=0. Rick

On Jan 29, 2020, at 1:01 AM, Basil Gunn <@basil860> wrote:


Richard Waller via Groups.Io <rewaller=verizon.net@groups.io> writes:

I “crashed” my micro sd card using a non- draws related program.
I reloaded the earlier version of software that I had been using which
had been working on to that sd card.
What exactly did you do? Did you re-image the mSD card?

The wsjt-x program comes up and
runs like before but Now I’m not getting audio from my ft 817 to
wsjt-x program. I’m using the exact same cables and settings I was
using before. I updated the software with the same results.
Is there a way to check the draws hat to see if it is
working?Thanks. Rick Ka4ohm
A basic test is to use the measure_deviate.sh script
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

This will generate a tone and enable PTT. There are options to test left
& right channels.
Use a second radio to hear the generated tone.

/Basil n7nix



Re: Draws problems

Basil Gunn
 

Richard Waller via Groups.Io <rewaller=verizon.net@groups.io> writes:

I “crashed” my micro sd card using a non- draws related program.
I reloaded the earlier version of software that I had been using which
had been working on to that sd card.
What exactly did you do? Did you re-image the mSD card?

The wsjt-x program comes up and
runs like before but Now I’m not getting audio from my ft 817 to
wsjt-x program. I’m using the exact same cables and settings I was
using before. I updated the software with the same results.
Is there a way to check the draws hat to see if it is
working?Thanks. Rick Ka4ohm
A basic test is to use the measure_deviate.sh script
https://github.com/nwdigitalradio/n7nix/tree/master/deviation

This will generate a tone and enable PTT. There are options to test left
& right channels.
Use a second radio to hear the generated tone.

/Basil n7nix


Draws problems

Richard Waller <rewaller@...>
 

I “crashed” my micro sd card using a non- draws related program. I reloaded the earlier version of software that I had been using which had been working on to that sd card. The wsjt-x program comes up and runs like before but Now I’m not getting audio from my ft 817 to wsjt-x program. I’m using the exact same cables and settings I was using before. I updated the software with the same results. Is there a way to check the draws hat to see if it is working?Thanks. Rick Ka4ohm


Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

Basil Gunn
 

I believe Basil did experiment with his friends IC-7000, but if I recall
correctly, only determined that the FM output could be made to work, but I
can't remember if he actually took a crack at the fldigi/wsjt-x over HF
problem and was able to duplicate it.
You recall incorrectly. Below is the link to email sent after we
successfully set up an IC-7000 for FLdigi Olivia 8-250

https://nw-digital-radio.groups.io/g/udrc/message/2523?p=,,,20,0,0,0::relevance,,%23ic7000,20,2,0,28894545

Ignore this remark as the udrc/draws driver is now in mainline linux kernel.
"You must use the latest udrc-dkms driver (1.0.5)"

In a previous post it was mentioned that the contents of that email were captured here:

https://github.com/nwdigitalradio/n7nix/blob/master/docs/RADIO_APP_NOTES.md#alsa-settings-for-ic-7000

/Basil n7nix


Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

Corky Searls
 

Just FYI, indeed Fldigi and the WSJT-X and JS8Call apps have very different sound sensitivities. On my main HF system which is still using a laptop with a SignaLinkUSB to drive a K3 I find I need to significantly change either the audio output levels for the computer, or in my case I change the Mic gain on the K3 (the change is about 10 units).

In talking with others, this appears to be "normal."

Thanks and 73,
-Corky, AF4PM


On Mon, Jan 27, 2020, at 7:36 PM, Dave Christensen wrote:
I did read and apply the settings for the IC-7000.
******************************

 

I have an Icom IC-7000 radio that I am feeding by the DIN-6 data connector in the back.  I can get the VHF stuff working with default ALSA settings or even the setalsa-ic7000settings for the IC-7000 and it works great.  Clean audio and no retries.

 

For FLDigi I have to change the ALSA settings from Analog = -3, Digital gain = -16 to 20 to Analog=-2.00 db and Digital = -8.00 db just to get clean audio.  Lower gain settings produces noise - no clean tone with FLDigi Tune turned on.  The signal is so hot that I can not get the ALC below full scale on the meter.   I lower the gain and the noise comes back  One interesting thing is that the sound card available for FLDigi selection is “udrc: bcm2835-i2s-tlv320aic32x4-hifi tlv320aicx4-hifi-0 (hw 1,0)”   

 

With WSJTX and JS8Call the soundcard is listed as plughw: CARD=udrc, DEV=0  The power setting slider in the apps do nothing.  These apps are opposite from FLDigi in that I can’t get enough drive to the radio using the same ALSA settings to generate any transmit power or even increasing the transmit gain.

So summary:  VHF/Direwolf work OK with default alsa settings.  FLDigi requires a hotter signal to get clean audio (as listened to by another HF rig.  JS8Call and WSJTX have such low drive into the transmitter that you can barely hear the transmitted signal.  I would love to find someone with an IC-7000 and get their settings to try.

Thanks for your continued interest.
Dave



Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

 

Thanks Steve!

I’ve got one local but I’ll keep you as a backup

Bryan

On Jan 28, 2020, at 2:27 PM, Steve, N9VW <steve@...> wrote:

I have one that is currently sitting waiting for something to do...
Let me know, I can get it out in the morning.

Happy Trails,
Steve, N9VW

On 1/28/2020 2:03 PM, Bryan Hoyer wrote:
If I can borrow a 7000 I’m sure we can figure out what the issue is. We’ll pay freight both ways of course.

Also, are you connecting via the Data or Accessory Connector?

Anyone have a loaner?
Bryan K7UDR






Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

Steve, N9VW
 

I have one that is currently sitting waiting for something to do...
Let me know, I can get it out in the morning.

Happy Trails,
Steve, N9VW

On 1/28/2020 2:03 PM, Bryan Hoyer wrote:
If I can borrow a 7000 I’m sure we can figure out what the issue is. We’ll pay freight both ways of course.

Also, are you connecting via the Data or Accessory Connector?

Anyone have a loaner?
Bryan K7UDR




Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

 

If I can borrow a 7000 I’m sure we can figure out what the issue is. We’ll pay freight both ways of course.

Also, are you connecting via the Data or Accessory Connector?

Anyone have a loaner?
Bryan K7UDR


Re: Nixtracker

Basil Gunn
 

remark; updown_log.sh, line 8, log_updown.sh -> updown_log.sh I
believe.
Changed comment to be consistent with actual name of updown_log.sh
script.

question; same file, lines 14-18 give the crontab entries. I had to
add ‘root’ as user to those lines like the other lines in /etc/crontab
in order to get lvd shutdown working. I’ve seen this before when you
were teaching us how to use btest.sh and crontab to beacon. Again, no
‘root’ Or any user specified in the crontab lines you wrote. It makes
me wonder if I am messing with the wrong crontab file? Pardon my
ignorance.
The comment in updown_log.sh has a crontab example which points to the
/home/pi/tmp directory. This is wrong & only used for
development. Changed the example to use the local bin directory
/home/pi/bin and updated bin_refresh.sh script to include the tracker
updown_log.sh script.

See commit here:
https://github.com/nwdigitalradio/n7nix/commit/9d65bb812bb699df3627be01a52abe0ad953c09d

To update:

cd
cd n7nix
git pull
cd config
./bin_refresh.sh

You shouldn't have to be root to run the the updown_log.sh
script. ie. the crontab should be used by default user (pi).
You can test this out by running the beacmin.sh script and verify that
it doesn't return with an error. You are confirming that the 'beacon'
command does not need to be run as root.

cd
cd n7nix/debug
./beacmin.sh

I tested this on my bench & it looks ok. Later on this afternoon I will
pull the mSD card from my truck & verify.

/Basil


Re: Nixtracker

 

Basil, trivial remark and question:

remark; updown_log.sh, line 8, log_updown.sh -> updown_log.sh I believe.

question; same file, lines 14-18 give the crontab entries. I had to add ‘root’ as user to those lines like the other lines in /etc/crontab in order to get lvd shutdown working. I’ve seen this before when you were teaching us how to use btest.sh and crontab to beacon. Again, no ‘root’ Or any user specified in the crontab lines you wrote. It makes me wonder if I am messing with the wrong crontab file? Pardon my ignorance.

david


Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

Jack Spitznagel
 

Dave, Basil, All,

 

Apologies, I probably should have retitled this message to call out the problem with the IC-7000. I do not want to hi-jack the original thread, but it is worth continuing the HF element of it.

 

If you look back about a year ago in the archives, you’ll find that I reported exactly these “symptoms” with my IC-7000 using both of my DRAWS boards (one is an “early-early” adopter board, the other is an early adopter board). With both boards, my FT-817 works fine with HF programs. Both a RigBlaster and a SignaLink will drive the IC-7000 without these issues even though the settings are a little touchy because the audio drive level has to be turned way down.

 

I have copied Dave’s settings below because they agree with my findings. As Dave discovered, tremendous amount noise is introduced as the DRAWS output settings are reduced below about -20 db or so. I never was able to completely overcome the DRAWS HF audio drive level issues on the 7000. As Dave pointed out, fldigi can be forced to work with an ugly signal due to the inability to reduce ALC with the DRAWS board in its “clean” audio output range. And like Dave’s experience, the latest make of wsjt-x generates too low output so transmit does nothing. JS8CALL is a complete non-issue for me, I have no need for it and I have not played with winlink/paclink etc.

 

Just before I gave up, I tried using a multiturn pot as a simple attenuator and was “sort of” successful transmitting a clean signal with fldigi but never got around to making up a cable that had the right voltage divider built into it. That would not have solved the wsjt-x problem anyway.

 

Since the FM side works well, the 7000/DRAWS combo has become my 24/7 APRS transceiver – provides a “blackhole” fill-in xastir node service here in north central MD running xastir.  The FT-817/DRAWS combo is part of my “go kit”.

 

I believe Basil did experiment with his friends IC-7000, but if I recall correctly, only determined that the FM output could be made to work, but I can’t remember if he actually took a crack at the fldigi/wsjt-x over HF problem and was able to duplicate it. That was about the time I forced myself to stop fooling around with the DRAWS board because it was making me increasingly obsessive (like not getting real work done).

 

It would be great if these problems could be solved!

 

KD4IZ

Jack Spitznagel

FM19oo

 

 

3a.          Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

From: Dave Christensen

Date: Tue, 28 Jan 2020 03:36:02 UTC

I did read and apply the settings for the IC-7000.

******************************

<snip>

For FLDigi I have to change the ALSA settings from Analog = -3, Digital gain = -16 to 20 to Analog=-2.00 db and Digital = -8.00 db just to get clean audio.  Lower gain settings produces noise - no clean tone with FLDigi Tune turned on.  The signal is so hot that I can not get the ALC below full scale on the meter.   I lower the gain and the noise comes back  One interesting thing is that the sound card available for FLDigi selection is “udrc: bcm2835-i2s-tlv320aic32x4-hifi tlv320aicx4-hifi-0 (hw 1,0)”