Date   

Re: measure_deviate.sh not working on RPi4b

Basil Gunn
 

David, No problem. Always happy when I hear of a success. Also I will
fix the wiringpi version problem shortly. Thanks for that.
Seeing your beacons on aprs.fi from a few minutes ago.

2020-01-01 15:45:11 PST: KE7RGP-11>APUDR1,WIDE1-1,qAO,KE7RGP-1::KE7RGP :01 15:45:09 PST KE7RGP mesg_beacon test from host husky on port udr0 Seq: 1

/Basil

Never mind Basil, btest.sh and measure_deviation.sh are now both
working. Not sure what was going on awhile ago but I do need wiringpi
2.52 for the deviation script. Thanks and sorry for taking up your
time on the btest part of this.


Re: Update WSJTX #draws #wsjt-x

Basil Gunn
 

Showing console output always helps me understand the problem you may be
having.

cd
cd n7nix
git pull
cd hfprogs

# now run the hf version check program

./hf_verchk.sh

js8call: current version: 2.1.1, installed: 1.1.0
wsjtx: current version: 2.1.2, installed: 2.1.0
Library: libflxmlrpc IS loaded.
flxmlrpc: current version: 0.1.4, installed: 0.1.4
fldigi: current version: 4.1.08, installed: 4.1.08
flrig: current version: 1.3.48, installed: 1.3.48
flmsg: current version: 4.0.14, installed: 4.0.14
flamp: current version: 2.2.05, installed: 2.2.05
fllog: current version: 1.2.6, installed: NOT installed

# Now do the update
./hf_verchk.sh -u

# Run ./hf_verchk.sh again to verify

js8call: current version: 2.1.1, installed: 2.1.1
wsjtx: current version: 2.1.2, installed: 2.1.2
Library: libflxmlrpc IS loaded.
flxmlrpc: current version: 0.1.4, installed: 0.1.4
fldigi: current version: 4.1.08, installed: 4.1.08
flrig: current version: 1.3.48, installed: 1.3.48
flmsg: current version: 4.0.14, installed: 4.0.14
flamp: current version: 2.2.05, installed: 2.2.05
fllog: current version: 1.2.6, installed: 1.2.6

If wsjtx is still not updated I need to see all the console output from
the above.
/Basil

Justin Clark (KJ7JC) <jstnsclark@...> writes:

I have tried updating mu DRAWS but i still have WSJTX V2.1.0.

Any help on how i can update it to V2.1.2?


Re: measure_deviate.sh not working on RPi4b

 

Oh, ok, interesting on the three times suggestion.


Re: measure_deviate.sh not working on RPi4b

 

Yes, no movement on the Bird 43. Maybe there is an intermittent problem with the meter. I know there are other things to look at but that has been my go to.


Re: measure_deviate.sh not working on RPi4b

 

Never mind Basil, btest.sh and measure_deviation.sh are now both working. Not sure what was going on awhile ago but I do need wiringpi 2.52 for the deviation script. Thanks and sorry for taking up your time on the btest part of this.
David KE7RGP 


Re: measure_deviate.sh not working on RPi4b

Basil Gunn
 

Here are the steps that fix measure_deviate.sh but break btest.sh. I
went through a couple of cycles of turning ax25 on and off between
running the two scripts just to make sure.
Below is your btest.sh output which looks good. Can you be more specific
about what is broken? Are you not seeing your radio transmit? Also be
aware that when the AX.25 stack is first brought up the first 2 packets
transmitted are control packets and may not engage PTT. On start up
please run btest.sh at least 3 times before checking if your radio is
transmitting.

./btest.sh
*** Running as user: pi ***
Send a message beacon
Sent: /usr/local/sbin/beacon -c KE7RGP-11 -d 'APUDR1 via WIDE1-1' -l -s udr0 :KE7RGP :01 13:20:48 PST KE7RGP mesg_beacon test from host husky on port udr0 Seq: 0

Also I see your packets on aprs.fi and they look OK
https://aprs.fi/?c=raw&call=KE7RGP*&limit=50&view=normal

2020-01-01 13:26:46 PST: KE7RGP-11>APUDR1,WIDE1-1,qAR,KI7NLL::KE7RGP :01 13:26:44 PST KE7RGP mesg_beacon test from host husky on port udr0 Seq: 0%

/Basil n7nix


Update WSJTX #draws #wsjt-x

Justin Clark (KJ7JC)
 

I have tried updating mu DRAWS but i still have WSJTX V2.1.0.

Any help on how i can update it to V2.1.2?


Re: measure_deviate.sh not working on RPi4b

 

Here are the steps that fix measure_deviate.sh but break btest.sh. I went through a couple of cycles of turning ax25 on and off between running the two scripts just to make sure.

David KE7RGP


Re: measure_deviate.sh not working on RPi4b

Basil Gunn
 

On the Pi4b, the piwiz updater keeps giving an error, says a file is
“not (yet) available”. Seems a common problem and to try again. I got
tired of re-imaging the sd card and found these instructions to update
when encountering this problem:
I'll look into this. I usually run my RPis headless so don't run piwiz
updater. The configuration scripts I wrote do everything that piwiz
does.

This appears to work, or at least gives 20 minutes of verbosity.
Yes it's time to update the image so that doesn't happen.

measure_deviate does not work. I confirmed that gpio 12 (nor gpio 25)
gpio 23 not gpio 25

will go high. I’ve also tried manually setting the pins. All this
works with the Pi3 but not the Pi4b.
This is due to measure_deviate getting wiringpi from the Debian
repository instead of the authors personal repo. I'll fix that.

Looking at the WiringPi blog, they claim version 2.52 is needed and I
follow their wget instructions to load this version. This fixes
measure_deviate.sh but then btest.sh stops working.
Let me look at the console output when 'btest.sh stops working'
btest.sh doesn't use WiringPi so this is confusing. Make sure you are
starting ax25 back up (ax25-start) after using measure_deviate.
/Basil n7nix


Re: Problems with Winlink handshaking on VHF and no power to transmitter on HF

Basil Gunn
 

Two problems:
with ax25 started I do a wl2kax25 - k2wvc-10 (a gateway on 2
met4ers). It connects but hangs after a Challenge is
received. Eventually it times out with jibberish and disconnects
Check /usr/local/etc/wl2k.conf
wl2k-password=
The winlink password you are using is invalid.

THE SECOND PROBLEM AS TO DO WITH NO HF AUDIO (AX25 STOPPED) on FLdigi,
JS8Call, etc. I can key the rig using FLdigi directed by the apps but
I am not generating any power. I ran measure_deviate.sh and it keys
the rig AND gives me 30 Watts out which is what I expect. I am using
the Left audio jack for both packet and HF - at lease that is what the
radio is connected to (IC-7000).
For FLDigi read this:
https://nw-digital-radio.groups.io/g/udrc/wiki/UDRC%E2%84%A2-and-fldigi-Setup-Page#Startup-and-set-levels-in-fldigi

The "Power" control in both apps is at the maximum. Below is a screen shot of WSJTX configs:

pi@kd7um-t2:~/bin $ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: udrc [udrc], device 0: bcm2835-i2s-tlv320aic32x4-hifi tlv320aic32x4-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0
pi@kd7um-t2:~/bin $

also touching any config parameter cause WSJTX to blow up and quit. I
am running WSJTX Version 2.1.0
Try running the latest version: 2.1.2

What am I missing? The apps both are hearing stations and they show up
in the app display so hearing works and talking (on HF) doesn't Thanks


measure_deviate.sh not working on RPi4b

 

I’m looking for guidance in setting up my RPi4b with my new DRAWS Hat. My low brow solution to the following was to buy an RPi3.


On the Pi4b, the piwiz updater keeps giving an error, says a file is “not (yet) available”. Seems a common problem and to try again. I got tired of re-imaging the sd card and found these instructions to update when encountering this problem:


sudo apt update

sudo apt full-upgrade

sudo reboot


This appears to work, or at least gives 20 minutes of verbosity.


Then git pull on n7nix dir.


Then configure core functionality.


ax25 and Direwolf work fine. btest.sh works.


measure_deviate does not work. I confirmed that gpio 12 (nor gpio 25) will go high. I’ve also tried manually setting the pins. All this works with the Pi3 but not the Pi4b.


Looking at the WiringPi blog, they claim version 2.52 is needed and I follow their wget instructions to load this version. This fixes measure_deviate.sh but then btest.sh stops working. I am duly shutting ax-25 on and off.


measure_deviate.sh loads wiringpi 2.50 and “gpio readall” returns “no board found”.


The attached console output of “showudrc.sh”, “gpio –v” and “gpio readall” is from a fresh install of nwdr14, attempted piwiz update, apt update as above, git pull on n7nix, wiringpi NOT updated to 2.52. This configuration will not set the pins high. Radio is tm-v71a in 9600 mode with the appropriate setalsa run.


Thanks, and most importantly, Happy New Year.

David KE7RGP


Problems with Winlink handshaking on VHF and no power to transmitter on HF

Dave Christensen
 

Two problems:
with ax25 started I do a wl2kax25 - k2wvc-10  (a gateway on 2 met4ers).  It connects but hangs after a Challenge is received.  Eventually it times out with jibberish and disconnects
Console output follows:
pi@kd7um-t2:~ $ wl2kax25 -c k2wvc-10
Connected to AX.25 stack
Child process
wl2kax25: ---
wl2kax25: <Trying ec2-52-72-230-141.compute-1.amazonaws.com
wl2kax25: <*** KD7UM Connected to CMS
wl2kax25: <[WL2K-5.0-B2FWIHJM$]
wl2kax25: sid [WL2K-5.0-B2FWIHJM$] inboundsidcodes -B2FWIHJM$
wl2kax25: <;PQ: 35237853
wl2kax25: Challenge received: 35237853
Timed out, exiting wl2kax25!
   $ v(
        vGf    9 ~  v i vG   v $ v 9 ~ 9 ~#u  9 ~   v  vf    }    v i v 9 ~pI vEOF on child fd, terminating communications loop.
Closing ax25 connection
Child exit status: 1
Waiting for AX25 peer ... timeout
pi@kd7um-t2:~ $
--------------------------------------------------------------
THE SECOND PROBLEM AS TO DO WITH NO HF AUDIO (AX25 STOPPED) on FLdigi, JS8Call, etc.
I can key the rig using FLdigi directed by the apps but I am not generating any power.  I ran measure_deviate.sh and it keys the rig AND gives me 30 Watts out which is what I expect.  I am using the Left audio jack for both packet and HF - at lease that is what the radio is connected to (IC-7000).
The "Power" control in both apps is at the maximum. Below is a screen shot of WSJTX configs:
 

pi@kd7um-t2:~/bin $ arecord -l
**** List of CAPTURE Hardware Devices ****
card 1: udrc [udrc], device 0: bcm2835-i2s-tlv320aic32x4-hifi tlv320aic32x4-hifi-0 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
pi@kd7um-t2:~/bin $

also touching any config parameter cause WSJTX to blow up and quit.  I am running WSJTX Version 2.1.0

What am I missing?  The apps both are hearing stations and they show up in the app display so hearing works and talking (on HF) doesn't
Thanks
 


Re: AX25 over UDP is not working on #nw14

Basil Gunn
 

WARNING installing new AX.25 packages will over write all config files in
/usr/local/etc/ax25 directory. To be safe back-up all the .conf files in
that directory before running.
/Basil n7nix

I've checked in a script, ax_verchk.sh, that works similarly to how the
hf_verchk.sh script works for updating HF programs.

The ax_verchk.sh script checks the version numbers for ax25
lib/apps/tools in Lee Woldanski's ve7fet github repo and compares them
to Debian packages I built that live in the n7nix repo. After verifying
that the n7nix packages are current it then checks the installed
versions of these packages to determine if a new package install is
required.

# Display help info

~/n7nix/ax25 $ ./ax_verchk.sh -h
Usage: [-u][-h]
No arguments displays current & installed versions.
-u Set application update flag. Intall packages
-h display this message.

# Display version numbers from ve7fet repo, n7nix repo &
# currently installed packages

~/n7nix/ax25 $ ./ax_verchk.sh
fet repo: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
nix repo: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
install: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
AX.25 packages are up-to-date.

# Do an AX.25 lib/apps/tools update

~/n7nix/ax25 $ ./ax_verchk.sh -u
Update AX.25 packages after checking version numbers.

fet repo: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
nix repo: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
install: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
AX.25 packages are up-to-date.

# First refresh your local copy of the n7nix repo
cd
cd n7nix
git pull

# Now run the ax_verchk.sh script
cd ax25
./ax_verchk.sh

/Basil n7nix

Bernard Pidoux <bernard.f6bvp@...> writes:


If you need a beta tester in order to check AX.25 for nwdr15.img image,
I volunteer to help.

Bernard, f6bvp

Le 29/12/2019 à 18:12, Basil Gunn a écrit:
Thus I want to encourage the NWDigital radio team to update the AX.25 stuff that may be wrongly installed or outdated.
Notice : I am using VE7FET repository.
Thanks Bernard. Will do.
That is the repository I use as well.
/Basil n7nix


Re: AX25 over UDP is not working on #nw14

Basil Gunn
 

Bernard,

I've checked in a script, ax_verchk.sh, that works similarly to how the
hf_verchk.sh script works for updating HF programs.

The ax_verchk.sh script checks the version numbers for ax25
lib/apps/tools in Lee Woldanski's ve7fet github repo and compares them
to Debian packages I built that live in the n7nix repo. After verifying
that the n7nix packages are current it then checks the installed
versions of these packages to determine if a new package install is
required.

# Display help info

~/n7nix/ax25 $ ./ax_verchk.sh -h
Usage: [-u][-h]
No arguments displays current & installed versions.
-u Set application update flag. Intall packages
-h display this message.

# Display version numbers from ve7fet repo, n7nix repo &
# currently installed packages

~/n7nix/ax25 $ ./ax_verchk.sh
fet repo: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
nix repo: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
install: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
AX.25 packages are up-to-date.

# Do an AX.25 lib/apps/tools update

~/n7nix/ax25 $ ./ax_verchk.sh -u
Update AX.25 packages after checking version numbers.

fet repo: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
nix repo: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
install: lib: 1.1.3, app: 2.0.1, tool: 1.0.5
AX.25 packages are up-to-date.

# First refresh your local copy of the n7nix repo
cd
cd n7nix
git pull

# Now run the ax_verchk.sh script
cd ax25
./ax_verchk.sh

/Basil n7nix

Bernard Pidoux <bernard.f6bvp@...> writes:

If you need a beta tester in order to check AX.25 for nwdr15.img image,
I volunteer to help.

Bernard, f6bvp

Le 29/12/2019 à 18:12, Basil Gunn a écrit:
Thus I want to encourage the NWDigital radio team to update the AX.25 stuff that may be wrongly installed or outdated.
Notice : I am using VE7FET repository.
Thanks Bernard. Will do.
That is the repository I use as well.
/Basil n7nix


Re: DRAWS and HF RMS GAteway possible ?

Basil Gunn
 

Thank you Bob NW8L for posting on the udrc forum!

Bob is the author of ARIM, Amateur Radio Instant Messaging,
(https://www.whitemesa.net/arim/arim.html) which works with ardop
(ie. piardopc & piardop2 on the RPi) ... and is a very nice piece of
work.

For me, at least, Bob NW8L & John G8BPQ are hero's of digital HAM radio
because they make their source code available!!

ardopc on github
https://github.com/DigitalHERMES/ardopc

Directory of John G8BPQ's downloads
http://www.cantab.net/users/john.wiseman/Downloads/

ARIM source code tarball
https://www.whitemesa.net/arim/src/arim-2.8.tar.gz

I suppose I'm a hero want-to-be because most code I have written in the
last decade is in a public repository ie. the source code is available.

With regards to Windows you can use an RPi & a DRAWS card by specifying
on your Windows machine either AGWPE or TCP/IP KISS to access the RPi
running direwolf. See the excellent Direwolf User Guide, thank you John
WB2OSZ.
https://raw.githubusercontent.com/wb2osz/direwolf/master/doc/User-Guide.pdf

You could also use the RPi & draws card as an ARDOP TNC & access it from
your windows machine with an IP address & socket port number.

As far as Windows goes I do not use it much (but I do use it). It's just
not that much fun to use. In terms of dollars/fun ratio you can not beat
a Raspberry Pi. I do not have a requirement of running Winlink Winmor
or Vara but I do have a requirement of running HAM digital mode
infrastructure that runs 24/7 on 12V. Easy and inexpensive to do with an
RPi & DRAWS HAT harder & more expensive to do with a Windows machine.

Anyway HAM radio is a hobby you should have fun playing with it and
Happy New Year to all the HAMS that read this forum.

73
/Basil n7nix


Bob NW8L <nw8l@...> writes:

ardop is not open source, but it is free and can run on virtually any OS.
Actually, ardop *is* open source. For Windows:

https://ardop.groups.io/g/developers/files/ARDOP_Win%20VBSource%20Rev1.0.4.zip

For Linux inc. Raspbian:

http://www.cantab.net/users/john.wiseman/Downloads/Beta/TeensyProjects.zip

This includes ARDOPC and ARDOP2 source. I build ardopc here from source for my 64-bit Linux machines.

73,
Bob NW8L


Re: DRAWS and HF RMS GAteway possible ?

Roland
 

I want to build an easy solution for VARA.WINMOR and ARDOP.
Only one PC and one TRX. Therefore I am going with a windows based mini PC for less than 200USD.  Power consumption is max. 6W not an issue at all.
Then I am going to install either RMS Trimode or BPQ32.  Thats the plan so far.


Re: DRAWS and HF RMS GAteway possible ?

Ryan Matthew Headley
 

Thank you for the information.  I have only ever encountered an executable package.


Re: DRAWS and HF RMS GAteway possible ?

Bob NW8L
 

>ardop is not open source, but it is free and can run on virtually any OS. 

Actually, ardop *is* open source. For Windows:

https://ardop.groups.io/g/developers/files/ARDOP_Win%20VBSource%20Rev1.0.4.zip

For Linux inc. Raspbian:

http://www.cantab.net/users/john.wiseman/Downloads/Beta/TeensyProjects.zip

This includes ARDOPC and ARDOP2 source. I build ardopc here from source for my 64-bit Linux machines.

73,
Bob NW8L


Re: DRAWS and HF RMS GAteway possible ?

Ryan Matthew Headley
 

It depends upon your goals.  A Windows machine is many times more expensive, and the power requirements are many times greater.  You also cannot leave a Windows machine running for months on end with no interaction and expect it to behave properly.

I should also mention that linBPQ running on a Raspberry Pi could access the ardop modem locally, and access Winmore and VARA modems hosted on a Windows machine on your local network.  That way if the Windows machine went down or you were unable to run it due to power requirements, your could still keep the ardop gateway up and running. 


Re: DRAWS and HF RMS GAteway possible ?

Roland
 

Going the Windows route for now.