Date   

Re: #claws-mail ICS Forms #claws-mail

Basil Gunn
 

I'm trying to understand your problem.
If you need the latest Winlink ICS standard forms just download and use
them.
https://downloads.winlink.org/User%20Programs/Standard_Forms.zip

flmsg allows you to act on the forms. Now using your paclink-unix or pat
mail client, attach the form to your Winlink message and send the
message.

What we found was that the various state agencies used different forms
so we needed to use those forms.

Your statement that you need to run Winlink Express to use ICS forms is
not true. Winlink has done a nice job of integrating forms into Winlink
Express so as Scott K4KDR points out the method you would use on your
Linux system is not as turn key as the Winlink Express program but still
doable.

/Basil n7nix


Ryan Matthew Headley <headley.ryan@...> writes:

I am trying to find a solution to this as well. I have been messing
with the html files that can be downloaded from winlink.org with no
results.

I also thought that flmesg could be a solution. It does indeed work,
but the fields in the form are old and are no longer acceptable under
ICS operations in my state (or probably any state).

Unfortunately--while pat and paclink-unix work for person to person
communication--if you are part of any official support effort you will
still need a Windows computer running Winlink Express in order to do
your job.


Re: #claws-mail ICS Forms #claws-mail

Mitch Winkle
 

I can certainly add the current ICS-213 to my UI client for PAT. Are you simply using the numbered format for the OTA transmission?

1.
2. etc.

On 11/22/19 10:51 AM, K4KDR wrote:
Good day!

Just to show myself that it could be done, I successfully sent an ICS-213 using PAT on the Rasp Pi/DRAWS.

Here is my write up on the manual steps I did to make it happen.  Not difficult at all but someone could certainly automate the process to reduce the amount of editing by hand for a new message.

http://k4kdr.github.io/pdf/2019-10-17--ics-forms-from-pat.pdf

73!

-Scott,  K4KDR


Re: #claws-mail ICS Forms #claws-mail

Ryan Matthew Headley
 

This a great proof of concept, and it does work; but not really ready for prime-time.  I hate having to carry a Windows laptop just for ICS forms.


Re: #claws-mail ICS Forms #claws-mail

K4KDR
 

Good day!

Just to show myself that it could be done, I successfully sent an ICS-213 using PAT on the Rasp Pi/DRAWS.

Here is my write up on the manual steps I did to make it happen.  Not difficult at all but someone could certainly automate the process to reduce the amount of editing by hand for a new message.


73!

-Scott,  K4KDR

============================


On Fri, Nov 22, 2019 at 10:01 AM Ryan Matthew Headley <headley.ryan@...> wrote:
I am trying to find a solution to this as well.  I have been messing with the html files that can be downloaded from winlink.org with no results.

I also thought that flmesg could be a solution.  It does indeed work, but the fields in the form are old and are no longer acceptable under ICS operations in my state (or probably any state). 

Unfortunately--while pat and paclink-unix work for person to person communication--if you are part of any official support effort you will still need a Windows computer running Winlink Express in order to do your job.


Re: #claws-mail ICS Forms #claws-mail

Ryan Matthew Headley
 

I am trying to find a solution to this as well.  I have been messing with the html files that can be downloaded from winlink.org with no results.

I also thought that flmesg could be a solution.  It does indeed work, but the fields in the form are old and are no longer acceptable under ICS operations in my state (or probably any state). 

Unfortunately--while pat and paclink-unix work for person to person communication--if you are part of any official support effort you will still need a Windows computer running Winlink Express in order to do your job.


Re: #draws #audio #ax25 #draws #audio #ax25

Basil Gunn
 

Apologies ahead of time if I am rehashing anything already extant on
the boards. I have attempted to search for solutions, but have not
been able to find anything.
Search forum: https://nw-digital-radio.groups.io/g/udrc/topics
Check Wiki: https://nw-digital-radio.groups.io/g/udrc/wiki/home
Check docs: https://github.com/nwdigitalradio/n7nix/tree/master/docs

I received my DRAWS hat yesterday, loaded the DRAWS image, and
followed the configuration steps listed on the boards. Most things
worked exactly as indicated.

In testing to set levels, I set up an Alinco 135 connected to the
DRAWS, and a Yaesu FT-991A for monitoring--both on 144.390Mhz. I had
to set the output gain to +15db before it was even audible--and +29db
is decodable, but still well below the other AX25 signals I was
receiving from elsewhere. I switched the radios with virtually the
same result. I cannot imagine that this is normal.
I have an Alinco DR-235 mkIII and found these settings to work:
https://github.com/nwdigitalradio/n7nix/tree/master/deviation#notes-alinco-dr-x35-mk-iii

Calculate the proper settings to use:
If you are using the NW Digital Radio image & are using a monitor

open a browser
url: localhost:8080
Click: Toggle TX calculator.


Re: Just starting out #draws

Ryan Matthew Headley
 

This is the image you should use if you need and X server:

https://downloads.raspberrypi.org/raspbian_latest

If you can get by without a desktop, this install is a little over half the size of the above version with the X server.

https://downloads.raspberrypi.org/raspbian_lite_latest

Either way, make sure that you make the changes to /boot/config.txt to enable to DRAWS hat.

When you go to configure your specific software packages, the DRAWS board shows up as the ALSA device 'UDRC.'


Re: Just starting out #draws

Paul Noa
 

Ryan,

Thanks for that advice, I was hoping there would be a minimal configuration as well, so this sounds good.

To clarify, so there is no need to download the latest image from NWDR/support, correct?

Could you be more specific on the Raspian with Desktop? I already have an image with a Debian blend, the option not in NOOBS but from RPI.org.

Thanks fro your support in advance,

Paul


Re: Just starting out #draws

Ryan Matthew Headley
 

If your only application will be as you describe, I would suggest foregoing the DRAWS image.

Download Raspbian with Desktop (NOT the one with 'recommeded software'); install gpsd, direwolf, and FoxtrotGPS; and you are good to go without a lot of complication.

Be sure to make the changes in /boot/config.txt to enable the DRAWS hat described at the bottom of the 'Getting Started' page.

This may not be what you are looking for, but this is what I would do with for such a straightforward single application.


#draws #audio #ax25 #draws #audio #ax25

Ryan Matthew Headley
 

Apologies ahead of time if I am rehashing anything already extant on the boards.  I have attempted to search for solutions, but have not been able to find anything.

I received my DRAWS hat yesterday, loaded the DRAWS image, and followed the configuration steps listed on the boards.  Most things worked exactly as indicated. 

Using the scripts indicated in 'Getting Started,' I configured AX25 and got ALSA working, but with a few curiosities.  Mysteriously, the default configuration sets AX25 to use the right connector.  (That one took a few minutes to figure out).  ALSA audio was is curious as well. 

In testing to set levels, I set up an Alinco 135 connected to the DRAWS, and a Yaesu FT-991A for monitoring--both on 144.390Mhz.  I had to set the output gain to +15db before it was even audible--and +29db is decodable, but still well below the other AX25 signals I was receiving from elsewhere.  I switched the radios with virtually the same result.  I cannot imagine that this is normal. 

I am probably going to set up my own imagine later today for further testing.

Any thoughts?


Re: Stream Audio Using VNC Command Line to Local Network #audio

Paul Noa
 

Basil,
I am reaching out for a little direction getting started with my Draws (Hat Only) install on RPi 3 B+ as I see you are very active and obviously much more knowledgeable than myself in this area.

The more I  read the more unsure I become as where to start. This is where I have started :
Could you be so kind as to direct me to the best most reliable version of Buster w/NWDR code for the Draws hat if this is not the best place to start?

Thanks in advance for your support,

Paul

Paul 


On Sat, 16 Nov 2019 at 11:05, Basil Gunn <basil@...> wrote:

Where in the command that you gave is the syntax for the USB device you
are using? dsnoop:1 ?

If I use cvlc --longhelp it lists alsa audio devices so I'm guessing you
would replace dsnoop:1 with dsnoop:CARD=udrc

cvlc --longhelp | grep -i alsa-audio-device
VLC media player 3.0.7 Vetinari (revision 3.0.7-0-g86cee31099)
      --alsa-audio-device {null,default:CARD=ALSA,sysdefault:CARD=ALSA,dmix:CARD=ALSA,DEV=0,dmix:CARD=ALSA,DEV=1,dsnoop:CARD=ALSA,DEV=0,dsnoop:CARD=ALSA,DEV=1,hw:CARD=ALSA,DEV=0,hw:CARD=ALSA,DEV=1,plughw:CARD=ALSA,DEV=0,plughw:CARD=ALSA,DEV=1,default:CARD=udrc,sysdefault:CARD=udrc,dmix:CARD=udrc,DEV=0,dsnoop:CARD=udrc,DEV=0,hw:CARD=udrc,DEV=0,plughw:CARD=udrc,DEV=0,default}

/Basil

Anthony Sutera <tsutera@...> writes:

> I am using my Draws Hat mainly for WSJT-X. I have a quick question: I
> would like to stream audio to my local network. On my other setups
> (Raspberry Pi3) using a signal link USB audio card, I succesfully use
> this command:

cvlc -vvv alsa://dsnoop:1 --sout '#transcode{acodec=mp3,ab=64,channels=1}:standard{access=http,dst=192.168.165.126/out.mp3}'

> to stream audio out to my local network. Can someone let me know the
> correct audio device to list in the command line using the Draws Hat
> sound card? Thank you! Tony Sutera KF7VLT




Just starting out #draws

Paul Noa
 

I just received my new draws unit (Hat Only).

I am using Pi 3B+.  I have reviewed as much online documentation I can find but not sure which is the latest, did not expect a beta version on the support page...

I am not sure if I have installed the proper/best version of software and would like not to go to far down the wrong path if possible.

My application is simple and limited to one goal: track multiple assets using FoxtrotGPS with DireWolf using a single radio.

Any help getting me started sorting all of the options would be greatly appreciated. perhaps simply a confirmation the support page downloads are the latest and most reliable.

Paul


Re: PAT with DRAWS on VHF

Dave Christensen
 

Thank you again for your time.  with your explanation I now understand the relationship of axports, mkiss, and the PAT config.  I did run the config script you provided 
----------------------------------------------------------------------------------
This is my edited PAT ax25 section now using the correct port name:

},
  "listen": [],
  "hamlib_rigs": {},
  "ax25": {
    "port": "udr0",
    "beacon": {
      "every": 3600,
      "message": "Winlink P2P",
      "destination": "IDENT"
    },
    "rig": ""
  },
------------------------------------------------------------
And my axports with the line I added removed referencing wl2k

It looks like this now:
# /usr/local/etc/ax25/axports
#
# The format of this file is:
#portname       callsign        speed   paclen  window  description
udr0        KD7UM-6         9600    255     2       Direwolf port
udr1        KD7UM-10            9600    255     2       Winlink port
---------------------------------------------------------------------------------------------
Now I am trying to find the whole paclink-unix installation instructions, MUTT interface, piardop, etc.  I know it is out there, I just haven't found it since you referenced adding piardop to the distribution 9 going forward with your work on Packlink-UNIX.

Another day....  TNX


Re: PAT with DRAWS on VHF

Basil Gunn
 

The packet configuration for a DRAWS hat enables both mDin6 connectors
as ports udr0 & udr1. If you follow the documentation & use the
configuration scripts these ports are started at boot time using systemd
unit files that use mkiss (instead of kissattach) for multi KISS attach
so that both ports are active & available.

Since you had to edit the axports file I'm guessing you did not use the
configuration script that is supplied in the n7nix directory on the
DRAWS image.

Very pleased that you have PAT working with your DRAWS hat.
/Basil


Dave Christensen <dkc2030@...> writes:

Basil, et.al

All the tests you mentioned above were all working normally from the image installation. Thank you again for detailing these, I have save this post for future checkouts.

To make a really long story short here is what fixed PAT running on the NW image:
1. Added a line to the /etc/ax25/axports file in the format: wl2k KD7UM 1200 255 7 Winlink
2. Did a sudo kissattach /tmp/kisstnc wl2k

It all worked. Now two things for me to do: create a script when starting PAT to do the kissattach and then the pat http command.

This help came from Scott:
"I believe this is the video that I used to get setup for PAT over ax25:

https://www.youtube.com/watch?v=o8OBF47UkeI&t=509s

-Scott, K4KDR"

Having said all this, and given my Newbie status, I am going to
investigate patlink-unix knowing now that this is the supported
product.

Again, thank you and all the moderators and contributors for your
time.


Re: PAT with DRAWS on VHF

Dave Christensen
 

Scott, et. al

To make a really long story short here is what fixed PAT running on the NW image:
1.  Added a line to the /etc/ax25/axports file in the format:  wl2k KD7UM 1200 255 7 Winlink
2.  Did a sudo kissattach /tmp/kisstnc wl2k

It all worked.  Now two things for me to do:  create a script when starting PAT to do the kissattach and then the pat http command.
 

Having said all this, and given my Newbie status, I am going to investigate patlink-unix knowing now that this is the supported product.

Again, thank you and all the moderators and contributors for your time.


Re: PAT with DRAWS on VHF

Dave Christensen
 

Basil, et.al

All the tests you mentioned above were all working normally from the image installation.  Thank you again for detailing these, I have save this post for future checkouts.

To make a really long story short here is what fixed PAT running on the NW image:
1.  Added a line to the /etc/ax25/axports file in the format:  wl2k KD7UM 1200 255 7 Winlink
2.  Did a sudo kissattach /tmp/kisstnc wl2k

It all worked.  Now two things for me to do:  create a script when starting PAT to do the kissattach and then the pat http command.

This help came from Scott:
"I believe this is the video that I used to get setup for PAT over ax25:
 
 
-Scott,  K4KDR"

Having said all this, and given my Newbie status, I am going to investigate patlink-unix knowing now that this is the supported product.

Again, thank you and all the moderators and contributors for your time.

 


Re: PAT with DRAWS on VHF

Basil Gunn
 

I can not find the PAT CONFIGURE setup for ax25 VHF ports.
Because I don't support PAT. I support paclink-unix.

I had ax25
started and when I attempted a packet connection the error message
said that a ax25 port was not found.
Without showing me (cutting & pasting into post or email) the console
output of the error message I can't really comment.

Verify that ax.25 is running properly by running:
ax25-status
and
ax25-status -d

It would be helpful if you could post the console outputs of the above
commands as well.

Read this:
https://github.com/nwdigitalradio/n7nix/blob/master/docs/VERIFY_CONFIG.md#testing-ax25

What do I need to change in the
config.json file to create a VHF port on PAT? There are lots of videos
and post for ARDOP configuration but these won't help.


Re: PAT with DRAWS on VHF

K4KDR
 

Hi Dave!

I believe this is the video that I used to get setup for PAT over ax25:


-Scott,  K4KDR

========================


On Sat, Nov 16, 2019 at 12:47 PM Dave Christensen <dkc2030@...> wrote:
I can not find the PAT CONFIGURE setup for ax25 VHF ports.  I had ax25 started and when I attempted a packet connection the error message said that a ax25 port was not found.  What do I need to change in the config.json file to create a VHF port on PAT?  There are lots of videos and post for ARDOP configuration but these won't help.

Thanks in advance...

Dave - KD7UM


PAT with DRAWS on VHF

Dave Christensen
 

I can not find the PAT CONFIGURE setup for ax25 VHF ports.  I had ax25 started and when I attempted a packet connection the error message said that a ax25 port was not found.  What do I need to change in the config.json file to create a VHF port on PAT?  There are lots of videos and post for ARDOP configuration but these won't help.

Thanks in advance...

Dave - KD7UM


Re: Stream Audio Using VNC Command Line to Local Network #audio

Basil Gunn
 

Where in the command that you gave is the syntax for the USB device you
are using? dsnoop:1 ?

If I use cvlc --longhelp it lists alsa audio devices so I'm guessing you
would replace dsnoop:1 with dsnoop:CARD=udrc

cvlc --longhelp | grep -i alsa-audio-device
VLC media player 3.0.7 Vetinari (revision 3.0.7-0-g86cee31099)
--alsa-audio-device {null,default:CARD=ALSA,sysdefault:CARD=ALSA,dmix:CARD=ALSA,DEV=0,dmix:CARD=ALSA,DEV=1,dsnoop:CARD=ALSA,DEV=0,dsnoop:CARD=ALSA,DEV=1,hw:CARD=ALSA,DEV=0,hw:CARD=ALSA,DEV=1,plughw:CARD=ALSA,DEV=0,plughw:CARD=ALSA,DEV=1,default:CARD=udrc,sysdefault:CARD=udrc,dmix:CARD=udrc,DEV=0,dsnoop:CARD=udrc,DEV=0,hw:CARD=udrc,DEV=0,plughw:CARD=udrc,DEV=0,default}

/Basil

Anthony Sutera <tsutera@...> writes:

I am using my Draws Hat mainly for WSJT-X. I have a quick question: I
would like to stream audio to my local network. On my other setups
(Raspberry Pi3) using a signal link USB audio card, I succesfully use
this command:
cvlc -vvv alsa://dsnoop:1 --sout '#transcode{acodec=mp3,ab=64,channels=1}:standard{access=http,dst=192.168.165.126/out.mp3}'

to stream audio out to my local network. Can someone let me know the
correct audio device to list in the command line using the Draws Hat
sound card? Thank you! Tony Sutera KF7VLT